No Power Lights for WRT54G v1.0

Discussion in 'Cisco/Linksys Wireless Routers' started by t-birk, Aug 30, 2006.

  1. t-birk

    t-birk Guest

    I have a v1.0 WRT54G that appears to be dead (bricked...). No LEDs light upon plugin. I've tried the 30 second reset and have attempted the pin shorting, but no luck in revival. I've put the volt meter to the power pack and it comes out with 5v, as indicated what it is supposed to be on its sticker. I've gone so far as to verify that 5v does make it to the system board, but I've since I'm not real familiar with electronics, I'm not sure where else to verify other than at the plug-in connector.

    I've searched the forums for similiar issues, but I haven't come across this particular issue (with seemingly no power to the system). Has anyone come across this and/or can point me in the right direction in possibly reviving this system? I was thinking of trying a different power adapter, but I can't find a 5v adapter right now. I find it hard to believe that it's the adapter at fault since my volt meter is showing 5v, but it wouldn't suprise me that a replacement would be a fix.

    Thank you kindly!

    - t-birk
  2. Guyfromhe

    Guyfromhe Network Guru Member

    This is a long shot, but it's worked for me on 2 or 3 switches and a couple linksys routers...
    The power brick seems to be working but no power lights or anything. I found an adapter that was a couple volts higher 9-12v and plugged it in (or take a multi voltage power adapter and turn it up slowly) and it seems to start working good as new again...
    Give it a shot, you can't make it any worse.
  3. BillDog103

    BillDog103 Guest

    No Power On WRT54g

    I had the same problem... I just replaced the AC Adapter with another 5 volt and it powered up.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice