No Signal on an WRT54G

Discussion in 'Cisco/Linksys Wireless Routers' started by sockhead, Nov 2, 2006.

  1. sockhead

    sockhead LI Guru Member

    Hi, my router was working perfectly fine when suddenly my connection went dead, and my pc was no longer able to even detect my wlan. I tried resetting my router, and it helped somewhat (wlan is detected by PC), but thoroughput is very slow and eventually that connection drops too. The distance between my pc and my router hasn't changed either.

    I connected another PC to the router directly, and that worked fine. Any ideas why this is happening? At the moment, my PC is not detecting my WLAN at all.
  2. rakeshjmd

    rakeshjmd LI Guru Member

    please reset router for 30 seconds & try to upgrade firmware of the router
  3. sockhead

    sockhead LI Guru Member

    i changed the firmware, and power cycled the router

    i still get random disconnects, and inability to see the router
  4. sockhead

    sockhead LI Guru Member

    here's some new info: i am able to access the router normally wirelessly, but as soon as i try to set a wep password the connection drops and no network is detectable

    even if i change the setting back to open, i still can't find any networks until i reset the router
  5. sockhead

    sockhead LI Guru Member

    now i am running with open security, nothing changed on my router (except with my dsl logon info), and am connected at 2 mbps

    any advice guys?
  6. HennieM

    HennieM Network Guru Member

    Not that it WILL help necessarily, but a suggestion:

    Power cycling the router is not resetting the router. Press the reset button at the back of the router for 30 seconds, which will reset the router to factory defaults.

    Once this is done, re-load the latest firmware (to make sure that it "goes in" with the router at defaults), and then re-specify your configuration. DON'T restore a saved configuration, as this may re-introduce whatever the problem was before.

    Also, delete any defined wireless networks in your wireless adapter's properties, and resetup your config on the PC to match the router.
  7. sockhead

    sockhead LI Guru Member

    Yeah, I tried holding down the reset button (to restore factory defaults), and in the end I end up with the same problem.

    I would restore defaults, then enter my DSL info, then enter my wireless SSID... I would leave it at that and then it would randomly lose connection. Also, in order to get back my connection in the first place I gotta hard reset it a few times.
  8. sockhead

    sockhead LI Guru Member

    my problem is definitely not setting related, i can set defaults in the firmware and the wireless network is still not detected
  9. sockhead

    sockhead LI Guru Member

    i managed to get connected again wirelessly, running 1Mbps

    the weird thing is that I'm getting a "Very Good" or "Excellent" signal

    the router is also set to G mode only
  10. sockhead

    sockhead LI Guru Member

    one last thing:

    the low thoroughput has nothing to do with range, i used to get a solid 54Mbps (according to windows at least) connection, and the computer is right next to the router
  11. HennieM

    HennieM Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice