No valid arpreplies .... HELP

Discussion in 'DD-WRT Firmware' started by MBChris, Aug 11, 2005.

  1. MBChris

    MBChris Network Guru Member

    Hello all,

    yesterday i got a great problem. After "cold"-Rebooting our Border-Router (DD-WRT V23) , which is providing DHCP for the whole net (Leasetime 24 hours), the DHCP-Service is broken and i dont know why :( Here are the problems i discovered this night:

    A client (WRT) requests an adress:

    Syslog tells me:
    request from ......
    broadcasting _IP_ to mac:mac:mac.....
    (sofar ok i think)

    at this time i see an entry in the DHCP-Leasetable which is the IP-Adress, the MAC and the time (60 seconds), but without Name in front

    after awhile (30-60 seconds) Syslog tells me "No valid arpreplies for _IP_/_MAC_" and the DHCP deletes the lease.

    Now we have alot of DHCP-Requests in the net, Some Clients getting there IP successfully, but only 1 of 100 requests is successfull :(

    Anyone a hint ?

    PS: YES, i know, i should define fixed IPs for the Client-WRTs .... but ... at this time all of the clients have DHCP

    thanks in advance for the help !

  2. Rich-M

    Rich-M Network Guru Member

    Interesting, was running a GS, on V23. Did a cold boot, and it bricked up. Was running for 24 hrs+ with lots of load prior to.

  3. MBChris

    MBChris Network Guru Member

    you mean it could be bricked ?
  4. Rich-M

    Rich-M Network Guru Member

    The power light continued to flash, tried the reset button, couldnt
    flash anything. XP claimed it was getting assigned Only solution was to short pin 15-16 on the flash. At that point I was able to access tftp and reload.

  5. MBChris

    MBChris Network Guru Member

    Sorry, but i haven't bricked it !!! Thats not my problem ! I changed the Hardware and still the Probs ?!?!?
  6. Thrasher

    Thrasher Network Guru Member

    You're using v23 on a live system ? :thumbdown:
  7. MBChris

    MBChris Network Guru Member

    YES, why not :) ok, its a bit risk but .... it worked for about 3 weeks flawlessly ! But anyway the problem still does exist !

    And ... if i move the DHCP-Service to an other WRT within the net ... the Problem still exists !

    I also dont understand WHY some WRTs (Clients) getting their ip normaly as before and some not !

    I sniffed the net, there are alot of DHCP-Requests, DHCP-Offers but a very small count of DHCP ACK :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice