No WAN IP after Firmware upgrade

Discussion in 'Tomato Firmware' started by dennis, Jun 23, 2013.

  1. dennis

    dennis Reformed Router Member


    I have a RT-N66U router that was working on an older version of Tomato just fine. Last night I upgraded the Firmware and my WAN will not renew with my cable modem. I have tried different firmware versions with same result. I can hook my PC to cable modem without issue. I can hook another router to the cable modem without issue. I can also hook the RT-N66U to the other router connected to the cable modem and I will get a WAN ip assigned from the DHCP of the other router. But for some unknown reason to me, I can not get the cable modem to assign the RT router an IP address. I have tried a different MAC address and even had it mirror the mac of my laptop that was connected to the cable modem and worked just fine. I have cleared NVRAM also without success.

    Thank you so much in advance
  2. Victek

    Victek Network Guru Member

    Which versions did you tried?
  3. Monk E. Boy

    Monk E. Boy Network Guru Member

    Yeah, the exact version you were running before and the version you're running now would be key.

    You say you cleared NVRAM, did you restore the configuration after clearing the NVRAM or did you set everything up by hand? Did you do a long NVRAM erase or a short NVRAM erase?

    You could try adjusting the setting under Advanced -> DHCP/DNS specifically checking/unchecking the "Reduce packet size" option (under DHCP Client (WAN)).

    I've also noticed some quirkiness after upgrading, under Advanced -> MAC Address try hitting the default button for all 3 interfaces and apply, many times on an RT-N66 two or more of the interfaces will end up with the same MAC address.
  4. dennis

    dennis Reformed Router Member

    I Tried tomato-K26USB-1.28.RT-N5x-MIPSR2-110-Mega-VPN-64K.trx then the 102,107,108,109. Nothing worked. Last thing I did before I went to bed was download the AIO version and just left it and went to bed. Came home and what do you know. I am online. Not sure if the AIO quickly connected or got stuck like the Mega. And I am afraid to flash another version in the event it will get suck again. Not to mention my wife being not so happy with me that I took down the internet. I will reboot the device and see if I reconnect as expected or see if I have another issue.
  5. dennis

    dennis Reformed Router Member

    Good news. I reloaded it now works after a reboot. If there is a desire for me to load a Mega, I would do it and try again if you wanted me to test out the options you offered for knowledge reasons. But if you don't really care too much. I'll just be happy with it being up and working.
  6. dennis

    dennis Reformed Router Member

    ok, strike what I said above. I guess non of my wired devices are getting IP's. Oh how I wish I never updated my firmware. Sorry, I didn't write down my orig firmware I was using.
  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    That's good news indeed.

    I would definitely recommend applying MACs to all your interfaces (well, unless you cloned your system's MAC to the WAN interface, then you can leave the WAN interface alone). If they don't change at all you can safely ignore the setting (don't click save), but if they do change, then you should save. It's unlikely to knock out your internet so long as the WAN's MAC address doesn't change.

    You also didn't mention if you restored your configuration from a file or if you did it by hand. The file is effectively an NVRAM dump so there's no point in clearing NVRAM to just restore the exact same variables back into NVRAM by restoring configuration from a file.

    I have heard of ISPs that won't allow you to get a new DHCP lease until your old DHCP lease expires, maybe that's what's going on here. The way to get around that is to perform a DHCP release on the WAN before anything that would result in you needing a new IP address.

    I assume you also know that most cable ISPs only allow you to have a single MAC address attached to a cable modem? If you want to change the device connected to the cable modem you need to disconnect power from the cable modem prior to plugging in the new device. Changing your WAN port's MAC address is the same as connecting a new device as far as an ISP is concerned.

    So if you want to be extra-cautious:
    1) Perform DHCP release on WAN
    2) Disconnect router from cable modem
    3) Disconnect cable modem power
    4) Apply default MAC addresses, etc.
    5) Connect cable modem to power
    6) Connect router to cable modem

    Though you may want to wait until your wife's sleeping or at least not using the internet... in the interest of marital bliss.
  8. dennis

    dennis Reformed Router Member

    Well I have been able to get my router to establish a WAN IP with different firmware updates. I am downloading them from Shibby's firmware link. Not sure why TW wouldn't give me a IP for the router but would for my other two devices that had a totally different MAC addy

    The problem I am having now is the ASUS router isn't giving out DHCP IP's to the wire connected devices on the LAN 1-4 ports. It's offering them up without issue via wifi.

    At one point, I was able to get the old router connected to the asus router. But I am still having issues getting my whole house direct TV box connected. On the status page, I show it connected and blinking. but it isn't giving an IP address. However. If I connect the direct TV device through the old router connected to the LAN port, I am able to download from the internet. So, now I am not sure why the ASUS router doesn't like this device. It worked before and it allowed me to see all my DVR's. Now I have nothing.

    Is there a way to connect to the asus router via a CLI and maybe do some kind of ARP command to see if I have an unknown MAC address registered but without a IP address? And since the device I am trying to connect is a direct TV device, there isn't anyway for me to get into that device and do some kind of a /release /renew to try and get an IP address.
  9. dennis

    dennis Reformed Router Member

    I have connected now two devices and pulled IP address. I just can't get the direcTV box to register. So annoying and it's time for bed. More troubleshooting tomorrow I guess.

    Thanks so much for the replies.
  10. dennis

    dennis Reformed Router Member

    after thinking about it. I don't think the deca device I am connecting to my router is going to grab an IP. I suspect it's working as a layer 3 device not layer 2. I am betting I need to release and renew the IP's for the DVR's themselves which is going to require me doing a cold/warm restart. Hopefully after I do this, they will get an IP and all will be well. I'll have to try that in 9 hrs when I get back home.
  11. dennis

    dennis Reformed Router Member

    Success!!! I now have all of my DVR's online with a new firmware. Now on to QOS.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice