No WAN with Asus WL-520GU

Discussion in 'Tomato Firmware' started by mucker77, May 4, 2008.

  1. mucker77

    mucker77 Addicted to LI Member

    Has anyone had success running Tomato on the Asus WL-520GU?

    5354 Broadcom Rev.2 processor
    16 MB ram
    4 MB flash

    DD-WRT works just fine. The Tomato 1.19 NB will flash into the router and I can access all pages of the firmware just fine. Problem is, I have never been able to get a WAN connection ever. I have cleared the nvram and have verified that the vlan1ports (0 5) are correct.

    I have a Buffalo WHR-G125 that the 1.19 NB works just fine with. the 125 and 520GU use the same 5354 cpu. Anyway, any hints would be appreciated.....

    m :)
  2. spliff

    spliff LI Guru Member

    This should go on the Tomato Wiki. It can be done I've actually been using the WL-520GU for quite some time with Tomato. Here is a writeup someone did. You basically have to flash to DD-WRT first, reset all settings, then flash tomato-ND.

    Ok, guide to install the Tomato firmware on an Asus WL-500GU.

    First step is obviously to get all the software you need ahead of time, as you will be disconnected from the internet while flashing the firmware.

    You will need:

    The Tomato 1.17ND(New Driver) Firmware
    The Asus recovery tool, which is included in their router setup driver package. Their site is asstastically slow, so I'm going to just mirror it with rapid ****. If you can get the Asus site to actually respond to your browser, get the file named Yes you do need to install it, suck it up.
    The DD-WRT firmware. This is necessary to get tomato working.

    Step 1: Hook up the new router in place of your old router, or hook it up to your modem. I am assuming you have a cable modem or other DHCP style connection instead of PPOE or whatever.
    Step 2: Hold down the reset button on the router and remove the power cord. Continue holding down the button and reinsert the power cord. Release the reset button once the power LED starts blinking. This means it's in recovery mode and we can **** with it now.
    Step 3: Make sure your computer is hooked up to the router via a wired connection, wireless will **** the bed repeatedly during this process. Open the Asus Firmware Recovery Utility, select the DD-WRT.v24 firmware and hit upload. Wait for the update to finish, close the program once done, wait 2-3 minutes for the router to reboot.
    Step 4: Log on to the router by browsing to username root:admin (or admin:admin I forget which) and perform a factory default. You can find that under the Administration tab.

    Congrats you now have DD-WRT installed on your router, if you want to install Tomato, continue reading.

    Step 5: Open telnet via the run command, type 'o' log in with root:admin and type in 'nvram get http_passwd'. Write down the password, it's needed for the next step.
    Step 6: Repeat steps 2 and 3, use the Tomato firmware in place of the DD-WRT firmware in step 3.
    Step 7: Log on to the router using the user name/password root (or possibly admin) and the password you received in step 5.
    Step 8: Perform a 'Restore default router settings' reset through the Administration -> Configuration links. FOR THE LOVE OF **** DO NOT PICK THE OTHER ONE OR YOUR DUMB ASS GETS TO DO IT ALL AGAIN.

    Congratulations, you are now the proud owner of a new Tomato equipped Asus WL-500GU, huzzah!
  3. bkmartin

    bkmartin Network Guru Member

    I have this same issue with the WL-520GU. I have tried 1.19ND, 1.20ND (two versions). I followed all of the instructions listed above by spliff. (His instructions are just required to get it working --- which we both obviously did). The Wireless and LAN interfaces work fine, but the WAN interface will not obtain an IP address via DHCP, nor will the WAN interface work if configured with static ip. (The WAN interface only shows transmitted packets, but not received packets --- no errors are listed on that interface either)

    Since spliff has it working, I can only assume that the OP and myself have a different hw revision of the wl-520gu that has this WAN problem...

    Of course, dd-wrt v24 works fine.

    Once booted into Tomato, it identified the wl-520gu as a WL-500gP V2. dd-wrt v24 identifies it as Asus WL-520GU/GC. Spliff, how does Tomato identify your wl-520gu on the Overview screen?
  4. bkmartin

    bkmartin Network Guru Member

    I fixed Tomato to work on my wl-520gu. Following the information in this thread:

    I found that vlan1ports nvram variable on Tomato was set to "0 5u" I changed this as follows (from telnet login to the router):
    nvram set vlan1ports="0 5"
    nvram commit

    Good news, the WAN interface then successfully connected and retrieved the correct IP address and the router works fine. I'm going to send this information to the Tomato author and perhaps he can get a future version to have this nvram set to "0 5" by default instead of "0 5u"

    Spliff, can you login to your router do a nvram show | grep vlan and see how your vlan1ports variable is set...
  5. spliff

    spliff LI Guru Member

  6. bkmartin

    bkmartin Network Guru Member

    I did set to factory defaults in dd-wrt before flashing and then back to factory defaults (in Tomato) after flashing. I would think reseting the configuration in Tomato after the flash would remove any residual config left by dd-wrt anyway. Perhaps the earlier version of Tomato 1.17ND that you initially used did not have this vlan1ports nvram bug. I would bet you have not tried reseting your router to Tomato defaults since you got it working and you have just been upgrading your firmware and letting your configuration remain. Perhaps along the way, this bug has been introduced in the Tomato default configuration on this router model...
  7. spliff

    spliff LI Guru Member

    I did start with 1.17, you are right.
  8. LLigetfa

    LLigetfa LI Guru Member

    Not so. I tend to switch back and forth between dd-wrt and Tomato and find that some settings survive. The "reset to defaults" in Tomato don't necessarily reset some dd-wrt settings.
  9. bkmartin

    bkmartin Network Guru Member

    Well, the thorough reset (which says it erases the nvram) should definitely wipe out any residual dd-wrt settings. This is one that I chose.
  10. TexasFlood

    TexasFlood Network Guru Member

    I can't remember any specific instances of settings surviving as you describe, but have never believed that a reset to factory defaults got rid of all nvram settings, espeicially when switching between different firmwares.

    I do think that erasing nvram will do the trick. Depending on what firmware you are running, this command could be "erase nvram", "mtd erase nvram" or in the case of Tomato it is "mtd-erase -d nvram". I think the below GUI choice also does a full nvram erase.

    I don't hesitate doing this on my Linksys WRT54G v2.0 but am a little hesitant to do it on my Motorola WR850G units as it also erases the MAC addresses on those. This isn't fatal, but I have to take the extra step to go in and change the nvram MAC addresses from 00:11:22:33:44:5{5-7} to what they should be and reboot. I still do it when I have any reason to believe that the nvram needs a good purge though, :-D

    NVRAM erase through GUI
    Administration -> Configuration
    Restore Default Configuration -> Erase all data in NVRAM memory (thorough)
  11. bkmartin

    bkmartin Network Guru Member

    In the interest of completeness, I did more testing. If you just do the restore system defaults (without erase) coming from dd-wrt v24, then the WAN will work since the vlan1ports setting is correct at "0 5". If you erase the NVRAM (the thorough reset option), then Tomato recreates the vlan1ports nvram variable incorrectly as "0 5u" and the WAN will not work (I validated this on 1.17ND, 1.19ND, and today's version of 1.20ND). Bottom line is if you move from dd-wrt v24 to Tomato, then you should only do the reset to default configuration (without erasing nvram).

    If you do the thorough reset by doing a NVRAM erase, then you can restore your WAN operation using the commands I documented earlier in this thread. Hopefully now the mystery is completely solved.
  12. LLigetfa

    LLigetfa LI Guru Member

    By "reset" I meant the 30 second reset button hold. I consider NVRAM erase to behave different.
  13. spliff

    spliff LI Guru Member

    Good thing you figured this out. The Asus WL-520gu is an awesome router. Its the same chipset as the Buffalo WHR-G125 (not on sale in the states) with the bonus of a detachable antenna. You can buy them on sale for about $50.
  14. Thebeast

    Thebeast Guest

    This seems to be the exact problem I am having with my WL-520GU. I was all excited about unboxing it from newegg last night. I flashed tomato on to the router and everything looked fine, all of my systems connected to the router/each other fine. unfortunately no internet access. I stayed up until almost one in the morning last night trying different builds and changing settings.

    Now I can't wait to get home (yeah I know I should be working at work and not digging through forums lol) and try this out. Hopefully I get it fixed and wont have to hear the wife complaining about me spending $50.00 on a router that "can't even get online"....:argue:

    Thanks for the post I think this will help me out.
  15. Toastman

    Toastman Super Moderator Staff Member Member

    This thread was a year old - I was under the impression that this issue was fixed some time ago - are you using an old version of Tomato?
  16. Low-WRT

    Low-WRT LI Guru Member

    Yeah, I know this doesn't help you, but I just bought a WL-520GU about a month ago. I PROMPTLY flashed it with Teddy_Bear's 1.23 mod...It has worked perfect since day one.
  17. substance12

    substance12 Addicted to LI Member

    is this statement still relevant to the latest build?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice