No Wireless Connection with WPA/WPA2 - WEP is working well

Discussion in 'Tomato Firmware' started by Yoshi2k, Nov 3, 2007.

  1. Yoshi2k

    Yoshi2k LI Guru Member

    [Solved]No Wireless Connection with WPA/WPA2 - WEP is working well


    I just bought a new WRT54GL and I flashed it with "Tomato Firmware v1.11.1217". But now I occur the problem, that I can not establish a connection to the router with my notebook when WPA or WPA2 is enabled. When I disable the encryption or only use WEP, which is not my intention, everything works perfectly. I also tried to connect my notebook my the original firmware, it was the same, but I only tried it once.

    Windows stucks when trying to resolve a network address. I thought about a problem with a blocked mac address, but this doesn't fit to the fact, that I can connect when using no encryption or WEP.

    Does anybody else have a similar problem? I would be very pleased if someone could help me!!

    My wireless card is a "Gigabyte GN-WI01GS mini PCI".


    Greets Stefan
  2. tinfoil

    tinfoil LI Guru Member

    What version of windows do you have? Is it fully patched? The driver ffor your card is current?
  3. Yoshi2k

    Yoshi2k LI Guru Member

    - Windows is Windows XP Pro with all official Patches
    - Device driver is the newest one, I could get
  4. Yoshi2k

    Yoshi2k LI Guru Member

    Well, I found a solution now, but this one also doesn't satisfy me.

    I changed the Wireless Mode from "Access Point" to "Access Point + WDS" and now it works. But I don't understand why.

    I've never heard of WDS but Wikipedia says:
    For me, WDS is only required when I have two different Access Points, which I want to inter-connect. But I only have my WRT54GL.

    I also want to enable WPA2, but this is not possible when using WDS...
  5. Larix

    Larix LI Guru Member

    I have the same problem with my G4 iBook. I can't connect anymore when the WPA or WPA2 is enabeld. I have set it TKIP + AES and I use a 62 character password. I have tested it with a shorter password, with AES and TKIP only but this didn't work well. Befor 1.10 it works very well. ;(
  6. Macskeeball

    Macskeeball LI Guru Member

    In my experience, a change in the encryption type requires a restart of the router to actually take effect. At least it did when I still used the official firmware.
  7. Yoshi2k

    Yoshi2k LI Guru Member

    I don't understand what you want to say, because the router automatically restarts the correspondent services. However I just tried it, but it didn't work. Any more ideas?
  8. Macskeeball

    Macskeeball LI Guru Member

    Maybe Tomato does. I was referring to when I still used the official Linksys firmware, although I've been using Tomato for a while now. Oh well.
  9. pumpkin

    pumpkin LI Guru Member

  10. Yoshi2k

    Yoshi2k LI Guru Member

    Thanks for alle your help. After restoring the default values of the router and starting over with the same setting, it works now. May be I should have tried this earlier.

    However I didn't know, that Windows XP needs an update to enable the support for WPA2 encryption. Also thanks for this hint.

  11. norkle

    norkle Guest

    No WPA from Android/Squeezebox

    I have the same problem as the OP, but no Windows involved here - I'm trying to access using Android-based HTC Desire and Squeezebox Boom. Can connect fine using WEP, but no luck using WPA (either as Access Point or WDS+AP).

    Using Tomato v1.27 on Asus WL-500gp.

    Are there any working options for WPA?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice