Non-responsive DNS

Discussion in 'Tomato Firmware' started by rkloost, Jan 5, 2009.

  1. rkloost

    rkloost Addicted to LI Member


    I'm running:
    Tomato Firmware v1.23.1607
    Copyright (C) 2006-2008 Jonathan Zarate

    Built on Sun, 14 Dec 2008 02:54:59 -0800

    at random times dns-resolving stops working.

    Change under advanced -> dhcp/dns server
    Use Internal Caching DNS Forwarder from active to inactive, save, change it back and save again.

    After restarting the service things work again.

    It seems the dnsmasq crashes random.

    Is this a known issue?

  2. ntest7

    ntest7 Network Guru Member

    No, not a known issue.
    Are you using any "custom" dnsmasq settings?
    Do you have this problem on multiple routers?
    Does the router still hand out DHCP addresses when you experience the DNS problems?
    Have you tried clearing nvram and retyping your settings (not restore from backup)?

    You also might try leaving the "Use Internal Caching DNS Forwarder" unchecked and see if you still have problems.
  3. rkloost

    rkloost Addicted to LI Member

    It seems something strange with DHCP.

    Windows Vista receives DNS-server via DHCP. This address is not used in my network.

    The setup:
    Frontend ( <-DMZ-> ( [Tomato] ( <- switch -> PC's with strange DNS issues

    Has anyone ideas howto debug this any further?

  4. DeCex

    DeCex LI Guru Member

    Thanks g0d, i thought it was only me. Im loosing connection over night, the router is responsive. I have reboot it to make internet connection working again. YES, iv cleared NVRAM after upgrade, reconf everyting, still connection drops during my sleep. Strange problem.
  5. ntest7

    ntest7 Network Guru Member

    I'd like to blame this on vista weirdness... Is just this one computer acting up?
    Use the IPCONFIG /ALL command to see where this information is coming from. Maybe you have a rogue DHCP server somewhere on your LAN.
  6. ntest7

    ntest7 Network Guru Member

    This sounds totally unrelated to the current discussion.
  7. DeCex

    DeCex LI Guru Member

    Strange issue, after loosing inet connection, i log in to tomato interface, the status page shows external IP adress, so which show that the router is still connected to internet. The strange thing is that users behind router cant access internet untill i reboot the router.

    I thought this was dns lookup issue. Lik dns lookup died or crashed or something after it been active for awhile, since im loosing connection during night. The only thing i know using router is the Wii wireless console weather lookup service is running.
  8. kenyloveg

    kenyloveg LI Guru Member

    I have the exactly same problem with rkloost. While after a few minutes dns resolution worked again.
  9. rkloost

    rkloost Addicted to LI Member

    After powercycling the router last friday it's stable again. No issues since powercycling the router and all systems connected. So since friday januari 9 it is stable again... But it is still strange unexpected behaviour.

    I will check if I can reproduce this behaviour on one of my OpenBSD firewalls, that uses DNSmasq.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice