Nothing but trouble... so far

Discussion in 'Cisco/Linksys Network Storage Devices' started by ArmyDoc, Mar 6, 2005.

  1. ArmyDoc

    ArmyDoc Network Guru Member

    I love the promise of this device, the main reason I bought one was the huge power consumption of my current Linux file server PC.
    I'm reasonably computer literate, but so far I've had noting but trouble setting the d**n thing up:

    1. from the first time the NSLU2 was powered up it refuses to recognize my external HDD - it's a 200 GB Maxtor in a no-name USB2 enclosure which uses some weird Cypress chipset (the only reference I could find was the term ME350UCII on the box). Whatever I tried, the setup wizard would give a Format fail error.

    2. I'm now at the point where I can at least enter the config utility by booting it up with only an old flashdrive. So I can at least change the most important settings (for now) like workgroup etc. But after re-connecting the HDD (which is recognized - at least, the disk1 LED is on), I still cannot format the drive, even through the config utility (web based thingy) the status of drive 1 keeps reverting to 'not formatted', and the drive log shows the format failed error.

    3. The NLSU2 will not allow firmware upgrades... every time I try one I keep getting a 'not enough room' error. Does it need a drive attached to flash firmware?

    4. Right now I'm formatting the drive using Partition Magic with two logical partitions, a 2 GB swap and a 198 GB ext3 partition. I'm not even sure if this works but from multiple sources on the Net this is what seems to be on the drive after a succesful format, so here's me crossing my fingers. If this doesn't work I'm thinking of returning the drive enclosure and exchanging it for one from Sitecom or a Maxtor OneTouch or LaCie BigDisk.

    So, my questions:
    a) is there a known incompatibilty with the enclosure or chipset (I tried connecting it directly to my two WinXP machines, but in both cases, driver installation failed miserably)?
    b) is this what's causing the HDD to fail formatting?
    c) why can't I flash the firmware?

    All help/advice/emotional support is appreciated!
  2. ArmyDoc

    ArmyDoc Network Guru Member


    What an extremely exhaustive way to get this hardware running... Well, apparently 'pre-formatting' the HDD did the trick - after replacing it in it's enclosure and attaching it to the NSLU2 the NSLU2 still wouldn't recoginze the drive (that would've been too much to hope for), BUT I was now able to format the drive through the config utility. After that, smooth sailing all the way. Flashing the firmware also worked, so it appears that a working HDD is necessary for this (still don't know why the thing couldn't use the attached flashdrive...).

    Now on to the fun...
  3. VTrider

    VTrider Network Guru Member

    Some info on external USB enclosure compatibility

    Hey Armydoc, I had the same exact problem with my NSLU2 when I first got it - fixed it (so I thought) the same way - a few days later the NSLU2 wouldn't recognize the drive again, or would give me format errors.

    There are compatibility issues with certian chipsets in some external enclosures and the NSLU2. I switched mine and haven't had a single problem yet. Some chipsets act of only occasionally, some every day - from what I've read on NSLU2 posts.

    If the problem comes back and you do suspect the enclosure, there is a good database of enclosures that do work over on the Yahoo NSLU2 group.
  4. ArmyDoc

    ArmyDoc Network Guru Member

    Hey VTrider,

    Well, I haven't had any troubles since the last post. And I did check the database you mentioned - my specific enclosure isn't mentioned but some other brand with the same productnumber is, so I'll assume that refes to the chipset, which should be supported.

    I've transfered all my files drom my old Linux fileserver HD to the NSLU2 without a hitch, and attached the drivefrom the old server as a second drive using a Conceptronic case. Worked fine, but here's nother little nag:
    In the status screen for the config utility (the opening screen) the 2nd drive is recognized and shown ready, but shows a capacity of 0 MB! It is a 120 GB drive - Windows explorer shows the correct capacity!?! Glitch in the frimware? I"M running v2.3R29 now.

    Last question now that I've mentioned firmware: does anybody now if you can downgrade from R29 to R25, or even uNSLUng3.18 which is based on R25?
  5. RoMe0610

    RoMe0610 Network Guru Member

    Downgrade from R29 to R25 is no problem.

    For unslung I cannot speak.
  6. VTrider

    VTrider Network Guru Member

    Armydoc, that 0% drive space bug has to do with v2.3R29 firmware. I'm running it right now and have the same problem, not much of a problem though, i'm just gonna wait till the next firmware update and hopefully they will fix it.
  7. wkaml

    wkaml Network Guru Member

    Can NOT recommend use of NSLU2

    Unless you got a LOT of extra hours at hand and want to experiment with Linux and this box, I can NOT recommend the use of the NSLU2. Does not matter what firmware version you are on at this point, serious problems are programmed and will give you a major headache, especially when you thought you could rely on this box.
    It is unbelievable to me of how Linksys can release such box that is loaded with bugs and eats up your data and time. At this point I have been through every bug on this forum and currently I am stuck with the issue that I cannot write anything to my USB Maxtor 250GB HD anymore. I will probably go through the 3rd reformat this time and lose all my data all over. This is *BAD*.
    So, if you want to use an NAS to store your data, _DO NOT_ use the NSLU2 - take your hands off!!!
  8. redbaron

    redbaron Guest

    I have spent 3 days trying to get my newly purchased NSLU2 and 250GB Maxtor drive to work (with Sony VAIO / Windows XP / WPC54GS card / WRT54GS Broadband Router), in the fashion promised by the marketing blurb. I wouldn't pretend to be a network expert, but I'm not incompetent either. Having been brought close to tears I looked for help on the internet (should have done that first...) and seem to have got the d##n things to work at last. Hopefully this info will be helpful to others, it's a collection of hints from related sites.
    Problems: the NSLU2 kept disappearing from the wireless network ('not available' in the web utility); when the NSLU2 was visible the hard drive kept becoming unavailable ('not formatted') via the web utility and the share would disappear from NetWork Places; trying to install games, access denied errors appeared during install.
    Solutions: (I had to go thru all this stepwise to get it to work)
    - ensure PC and NSLU2 on same Workgroup (named the workgroup the same as the SSID for good measure?!)
    - permanently switch off Norton Internet Security Firewall
    - permanently switch off Windows Firewall
    - disable UPnP on the NSLU2 via the web utility
    - upgrade the NSLU2 to Firmware v29 via the web utility (any hard drives must be disconnected for this to work)
    I wasted a huge amount of time forcing the Windows Utility to format and recognize the HD (the properly formatted HD was simply not being 'seen' by the NSLU2); swapping it to the laptop and deleting the partitions to force the utility to reformat it etc; none of this helped in the long run.
    The no-name HD aluminium case caused some random misbehaviour as well (am now running it outside the case!) so will be buying a Maxtor case next.

    Hope this is helpful. Any clues to how to get this all to work with the Firewall(s) switched on?
  9. jonaadam

    jonaadam Guest

    R25 Firmware

    Where can I find a reliable binary?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice