NSLU backup problem

Discussion in 'Cisco/Linksys Network Storage Devices' started by cosmic, Nov 10, 2005.

  1. cosmic

    cosmic Network Guru Member

    Using R.29 firmware, Windows 98SE, Maxtor 250 GB disk.

    Have had this disk for half a year. I finally got the built-in backup feature to work, BUT there are two issues:

    1. I made a full backup overnight (43 GB). When backup was completed I noticed that some folders and several thousands files had not been copied. In the log I see this:
    Backup: Maximum errors occur in job 'PelleBackup', job is aborted. Then there is a list of 21 files which could not be accessed.

    This message is shown at every backup, and not all files and folders are backuped. What is this? Aborting just because a few files could not be copied?! Scary. Worthless feature.

    R.63 seems to have a lot of problems. But, is this backup bug solved in R.63?

    2. Another strange thing is that all copied files are copied to two different shares on the NSLU2 disk - to NSLU\cosmic, and to NSLU\admin\cosmic = duplicate backup. I suppose I have misconfigured something - but what?

  2. cosmic

    cosmic Network Guru Member

  3. cosmic

    cosmic Network Guru Member

    Using R.63 firmware, Windows 98SE, Maxtor 250 GB disk.

    An update of my backup headache.
    I am using NSLU2 with native R.63 firmware, Windows 98SE, Maxtor 250 GB disk.

    After upgrading to R63 and removing strange characters in some 20 files on disk, backup now works, and virtually all files (a few exceptions in Windows directories are not accessed) on 3 computers are backup up (43GB and 18GB from two Windows 98SE machines, and 3,5 GB from a Windows XP laptop).

    So far so good. A few issues still remain though:
    1. From my own Win98 computer I have access to all folders for all 3
    computers without problem. But from the other Win98 computer the NSLU is not accessible when clicking in Network neighborhood - I get an error message that access is not allowed. Everything seems correct configured (identical with the other Win98 machine). Backup works fine, though.Access from that computer has worked before (before upgrading to R63, when I also deleted all shares and created new ones).
    This time I did not create any additional shares on the NSLU, but simply 5 folders directly under ADMIN 1.

    2. I have only two backup jobs defined, but it is still not possible to add more jobs. Get message "Too many jobs". With R29 I think I had additionally jobs defined which I then deleted. It seems they are still visible to the NSLU and that it therefore is blocking additionally jobs?
    How should I overcome this? Resetting did not help.

    3. In the Shares section in the NSLU interface, the DISK 1 share is
    highlighted red. When trying to access it, message "There is no folder associatyed with this share" is shown.

    4. Backup works, but is slow. Speed is only 8Mbps (i.e. 1 megabyte/sec). I know our network (100Mbps) has some bottleneck which usually limits network speed to about 22Mbps. I haven't found out the reason to this. Maybe this is also the reason to the very slow backup speed.

    Very grateful for advice.
  4. d__l

    d__l Network Guru Member

    Are the backup jobs full, incremental, or synchronize? I found that an incremental job has roughly half to two thirds the average transfer speed of a simple drag-and-drop folder copy to the NSLU2. I don't know about the full and synchronize backup speeds.

    It has been reported elsewhere that files named $-----$, where "-" is any character, will not copy to the NSLU2.
  5. cosmic

    cosmic Network Guru Member

    All of them were full backups.

  6. cosmic

    cosmic Network Guru Member

    I downloaded and extracted (.tar file) the config.bin for the NSLU to see I could find any weird stuff. For example the NSLU doesn't allow me to define any more jobs. But in CGI_ds.conf only two jobs are defined. So why can't I add more jobs??

    Extract from CGI_ds.conf:

    PelleBackup=1:1:ADMIN 1:/kossmo:::kossmo:/c:0:0:12:0:pm
    AnetteBackup=1:1:ADMIN 1:/chiver:::chiver:/c:0:0:12:0:am

  7. d__l

    d__l Network Guru Member

    Are you using all foward slashes when trying to make your new backup jobs? See: http://linksys.custhelp.com/cgi-bin...F9zY2ZfbGFuZz0xJnBfcGFnZT0x&p_li=&p_topview=1

    This appears to be a new Answer that may be related to the introduction of the R63 firmware. I know that on older firmwares such as R25, one had to use forward slashes for the NSLU2 subfolder and back slashes for the Other Device (Windows' devices) shared folder. The old style, back-slashed, back up jobs will work even after you migrate from an old firmware to R63.
  8. cosmic

    cosmic Network Guru Member

    Yes, all forward slashes.
    Linksys has really succeeded 100% to confuse people on this.

  9. Doug_B

    Doug_B Network Guru Member

    Couldn't tell if this is still a perceived problem. In any case, it appears that "public" shares (i.e., shares created outside of admin, or at least some subset of these) are duplicated under admin. I don't believe that the actual folder tree and files are duplicated, just that you have two different shares pointing to the same tree.

    I saw this problem with a different share while testing stuff out. I think I might have broken some sort of link or removed a top level folder associated with a given share, so the message may have accurately provided the status. Since I had little data on the disk and it was only test data anyway, I was eventually able to clear it all out, probably by deleting the share. Don't know if this will work for you, if you can fool around with the Disk 1 share (not currently at home with my unit), or if it's realistic for your situation based on existing data on the drive.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice