NSLU reboots in a loop when harddisk connected

Discussion in 'Cisco/Linksys Network Storage Devices' started by hashman, Dec 24, 2006.

  1. hashman

    hashman Network Guru Member


    I got a major issue on my nslu2 which appeared all on its own out of the blue:
    One day I just tryed accessing my nslu2 mounted hard disk from my windows XP computer and it reasked me the login/pw to connect to the drive (unusual), so i typed it... and nothing happened...
    I tried pinging my box: no response
    So i opened the closet to see it blink ... blink and blink
    It went through its usual boot process: Green blinking of the status light, disk1/disk2 lights turn on... and finally, the status light goes orange and starts all over again: Sort of an infinite loop.
    So i turn the box off (have to unplug), and plug it back in... turn it on: no chance of getting it to work. Same infinite loop in boot process... the Status light goes from green blinking to an orange blink and start again.

    I then disconnect both disks and try to boot again: it boots.
    But the IP had reset from (my network settigns) to
    So i change my laptop network settings to connect to the web page and then go to admin to set back normal ip: I get the "samba can not find information" error.
    I manage to fix that with the RedBoot method (reset sysconf)
    But now the main problem:

    I can boot the NSLU2 without disks normally.
    As soon as I connect a disk (either ext3 formatted, or ntfs formatted, or even unformatted) it just goes back to crashing (status blinks orange and then loops on trying to boot up)
    I can connect the disk before turning it on (on either usb port), or once booted up: same result.
    If I connect the disk after it has booted up... it restarts after a few seconds of working correctly (around 20seconds)

    I have tried all available firmwares (unslung, linksys official, debianslug...etc): same result :-(

    Any help would be appreciated, and Merry xmas and happy new year to all

  2. hashman

    hashman Network Guru Member

    power issue. With new adapter all works fine...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice