NSLU2 crash?

Discussion in 'Cisco/Linksys Network Storage Devices' started by Oisi, Aug 7, 2005.

  1. Oisi

    Oisi Network Guru Member

    I have an NSLU2 for about a week now and have some problems.
    I'm using a Lacie enclusure holding a 250 gig Seagate drive and have the NSLU2 connected into a 3com wireless router.
    My problem is the NSLU2 just hanging, when trying to copy files it works for a few minutes and then hangs. Windows loses the drive, I can no longer access the configuration from the browser and I can no longer ping the NSLU2 from cmd prompt.
    All I can do is unplug (as the power button stops working) the unit and re-start it.
    Anyone have any ideas? What could be wrong?
    I have had a little more success with connecting to the device using an FTP client, it works for much longer but eventually it stops.
    (using firmware 2.3 R63)
  2. comijmv

    comijmv Guest

    What a crack of firmware. I have the same problem here, I have upgrade the firmware to 2.3 R63.

    I have formated my hard drive to NTFS and then I have the same problem
  3. Oisi

    Oisi Network Guru Member

    I'm using Ext3, does anyone else have this problem?
    Is it possible to down-grade to a previous Firmware? If so, maybe someone can post the R29 file? It's no longer available on the website.
    Anyone have some ideas on what I could try?

    I have actually realised that reducing the speed of the copnnection helps i.e. connecting to it over a slow WiFi makes it last hours if I use FTP only.


  4. Oisi

    Oisi Network Guru Member

    managed to find R29 on ftp.linksys.com, reflashed (downgraded) and now all's working fine!
    For god sake Linksys, get it sorted.
  5. teachscience

    teachscience Network Guru Member

    NSLU2 firmware

    Linksys now claims r 63 is beta software. Go figure considering that it is the software listed on their website! This upgrade was painful.
  6. techmanblues

    techmanblues Network Guru Member

    Yes, a Linksys tech confirmed with me that R63 is BETA. Now, they tell me!
  7. HansBrackhaus

    HansBrackhaus Network Guru Member


    i had/have those problems too. This problem accoured with all firmware versions available for me.

    Everytime i try to scan my \\nslu\music\ directory for mp3s with a media player the NSLU2 will not respond anymore. The files can't be read anymore, any access attemp will fail. I can't switch the NSLU2 off- i have to pull the power cord.

    Does anyone of you know how to solve that problem. It did not help to flash R29 again. The R63 worked for NTFS - but i always have this problem with copying and reading many small files.

    Any help would be nice...
  8. HansBrackhaus

    HansBrackhaus Network Guru Member

    This morning i called customer service.

    In my case the asume that my USB2.0-IDE-Case could cause that problem - they say that as it is a no-name product the USB2.0-controller might cause problems. (I use a Samsung Spinpoint 160GB IDE harddisk.)

    The customer service told me to check if using other USB-Cases would help with this problem. Linksys advices to take Maxtor One-Touch external harddisks or use of ICY BOX-Cases. Any experiences, advice?

  9. custk9

    custk9 Network Guru Member

    Same problem here. No use in changing to Icy Box cases, I have one and also the same problems. NSLU2 (R63) with IciBox containing Maxtor 120gb (3 partitions, 2FAT 1 NTFS).

    I noticed that the lockup occured when you are trying to access the slug with a mediaplayer for example playing a song and at the same time accessing the same directory via Windows explorer.

    Results in no response from the slug and the need to pull out the plug in order for it to restart.

    For firmwares: try ftp.linksys.com There's more on the server than Linksys states on his web pages.
  10. d__l

    d__l Network Guru Member

  11. SeanFL

    SeanFL Network Guru Member

    I'm using a maxtor one touch 250 (the drive they suggested as a bundle) with r63 / NTFS and having loads of problems.

  12. kn0xster

    kn0xster Network Guru Member

    Yeah I've been having the same problem. I upgraded the firmware to the 63 and it is still the same.

    I have a Lacie 160GB drive attached to the NSLU2

    At first I thought it was something to do with copying large files but then i did a test and was able to copy 4 x 1.5 GB files over to the HD on the NSLU2. I have a directory containing about 40 GB of my music and when I try to copy this entire folder over thats usually when it happens.

    I'm going to see if I can downgrade the firmwar tonight i reckon and see if it makes any difference. Anyone have any ideas on which is the best one to use?

  13. peterdesan

    peterdesan Network Guru Member

    Can anyone post a link to an earlier version of firmware that works, ive had a look at the ftp site and cannot find the earlier firmware for nslu2.

  14. peterdesan

    peterdesan Network Guru Member

    Well, ive found v23 r29 on the ftup site, but when i try to use the upgrade function on the device to change from r63 to r29 i just get an error message saying not enough space.

    anyone any advice ?
  15. d__l

    d__l Network Guru Member

    peterdesan, you need to use the eraseall utility. See Linksys Answer ID 2901.
  16. kn0xster

    kn0xster Network Guru Member

    yes there should be an eraseall utility in with the 29 firmware. Its inside the zip I think. If not have a google for it I found it somewhere.

    I'm taking my slug back to the shop today. I'm going to get them to change it for another one. Last night I tried all kinds of things to get it working:
    1. Tried 2 different disks.
    2. Tried formatting both disks as NTFS - which worked but i still got the time out error after copying about 4Gigs of data over.
    3. Tried various combinations with both the 29 and the 63 firmwares.

    I always get the same error! No matter what I try. :-S

    Lets see if i can make some progress this weekend with a new Slug.

  17. d__l

    d__l Network Guru Member

    kn0xster, a fellow over on DSLR was able to eliminate his "network device is unavailable" transfer error problem by doing a Fix Disk operation on his Windows source drive. He was trying to copy a 32 GB Norton Ghost backup. Part of his transfer problem was caused by disk error on the source drive. You might check out this: http://www.dslreports.com/forum/remark,14613131 to see if it would apply to your situation.
  18. kn0xster

    kn0xster Network Guru Member

    cool thanks. I'll have a look at that.

    It might still be worth me changing the unit in any case. Like I said, I had no problems transfering large files its just when copying multiple files.

    thanks for the link!
  19. kn0xster

    kn0xster Network Guru Member

    well i ran a sacndisk on one of my drives this lunch time and it didnt find anything. did you just use the program that comes with XP or dod you use someother utility to check the disk?

    Anyway I managed to swap the Slug for another one at lunch time :D So I'll give it a try tonight and will report back with any news.

  20. d__l

    d__l Network Guru Member

    For your Windows drives, do whatever you normally do to scan and fix errors.
  21. kn0xster

    kn0xster Network Guru Member

    Well looks like this new one is fine. I changed the Slug today and have just managed to copy all the files over after formatting the disk using the format utility on the web interface.

    Question now is, do I try and upgrade from the 24 firmware to the 63 or leave it? mmm. We'll see tomorrow. :rockon:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice