NSLU2 drops connection ->Please write to support@linksys.

Discussion in 'Cisco/Linksys Network Storage Devices' started by Registered, Sep 30, 2005.

  1. Registered

    Registered Network Guru Member

    maybe if enough people write to them, they will fix this in a future upgrade.
    I'm using f/w 2.3R63, and I can write to the drive till no tomorrow, and stream from it.
    If I try to copy more than 30M at a time, I will get the
    "Cannot copy XXXX: The specified network name is no longer available"

    after many hours on chat w/ tech support there seems to be no resolution to this problem, and I suspect there is a problem with the firmware ( I had 2 NSLU2's already)

  2. d__l

    d__l Network Guru Member

    What drive enclosure are you using?

    Have you ever scandisked the HD?
  3. Registered

    Registered Network Guru Member

    Yeah, I scandisked the hardrive, defraged, and it works really well when connected to my computer ( this was tested with two computers).

    Likewise I can copy whatever I like to the NSLU2 - The problem is only when trying to copy back anything >~50Megs ( a video, or a folder, etc...)

    The only thing that I think is special is that my drive is all NTFS (250G) - a newly supported feature?

    The enclosure is the vantec NexStar2

  4. d__l

    d__l Network Guru Member

    I tested my ext3 drive with the largest files I had on hand, 75 MB, by Windows drap and drop copying both ways. It worked perfectly. Then I tried drag and dropping a larger folder, 170 MB, of nested subfolders and programs (max program size of 40 MB). That worked perfectly.

    One thing I did find was that a straight copy in either direction is almost twice as fast as an incremental back up copy done by the firmware: ~32-37 mbps vs. ~17-19 mbps.
  5. Registered

    Registered Network Guru Member

    By chance do you have an NTFS drive to try with?

    Your success with the device is encouraging - are you using the latest firmware?

    I was going to return mine - but first I will see if I can find another drive to test in ext3 format

  6. kamiller42

    kamiller42 Network Guru Member

    I was using NSLU2 with NTFS and experiencing drops. Realizing its Linksys quality and not ready for prime time, I reformatted my Maxtor OneTouch ext3 (R63). I no longer see drops and some features that were failing when I first upgraded to R63 are gone. (When I first upgraded, I was still ext3 from R29.)

    I cannot have drops because I use my NAS to backup virtual machine files, VMware. If you haven't seen them, they're huge, 5-8GB. I did a backup yesterday of all my virtual machines with no problems.

    Bottom line: Copy your stuff off the drive, flash R63, delete all partitions (I used PartitionMagic because based on my experience, I don't believe the NSLU2 format routine truly clears everything out.), re-format drive, and copy your stuff back.
  7. Registered

    Registered Network Guru Member

    hmmm... Thanks for the info.

    I was hoping that I could keep my drive as NTFS .... maybe then the NSLU2 is not for me...

    Before I return it, I will try to find an extra drive to format as Ext3, and I will see if the problem goes away

  8. d__l

    d__l Network Guru Member

    Sorry, I only have one USB HD at the moment and it is dedicated to the NSLU2 as ext3.

    FWIW, the NSLU2 used to have problems with drops of large files to ext3 and then that was fixed with R29. I guess Linksys will probably eventually fix your NTFS drop problem if others are having it and it just isn't something with NTFS AND your particular USB enclosure. The question is when?

    If others can't duplicate your problem, then it may never get fixed.
  9. Registered

    Registered Network Guru Member

    yeah. that's why I was encouraging people with the problem to write.... ( I noticed there was at least one other person with the problem...)
  10. SeanFL

    SeanFL Network Guru Member

    same here

    same here, and I never realized it had to do with the size. my r63 with a NTFS drive is very unstable...hope they fix it soon! I don't want to spend the time changing the drive back to ext3, then back to ntfs once they get it right.

  11. Registered

    Registered Network Guru Member

    Hey Sean,

    Did you contact Linksys tech support? I already returned the two they had me buy, but I would really like to buy the product, if I thought they would fix the problem. The trouble is that the tech support told me they believe its an isolated issue ( two defective units) but I'm pretty sure that its a bug in the firmware.

    I'm hoping that a firmware update will resolve the problem, but I don't want to be left holding a unit if that never happens...
  12. Pimptastic

    Pimptastic Network Guru Member

    FYI....im also having the same issues

    Need to get another drive so i can test out a drive in ext3 format
  13. Registered

    Registered Network Guru Member

    Hey Pimptastic,

    Have you writen to Linksys yet?

    I keep hoping this will get resolved, as my drive was way more usefull when it was connected to the network...
  14. Pimptastic

    Pimptastic Network Guru Member

    Yes, i have emailed them.

    Was onto tech support ealier today...what a bunch of muppets.

    If they tell me to press reset and turn it off once more....grrrr :sad:

    In the meantime, im gonna downgrade the firmware and convert my drive to Ext3...see if that helps

  15. ffed

    ffed Network Guru Member

    Works wireless

    I also have this problem and can't copy big files from my NTFS NSLU2 accross my network. I've reported it to LinkSys. However one thing I have noticed is that when I do the copy via my wireless access point to a laptop with an 11b card it works (bit slow but completes), if I try to a laptop with an 11g card it fails! So maybe it's a speed thing and it fails because it can't sustain the higher transfer rates.
  16. Registered

    Registered Network Guru Member

    Hi Fred,

    I agree with you that it is a speed issue - cause streaming works well ( streaming is technically reading at a slower pace)

    I'm still convinced that it is a problem with code in the firmware, not with the hardware itself....the question is whether an update will be released anytime soon, or if we have seen the last of the updates for this product, as it is rather old now by computer standards...
  17. Pimptastic

    Pimptastic Network Guru Member

    Just for everyones information

    I recently converted my drive to Ext3 and now all my problems have gone using the latest firware.

    transfer speeds have tripled too.

    Now happy :cheer:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice