NSLU2 Drops connection

Discussion in 'Cisco/Linksys Network Storage Devices' started by yopnono, Aug 9, 2005.

  1. yopnono

    yopnono Network Guru Member

    Hi. I'm using the fw r29 and have also tried the r63 but still i have this issue tha when transfering large file 100mb -> up, it drops connections after a while ( really annoying).

    So the question is is there any other FW that you know works fine?. This only happen when moving files from this unit, not if moving from computer to computer
  2. yopnono

    yopnono Network Guru Member

    Other thing. Also if i can move the file, the file sometime is corrupt.
    (Moving files over windows network)
  3. Oisi

    Oisi Network Guru Member

    which drive are u using?
  4. yopnono

    yopnono Network Guru Member

    Using a lacie USB2 with a SEAGATE ST3250823A. Also if I connect the usb disk to the computer directly it works fine (NTFS).

    Have also tried to connect the NSLU2 directly to computers and it fails to transfer.

    Have tried format the disk using NTFS and EXT3 (built in format).

    It seems that the unit don't like large files, and absolutly not compressed files like rar, zip, compressed .exe files.
  5. Oisi

    Oisi Network Guru Member

    I also have a Lacie with a Seagate drive, mine's a 250gig. Looks like I have the same problem actually. I thought I was okay as I was only transferring small files (mp3s, photos etc..) but now when I try some huge zip files I have it crashes most of the time.
    R29 is a LOT better than R63, at least with 29 it's half useable.
  6. yopnono

    yopnono Network Guru Member

    Maybe it's better with r29, but it's still not like it should. I really can't trust it for backups, since i don't know if the files are going to get corrupted.

    I thought i bought a kind of quality product since it's from cisco/linksys. But so far i guess not.

    Maybe I should try to unsslug it and see it that helps (don't think so)

    Is you disk a laice porche 250
    my disk is. And mabe it's some kind of issue between the disk and unit. Don't have any other disk to try for now.
  7. yopnono

    yopnono Network Guru Member

    Ok I have been playing with the NSLU2.

    And found that if I change the socket settings in the file "smb.conf"

    to this value :

    socket options = TCP_DELAY SO_KEEPALIVE SO_SNDBUF=51200 SO_RCVBUF=51200

    It's seems ok for the moment.
    Using FW 23r63
    EXT3 File format.

    Just boot your windows using a "Linux liveCD" and you will be able to access the disk. Then in one of the partitions, you will find the smb.conf file, just open it using ie wordpad and change the string "socket options"

    As I said it work for the moment, have only tried to transfer files up to 300-400MB, and all are ok after the move, no timeout or corrupt files yet

    I used a linspire LiveCD

    (if you are using linux, you don't need to boot using a liveCD ) :)
  8. yopnono

    yopnono Network Guru Member

    How stupid of me to think that this **** unit should work.
    It 's back to the same, dropt connections, corrupted files etc,etc.

    It's going back to the store, unless I just hammer it with a hammer.

    Nope I'm going back to what I use to have a server in the closet.

    I just never have any problems with it, except the fan nois, So it going to be a laptop with USB Disk and network.

    PS:The support I have received from linksys was not to any help so to speak
  9. uffez

    uffez Network Guru Member

    Has someone been able to resolve the issue of dropped connections? Or, is it HW related? Seems strange, though, that not the entire community has the same problem in that case. Anyhow, I have exactly the same problem. Have tested FW R63, and now I´m running Unslung 5.5 BETA. But, if it is HW related the FW doesn´t really matter... Someone has a clue???
  10. grumpa

    grumpa Network Guru Member

    No "Drops"

    For whatever it is worth ... my upgrade to r63 went without a hitch. All of the "new" features (ie. FTP) work fine. Not a hiccup in about 2 weeks. The connections are faster, and the NSLU2 GUI presents itself much quicker. After reading many of the posts, I copied a 27gb Acronis disk backup from my notebook to the NSLU2 without a problem - albeit it took some time (2.75 hours) ... it was done over a 54g wireless connection through the Belkin Pre-N router. Happy camper here.
  11. roule

    roule Network Guru Member

    I finally solved my Windows networking problems, and now I can mount the FLASH share. ANd the real problems began...

    I tried uploading a large (100MB) and got an error message from Win2K: "The specified network name is no longer available". This happens too when reading the file. Thereafter, problems get worse (as if the damage was in the TCP stack). The share becomes less accessible (more strange behavior), the web i/f starts rejecting connections, &c. And I tried doing a cksum (Cygwin); one time it appeared to go to the end, but didn't give the same check sum as original; but mostly it fails, and Cygwin's cksum "cksum: N:/Tracy2005.MPG: Bad file descriptor". Probably the same error as above.

    Nothing reassuring (I'm on uNSLUng R29). Is anyone actually having success with this device (with large files)? Is it the USB flash that doesn't work well? I won't bother with a HDD until this works.

    Very disappointed at this point in time. Why was R63 reissued (as I just read here)?
  12. uffez

    uffez Network Guru Member

    I´ve experienced lots of problems when copying files. Basically, the SLUG stops it´s network controller and becomes unaccessible. I´ve tested using R24 and R63. Now, I´m running Unslung Beta 5.5.
    Anyway, I decided to upgrade the samba SW, which I did using the howto. Then I changed one parameter in the smb.conf to remove buffer handling. Basically, the line that I use is now:
    socket options = TCP_NODELAY (samba default setting)

    And, voilá, at the moment (at least) I´m able to copy > 1 GB files to my 250 GB LaCie disk.

    I don´t know if this is a solution to the problem, or if it is just a temporary shift of mood in my SLUG....

  13. roule

    roule Network Guru Member

    Very interesting... (and kind of matches my theory about stack problems). So worth a try. At any rate, I'm about to go opeNSLUg (which hopefully has a better SAMBA). I'll look into this particular option and what it means.

    Another thought. Could part of my problems come from not having an HDD in USB1? Ie. maybe the slug doesn't like running without a real HDD?

    For now, I'm holding on to the H/W on the assumption that it's a S/W problem with can be fixed with lots of patience or work...
  14. uffez

    uffez Network Guru Member

    My view is the same as yours, Roule, that I hope this all boils down to SW problems. The difficulty, of course, is to find the problem. Anyway, I ´ve managed to keep it alive all night backing up another machine (roughly 50 GB copied so far).
    In order to at all trace faults you must have at least uNSLUng. I´m also interested to try the opeNSLUg, but since I´m not a Linux expert I´m still hesitating. On the other hand, the web-i/f functions are fairly simple to handle through command-line options, mainly in Samba.

  15. yopnono

    yopnono Network Guru Member


    Did get my new relaced NSLU2 yesterday and hav tried it.....
    To no success the same whit this box. The store will refound my for this no good product.
  16. DirtHerder

    DirtHerder Network Guru Member


    I'm having the same problems.

    I was hoping a solution had been found.

  17. jaytkay

    jaytkay Network Guru Member

    I'd pretty well given up on the NSLU2 because of this issue. After upgrading to R63 with no change in reliability, I phoned Linksys tech support.

    Everything else on my network works fine - PCs, Macs, Linux, print server, 802.11g repeater. Everything connects flawlessly.

    Spent over an hour on the line. The guy was tremendously thorough about testing my network configuration. I have a Linksys DSL router, a Netgear switch and a D-Link wireless router/access point on the network, and he patiently walked me through every conceivable combo of plugging things together and turning things off and moving things upstream and downstream.

    Oddly, the only thing that seemed to improve the NSLU2 connection was turning off the D-Link wireless DI-624. Which isn't really a viable solution for me. And it only improved a little. I still can't copy a 700MB file off the NSLU2.

    And, also odd, he didn't touch the NSLU2 settings.

    Either they don't have a handle on this, or they aren't sharing it with tech support.
  18. d__l

    d__l Network Guru Member

    Is everyone having problems with this trying to use UPnP on the NSLU2? Perhaps if you had UPnP support enabled, you might try disabling it and re-testing.
  19. jaytkay

    jaytkay Network Guru Member

    I just disabed UPnP. Rebooted all the devices on the network.

    No change
  20. d__l

    d__l Network Guru Member

    Oh well. I have read that UPnP on the NSLU2 has been known to cause dropping problems.

    I wonder if you simply have a defective unit?
  21. jaytkay

    jaytkay Network Guru Member

    Another note: I can write a 700mb file to the NSLU2. But I can't copy it back to the Windows machine.

    Via Windows directory browsing and FTP, the transfer always fails within a minute.
  22. jaytkay

    jaytkay Network Guru Member

    Another note:

    Copying a 700MB file to the NSLU2 is OK. Via both Windows directory browsing and FTP.

    It fails when I try to retrieve the file, again via Windows directory browsing or FTP.

    The thing receives data OK, but doesn't send.
  23. jaytkay

    jaytkay Network Guru Member

    And yet another note:

    The NSLU2 works fine for smaller files.

    Right now:
    -- My laptop is playing MP3 files from the NSLU2
    -- My desktop copies new MP3s to the NSLU2
    -- I'm clicking around the WWW administration screens
    -- While browsing via FTP

    I just can't pull a big file from it.
  24. Registered

    Registered Network Guru Member

    Actually I have the exact same problem.
    I can write to the device as much as I like, but anytime I try to copy off files, it craps out with the message

    " Cannot copy filexx: The specified network name is no longer available"

    When streaming files, I don't have this problem.

    I'm on my second unit, and have spent many hours on the tech chat support.
  25. kn0xster

    kn0xster Network Guru Member

    Yeah me too. I put a post up on the other thread "NSLU2 crash?".

    I'm sure this thing should work. I get the dropped connection when copying loads of files either way. i'm tempted to try openSlug on it but then its going to take time to configure and if i still have problems I wont be happy.

  26. PedrosPad

    PedrosPad Network Guru Member


    I connected a full NTFS 250GB HDD to Drive 1, and a new 250GB ext3 formatted HDD to Drive 2.

    I couldn't get the NSLU2's built in backup toolz to help, so simply opened a window to both drives on an WinXP client, and dragged all the files to the empty Window.

    It kept failing with the error message you state. I spent about 8 evenings playing with it. :(

    I finally gave up and simply plugged the NTFS HDD directly into WinXP client, and dragged the files into the empty NSLU2/ext3 Window. It took 4 days to copy (USB1.1 on client), but no crash! :)
  27. bthessel

    bthessel Network Guru Member

    I just purchased a NLSU2 yesterday, upgraded the firmware to r63, formated my external drive using the built in format and did not see any problems transfering large files to it. I mapped a network drive to on my Windows machine to the disk 2 share and moved 87 GB of files onto it with no problems at all. Many of the files were larger than 1 GB some as large as 3 GB. I don't know how long it took since I started it before I went to bed and checked it this morning and it was all done.
  28. kn0xster

    kn0xster Network Guru Member

    Thanks that really helped :drinking:

    I wonder if its an issue with the laclie drives... any one got one that works?

    I put the 29 firmware back on just now and now it wont even format the drive.

    I will get this to work... I will...

  29. d__l

    d__l Network Guru Member

    bthessel, what drive enclosures or model of USB drives were you using? That may make a difference for successful large file transfers.
  30. bthessel

    bthessel Network Guru Member

    I've got a Seagate 200 GB drive in a Metal Gear Box enclosure.
  31. peterdesan

    peterdesan Network Guru Member

    Has anyone manged to find a fix to this problem.
    We purchased the NSLU2 with a maxtor 80gig HD, usb port1 formated NTFS

    We set it to daily backup of our server with cumulitive file size of 11gig. It seems to copy all the files, but then the NSLU2 a few minutes into the backup drops of the network and is not accessable unless i restart it

    I also find sometimes the clock dont keep the right time
  32. volshmiel

    volshmiel Guest

    Dropped Network Connection

    I'm having the same problem. I get the error message, "Cannot copy: FILENAME. The specified network name is not available."

    It was after the firmware upgrade to Linksys 2.3r63 when I started having this problem.

    I upgraded to Linksys Firmware 2.3r63 from r29 because it allowed the NSLU2 to access NTFS-format drives. I liked the option of plugging it directly to my system and the option of taking it to other systems.

    I wonder if it simply must have only an ext3 drive to work. Very frustrating. This effectively renders the device useless. I can't rely on it to transfer files.
  33. Registered

    Registered Network Guru Member

    volshmiel, have you written to linksys tech support? So far they don't beleive that there is a problem with device under NTFS
  34. jaytkay

    jaytkay Network Guru Member

    FWIW, my NSLU2 doesn't work any better with r29 over r63.

    But with r63 the slug works badly with NTFS, not just EXT3! Progress!

    Linksys tech support doesn't read these forums? Seems like an obvious resource for them.
  35. Pimptastic

    Pimptastic Network Guru Member

    I am also having this exact same problem.

    received my NSLU2 yesterday...set it up yesterday and everything went smoothly.

    I updated the firware to the latest version and though everything was cool.

    then i tried to copy a 800mb file from the NSLU2 to my PC and after about 10 seconds of copying i get the dreaded "Cannot copy filexx: The specified network name is no longer available".

    Copying same size files to the device is fine...no problems at all.

    Streaming a movie from the unit is also fine...it is only when trying to COPY large files from the device.

    Really hope someone can come up with a solution.

    Tried most things in this thread, need to try chaging the settings in the "smb.conf" file...see if that make a difference.

    FYI...my NSLU2 is connected directly to a netgear router, along with my PC and my XBox
  36. Pimptastic

    Pimptastic Network Guru Member

    Just for everyones information

    I recently converted my drive to Ext3 and now all my problems have gone using the latest firware.

    transfer speeds have tripled too.

    Now happy :cheer:
  37. slkwcy

    slkwcy Guest

    NSLU2 not hanging anymore

    Just like to say thanks for all those who posted. By gathering all information, I decided to try reformatting my USB disk to EXT3 format for usage with NSLU2. That took more than 2 days to complete with all the files I had.

    But after that, no more hanging and had been running smooth for weeks now without reboot.

  38. DirtHerder

    DirtHerder Network Guru Member

    Just wondering if anyone has been able to resolve this problem using NTFS formatted drives.

    My NSLU2 has pretty much been collecting dust since my last post in this thread.

    Incidentally anyone know of any other alternatives for an NSLU2 (have a bunch of external drives that need to be connected to the network). Kind of tired of waiting for Linksys to fix this. :thumbdown:
  39. Maldrien

    Maldrien Guest

    Any news on that particular problem?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice