NSLU2 getting slow transfer speeds

Discussion in 'Cisco/Linksys Network Storage Devices' started by Chicken, Jan 20, 2006.

  1. Chicken

    Chicken Network Guru Member

    I got my NSLU2 today and installed it with one Maxtor DiamondMax10 7200RPM 200GB 8MB S-ATA in an IcyBox 351 St-US enclosure.

    I'm getting transfer speeds from and to the NSLU2/HD of 4.7MB/s maximum.
    Connected to a WRT54GSv1, so it's 100Mbit/s.

    Using the newest firmware by Linksys 2.3r29 (looks likes its the newest one on the website, i dunno how u guys got r63)

    The disk is EXT3 formatted

    Someone experience the same issue? Or this is normally for the NSLU2?

    I also noticed that opening a file, in my case a video file, it have to load a few seconds before it loads in your mediaplayer. After it's playing, i can skip forward without lag.
  2. d__l

    d__l Network Guru Member

    That sounds reasonable for the transfer speeds you can expect. It isn't a speed demon. In some comparative reviews of transfer speeds between it and other NAS devices, it was one of the faster units available, but not the fastest of all.

    Writing a file directly to the NSLU2 is definitely faster than using a Data Backup job that you have set up.

    The r63 firmware is right there on the Linksys web site under the firmware link on the NSLU2 product page. You can't miss it. :)
  3. dcrane6

    dcrane6 Network Guru Member

  4. gelan

    gelan Network Guru Member

    That's 100 mega bits per second. And 4.7 mega bytes per second. To find the equivalent in megabytes per second, you divide the 100 by 8, which gives you a maximum of 12.5 megabytes per second. take away a few for network overhead and the rest being limited by the NSLU2 itself. God (and the linksys engineers) only know why they underclocked the CPU in it.... boggles the mind. It was probably some "low-power" or "minimal heat" things that the marketing department wanted them to do.
  5. Chicken

    Chicken Network Guru Member

    Is this possible without using the Unslung firmware? I'm using Linksys's 2.3R29 (this is the newest i got on the linksys site, netherlands). Maybe's i have to look at the global site vor R63?

    Another thing... i can't find how to telnet to the nslu2? (and why they call it "slug"?)... i tried telnet
  6. custk9

    custk9 Network Guru Member

  7. Chicken

    Chicken Network Guru Member

    Thanks custk9, but before i upgrade i want to know something...

    Firmware Date: 7/06/2005
    Firmware Release Version: 2.3 R elease 63

    Firmware Date : 1/12/2005
    Firmware Version : 2.3 Release 29

    Looks like R29 is newer?

    What advantage i'll get with using unslung?

    I read the R63 supports NTFS/FAT32 on USB2 and FAT32/EXT3 on USB1...
    According to what i researched, I can only set user rights/groups/access/shares on an EXT3 formatted drive....
    So, It's possible to put in a USB-stick on USB1, like an 128MB USB-stick and format it to EXT3 and use that to put the groups/access/shares info on it? And then use a FAT32 or NTFS harddisk on USB2 to store the data.....

    In this case, the original R63 is better or the Unslung 6.x ?
  8. d__l

    d__l Network Guru Member

    R63 is the newest firmware available.

    I don't think the NSLU2 will let you format flash or any drives smaller than 10 GB. It recognizes drives smaller than 10 GB as a FAT32 drive.

    I don't know this for certain but I believe that the groups/access/shares info resides on the ext3 drive that it pertains to.

    Also the NTFS implementation is buggy and I wouldn't recommend anyone using it if possible. Large transfers to an NTFS drive often drop after a few minutes of transfer.
  9. Chicken

    Chicken Network Guru Member

    How about a drive with several partitions...

    I thought someone did it here...

    I was thinking of a disk (200gb) in 2 partitions...
    The first one, small partition formatted with EXT3 (using partition magic).
    The second, the rest of the space, using FAT32 since NTFS is bugged.

    Will that work? And is FAT32 bugged or not?
  10. d__l

    d__l Network Guru Member

    I can't say about multiple partions with different formatting. I don't think anyone has reported on that possibility, only multiple partions of the same type.

    FAT32 drives seem to work reliably within the standard limitations of no groups/access/shares and no ID/PW changes. At least I have never had a connection drop when testing transfers of large folder/files to a flash drive.
  11. Chicken

    Chicken Network Guru Member

    I just found out why the NSLU2 makes 3 partitions on the disk when you format it through the webinterface. It's to be recognized by the NSLU2. So... preformatted EXT3 drives (with just 1 big partition) can't be recognized by the NSLU2.

    The two small partitions, one of them is formatted in EXT3, the other isn't formatted (Windows can't read it, using ext2fsd driver).

    When you format the disk on the NSLU2 you get (in my case a 200GB HD)
    1. EXT3 (189GB), 2. EXT3 (117MB), 3. EXT3 (55MB unformatted/unreadable)

    The first partition, EXT3, there are the files stored which you put in through a share.
    The second partition, EXT3, got the share/groups/users/passwords stored.
    The third partition, probaly EXT3, Can't read

    When I try the following....

    - Format the disk using the NSLU2
    - Convert the first EXT3 partition to FAT32 with Partition Magic
    The NSLU2 can't see the FAT32 partition.....

    - Format the disk using the NSLU2
    - Resize the first EXT3 partition to 10MB using Partition Magic
    - Create a new FAT32 partition (189GB)
    The NSLU2 can see the FAT32 partition and appears as a share with the name HDD_1_1

    I tried to use users/groups/access, they all will be stored on the 117MB EXT3 partition.

    Windows can read the FAT32 partition and the NSLU2 can... the only bad thing is... It's better to use NTFS, but its bugged according to a lot ppl here. Limitations of 4GB per file....

    I hope this works and FAT32 isn't bugged like NTFS, gonna try to copy about 150GB of files to it and watch if it's gonna hang/crash

    To give a summary... my harddisk looks likes this:

    1. FAT32 (189GB)
    2. EXT3 (10MB)
    3. EXT3 (117MB)
    4. Unknown (55MB)

    2,3,4 are created by the NSLU2. 2 was resized with partition magic.
  12. d__l

    d__l Network Guru Member

    Yeah, I should have mentioned that the ext3 partition the NSLU2 creates isn't 100% the same as a standard Linux ext3 partition, but has two other "hidden" (hidden from NSLU2 view) partitions.

    Good luck on your multi-partition experiment. FAT32 isn't the best choice for the second partition, but what else can you do when the NTFS functionality needs work. Maybe the next firmware version will fix NTFS.

    Let us know how it all works out for you. I'm sure many people might benefit from your results.
  13. Chicken

    Chicken Network Guru Member

    Damn, i almost thought it worked till it tells me "Can't use share/groups/access on shares starting with HDD_ or FLASH_"
    That means, even if there are the standard ext3 partitions formatted by the NSLU2.... the other kind of partitions (FAT32/NTFS) will be automatically shared and can't change the access/groups/users
  14. dcrane6

    dcrane6 Network Guru Member

    It's absolutely possible to do without running the Unslung firmware. I know because I did it, and have had it running stable for the better part of 6 months now on the stock R63 firmware. All that's involved is a simple removal of a resistor on the board, and you're good to go. Just follow the directions in the link I provided for you. :)
  15. Chicken

    Chicken Network Guru Member

    Ok, thanks, I'll do it soon. You only removed the resistor, right? No things like a little heatsink on the cpu?

    And... the thing is getting some performance increasements? I mean, the speed transfering through the network which is normally around 4-5MB/s
  16. d__l

    d__l Network Guru Member

    From what I've read at www.nslu2-linux.org and what friends have told me, removing the resister didn't improve the transfer speeds appreciably, but did improve the speed of the GUI pages. I've thought that other functions such as scans and back up jobs might be accelerated also.

    Your mileage may vary. If you do plan to remove the resister, you might check the times on some functions/operations and the transfer speeds both before and afterwards to see if there is an improvement.
  17. Chicken

    Chicken Network Guru Member

    Ok, I removed the resistor following that guide and it runs a lot faster now. The webinterface is way faster...

    I also notice a faster transfer speed to and from the NSLU2!!

    It's getting around 6MB/s now, before it was not more then 4.7 at maximum and unstable speeds. Now the speed is also a lot more stable!

    Soon i'm gonna get some small heatsinks and put it on the cpu
  18. gelan

    gelan Network Guru Member

    *laugh* I start spouting my mouth off and here I go with slow transfer speeds. 1.9-2.0 is my average. nothing less, nothing more. I de-underclocked it, unslung it and upgraded to samba 3, no change. What am I doing wrong?
  19. dcrane6

    dcrane6 Network Guru Member

    Glad to hear it, and that sounds very similar to my results. :thumb: :

    Now go enjoy those nice fat transfer speeds. Well, fat in comparison. :D

    Edit: That's a nice idea for the heatsinks, let me know how that pans out for you.
  20. d__l

    d__l Network Guru Member

    Possibly the USB chipset in your drive enclosure may be holding your speeds down?

    Also are those your average transfer speeds for one large file, say more than a 100 MB or many smaller files from a folder. Try watching a NetMeter throughput graph of a multi-file transfer sometime. There are starts and stops in the throughput and the transfers never get up to the full speeds of a single large file.

    I'm wondering if small file transfers maybe where overclocking would really shine as this should be more CPU processor limited than simple large file writes?
  21. gelan

    gelan Network Guru Member

    It's one single large file, and I don't use windows, I use Mandriva Linux so this "Net Meter" probably won't work for me.

    I doubt that it's the USB chip in the enclosure, I've seen speeds up to 50Mb/s when this drive and enclosure were hooked up to my desktop directly. It's a Vantec Nexstar 3 enclosure, not cheap, so I don't think that it's a factor.

    KDE allows you to see your transfer speeds natively as you copy a file.
  22. gelan

    gelan Network Guru Member

    hmm... I just borrowed my girlfriend's laptop and set up the NSLU2 share on her computer and proceeded to copy a large video file, and it transferred quite quickly. This tells me that it's something on my desktop and linux that is causing the bottleneck, which is weird.... Well, on to the linux forums to figure this one out ;)

    Thanks again.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice