NSLU2 - USB HDD intermittently recognised

Discussion in 'Cisco/Linksys Network Storage Devices' started by mawwoods, Jan 12, 2005.

  1. mawwoods

    mawwoods Network Guru Member

    Very much liked the idea of the NSLU2, so got one and plugged my 80gb hard drive in a (no name brand) case with a usb connector. All seemed to be working ok.

    Now I am trying to get data off the drive, but the problem is that the NSLU2 seems to 'lose' connection (ie when I log onto the administration page it cannot see any drives). This means I cannot get access to any data on the drive....bit of a worry!

    Thing is, the hdd and enclosure have been rock solid in terms of stability when I was previously using it with windows (and no I have not tried to reformat it back to NTFS).

    I have found that when I connect it to a Linux PC (fedora core 3) it recognises it every time, and I have been able to extract the data off it. Further, when I plug the drive back in to the NSLU2, it recognises the drive again, but only for about 5 mins (but only if I connect it to the linux pc).

    Anyone have any ideas about this? Anyone else had similar problems?
  2. gregh

    gregh Network Guru Member

    I too have been haveing the same problem, exactly as you described it. The drive is recognized with no problems when attached to suse 9.2. The NSLU2 will **sometimes** at least acknowledge that the drive, by lighting up the drive 1 light; but it still says that there is no drive attached in the admin menu.

    The only thing that I think it could be is some incompatibility with the enclosure. I am using a "Back-Up Q" with a samsung 160 GB HD, both purchased from newegg. I hope it is not this, though, because for the money this is a really quality enclosure.

  3. mawwoods

    mawwoods Network Guru Member

    Yeah, that is exactly the problem I have, NSLU2 puts the LED for the USB port on, but nothing in the admin screen!

    It seems a bit of a shame to replace a case just on the off chance it has some sort of compatability problem with the NSLU2. The case already supports USB 2.0, so it should be fine for the job and I have not seen any documented problems.

    For a while I thought it might be that the drive was overheating and dropping offline, but keep coming back to the fact that it works consistently without any problems whatsoever connected to a pc with linux, and prior to being reformatted, with windows.

    VERY frustating!
  4. gregh

    gregh Network Guru Member

    Ok, I bit the bullet and bought a new HD enclosure (compusa brand, from compusa). The drive was immediately recognized, and it has been up and running for 24 hours. I did an automated backup of our system server (hopefully the nslu2 will replace this), and all files--including large (1-3 GB) files--were transfered problem free. I would say it was 24-48 hours after I did this the last time that I started having problems.

    I have it set up to do incremental backups of the server every night. I will allow it to do this for a week, and then report back as to the stability of the system.

    One other note is that I did upgrade the firmware to r29 a few minutes ago. This has had nothing to do with my success thus far, and hopefully the combination will prove successful.

  5. bdl99

    bdl99 Network Guru Member

    I've made three observations

    1) With most of the enclosures try removing the jumpers from the HDs. I've found with the drives set as master you tend to get a hit and miss recognition of the drive. In other words the Drive LEDs on the NSLU2s don't always come on.

    2) With the R21 firmware I noticed that some times it would loose connection and the drive would no longer appear to be accessible. Upgrading to R25 or R29 fixes this problem.

    3) Before finding the remove the jumpers trick, I found if the drive LED comes on but the unit fails to mount the drive, restart from the web interface and the unit always restarted with the drive(s) correctly mounted.

    I now have several units than run without any problems and no fear of restarting.
  6. mawwoods

    mawwoods Network Guru Member

    From the advice above, and on one of the other threads I have removed the jumper from the hard drive to make it a slave. I have also upgraded to the most recent firmware (the one released Jan 2005).

    And as such I have not had any problems, so far it seems to be stable. So I am very happy about that, because it does seem to be an excellent product.

    So that seems to be fixed for now. If it does start playing up again I will post here again.

    anyway, thanks bdl99, your advice seems to have fixed it!
  7. VTrider

    VTrider Network Guru Member

    Gregh - Do you know who makes that CompuUSA branded enclosure? I have the same problem you were having with your Back-Up Q enclosure - I have a 'rosewill' enclosure - just an OEM version of the Backi-Up Q I believe - same chipset which is not compatible from what I read with the NSLU2.

    I'm just looking for a compatible enclosure so I can leave all these problems behind, thanks.
  8. Sbelew

    Sbelew Network Guru Member

    I am also using the Compusa branded USB 2.0 enclosures. Both have 120g WD hard drives in them and both are working flawlessly. I use the backup disk 1 to disk 2 option.
  9. ajnodine

    ajnodine Network Guru Member

    I'm using the 35.00 coolmaster usb 2 enclosers from newegg and they both work great. Both have a different 200 gig drive.
  10. gregh

    gregh Network Guru Member

    I am not sure, other than it is made in china, and has a controller chip manufactured by CYP.

    I guess now is a good time to update my success (and failure) with the slug. The drive has been up and running for about 2 weeks now. I have had no further issues with intermittent HD recognition.

    I have had some headaches with the initial file transfers. I had the system set up to do nightly incremental backups of our old NT4.0 fileserver. This was so that I could get a feel for how stable the new setup would be, as well as keep all of the files fresh. The first day that I turned off the NT4.0 server I began to notice that a few files were corrupted. After doing a directory compare (with beyond compare 2) I realized that many, if not most, of the files on the slug were corrupt. It turned out that many of the files transferred durring the inc. backups were somehow exactly 8 hours older than the origional files copied. It was only these files that were corrupted, and I don't know how they got that way. Luckily, they were all old files--so they were easily replaced from backups. I am not sure if there was a problem in my setup, or if there are bugs in the backup code.

    I can now report, though, that the setup is now stable (for ~2 weeks) and I have not had any more problems with the system.

    Here is a quote from the little slip they put in with my compusa enclosure:
    Is good with machine plank accoridng to the right method conjunction the hard dish , lock the tight and HDD, cover the upper cover, can immediately trust the usage

    Now I KNOW it will work because can immediately trust the usage
  11. gregh

    gregh Network Guru Member

    Just found out the Manufacturer info:

    Manufacturer: FMI
    Manufacturer Model Number: HD-338-U2C
    CompUSA Model Number: 312100
  12. VTrider

    VTrider Network Guru Member

    This NSLU2 has been nothing but a headache for me since I got it - I know it's just a matter of time until I find an enclosure which will work with it - i've checked the database here and found some that i'm going to try. The enclosures I have use the GenisysLogic GL811E chipset, which judging by other messages I've read here is buggy with the NSLU2.

    I just can't wait until these problems are gone, it's frustrating (costly too).

    (Thanks gregh and everyone else for posting your enclosure info!)
  13. ajnodine

    ajnodine Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice