NSLU2 v2.3R76 Beta firmware

Discussion in 'Cisco/Linksys Network Storage Devices' started by Toxic, Sep 2, 2007.

  1. Toxic

    Toxic Administrator Staff Member

  2. danysnow

    danysnow Guest

    I have installed this version.

    I have tray with only one HDD and the NLSU2 work ok.
    I have try to connect by internte behind a VPN connection and thi work wery well.
    I have try to connect my USB Disk formattet NTFS and i don't see the disk !

  3. kevanj

    kevanj LI Guru Member

    Seem to have discovered an oddity with R76....

    I have a photo collection on my NSLU2, and use Photoshop Elements 5 downloader to grab pics off memory cards that are plugged into a photo printer. I upgraded from R25 to R76, and everything appeared to be working OK, but I began receiving errors in Photoshop saying "Cannot write to the specified directory" when I select one on the NSLU2 to transfer pics to. The upgrade to R76 was the only change, so I backed down to R73 and it started working again....Oddly enough, from the PSE downloader I could create a new directory, but when I tried to select it for transfer, I got the same error (R76). Also, I was able to create directories and files from the OS, so it wasn't a permissions issue. I would have thought that PSE would use standard Windows (Vista) files transfer protocols, so the reason for this problem is unclear at this point....
  4. lbealsjr

    lbealsjr Guest

    "No enough free space"

    When I tried upgrading my NSLU from r73 to r76 I got an error that said, somewhat ungrammatically, "Upgrade: no enough free space".

    Anyone else see this?

    Nevermind, turns out you have to shutdown attached drives when you upgrade or you get this error
  5. Toxic

    Toxic Administrator Staff Member

  6. Talisker

    Talisker LI Guru Member

    Flash a new firmware


    Can I flash this new firmware from the web interface if I'am using the Unslung 6.8 ? :)
  7. snooze7555

    snooze7555 Network Guru Member


    Yes you can, no problem
  8. gimpazilla

    gimpazilla Guest

    Just installed this. Looks like the Vista native backup software now works when backing up to the slug. Can't see any other diferences.

  9. Talisker

    Talisker LI Guru Member

    It works with me as well

    XP and VISTA client / NSLU 266 Mhz and WD MyBook 500 Go
  10. zonly1

    zonly1 Guest

    Whenever i try to download this file, it gives me a permission error. Am i doing something wrong?
  11. Toxic

    Toxic Administrator Staff Member

    Beta Firmwares have been removed due to the fact that firmwares are not allowed to be downloaded by anyone without the source code being made available as well. Since LinksysInfo.org has not been given the source code or a link to it for each individual firmware, we are therfore unable to allow downloads of Beta Firmware anymore.

    If you need to contact anyone about this, please visit http://www.fsf.org/licensing/licenses/gpl-faq.html first of all. Then contact one of the departments here: http://www.fsf.org/about/contact.html

    You may only want the firmware, but without source code, we are not allowed to issue it to you. Sorry but thats not my decision :(
  12. TODDBG80

    TODDBG80 Guest

  13. zserver

    zserver Guest

  14. arobase58

    arobase58 Guest

  15. robomonkey

    robomonkey Guest

    In the same boat here... if someone can shoot over the firmware... greatly appreciated.

  16. kurtstricker

    kurtstricker Guest

    I'm in the same situation

    Please send to me at kurtstricker(at sign)yahoo.com

  17. anthony415

    anthony415 Network Guru Member

  18. fostex68

    fostex68 Guest

    Could please anyone send it to


    Thank you!
  19. Bengt_L

    Bengt_L Guest

  20. slug_owner

    slug_owner Guest

    Please send me copy too:


    tanks a bunch in advance!!!
  21. christis

    christis Guest

  22. rmathews

    rmathews Guest

  23. memnemon

    memnemon Addicted to LI Member

    if it is around... I'd like a copy of v2.3r76 as well... memnemon (at) hotmail.com

    btw, I see a few requests going back to march - has anyone who has asked got a copy ?
  24. mstombs

    mstombs Network Guru Member

    This beta firmware should be requested from Linksys, it was readily available on the Linksys beta website when I last had access (along with old betas 71, 72, 73, 75). Hopefully if enough people ask Linksys will be encouraged to finish the firmware and release the code and GPL sourcecode which is long overdue!
  25. snooze7555

    snooze7555 Network Guru Member

    I send you the firmware r76
  26. memnemon

    memnemon Addicted to LI Member

    Many thanks - arrived and installed - much appreciated.
  27. Kinux

    Kinux Addicted to LI Member

    As I have connection problems from XP command prompt to my NSLU2 v2.3R63 I would like to check this R76 beta version too.

    If anyone can send a copy to : rainbowcastel [a t] gmail .com would be great to see the result.
  28. Rabbit05

    Rabbit05 Guest


    I have the same problem. Can anyone send me a copy to: uros.okorn(at)siol.net

    Thnx Uros
  29. snooze7555

    snooze7555 Network Guru Member

    i send you v76
  30. snooze7555

    snooze7555 Network Guru Member

    I send you V76
  31. Hans716

    Hans716 Guest

    I kindly ask to send a copy of the latest (beta) firmware to: ford.probe@telering.at

    thank you in advance!
  32. Kinux

    Kinux Addicted to LI Member


    Thanks a lot for the firmware. The update went well but have still problem with Command Prompt name resolution.

    I'm going to open a new thread for my problem.
  33. zantos

    zantos Guest

  34. CyQuesT

    CyQuesT LI Guru Member

    Could someone send me to Dirtylittelhelper[@]gmx.net
  35. pepotefer

    pepotefer Guest

  36. 94eg6hb

    94eg6hb Guest

    been looking forever for this firmware.

    can't believe after one update all my problems were solved.

    Much thanks...
  37. brocher

    brocher Addicted to LI Member

    I've also been looking forever for this firmware.

    if someone could send a copy to wull.dickson@gmail.com I would be forever grateful.

    Many Thanks
  38. yarilo

    yarilo Guest

  39. raserdk

    raserdk Guest

  40. brocher

    brocher Addicted to LI Member

    Any chance of sending a copy of the firmware to broch71@yahoo.co.uk please

    Thanks in advance
  41. sources

    sources Guest

  42. Babbel00

    Babbel00 Guest

    This one might solve my current problems.
    Hopefully someone is kind enough and willing to send the firmware to:


    Thanx in advance ! I'll owe you one.. even if it doenst solve my probs :)
  43. pannetron

    pannetron Guest

    Please, please, please send me the R76 firmware, too!! russ[@]s-cars.org
  44. xopotl

    xopotl Guest

    NSLU2_V23R76 firmware

    I'm having the exact same issues.
    Could i receive a copy of the NSLU2_V23R76 firmware image as well.


  45. topolinik963

    topolinik963 Guest

  46. chajnik

    chajnik Guest

    I would very much appreciate anybody for sending FW R76 to k_chajnik@web.de (please!).
    Thanks a lot in advance!!!
  47. tiloup

    tiloup Guest


    Please, would someone be kind enough to send me a copy of the firmware NSLU2 v2.3R76 Beta Firmware to: mmingard@hotmail.com
    Thanks a lot!!
  48. Toxic

    Toxic Administrator Staff Member

  49. bbbc

    bbbc Addicted to LI Member

    Anyone place a request for v2.3R76 firmware source code?

    Anyone place a request with Linksys for the NSLU2 v2.3R76 firmware source code?

    I'm hoping we can see a new version of Unslung based on the v2.3R76 firmware for better Vista compatibility.

    Thank you rwhitby for your hard work through the years.
  50. BrianCooke1

    BrianCooke1 Guest

    Me too please! Could someone send me a copy of v2.3R76? Thanks very much.

  51. mstombs

    mstombs Network Guru Member

    For the V2.3R76 firmware see Toxic's link 3 posts up. Do join me in requesting source-code from Linksys, I'm sure its on the way...
  52. D@niel

    D@niel Guest


    i've just got my nslu2 and i found a firmware called v2.3RA5. Does anoybody know what this firmare is, and if V2.3R76 is newer or older?

    On the german linksys homepage i've found as latest firmware: V23RA5 (ETSI) 9/26/2005, so it seems to be a very old firmware, but i've read alreday that linksys ship the new nslu2 with R7x er firmwares?
  53. mstombs

    mstombs Network Guru Member

    2.3RA5 is a bit newer than 2.3R63 - check the Linksys GPL opensource ftp site - its 3 years old.
  54. mstombs

    mstombs Network Guru Member

    The GPL source-code for versions V23R73 and V23R76 have now been posted on the FTP site. Thank-you Linksys.

    On my system a couple of tweaks are needed for this to compile

    1) Change reference in mklinks.sh from /samba-3.0.20 to samba-3.0.22


    2) copy lib/libcrypt_old from V23R63 (which did compile) to V23R73 build dir

    cp /home/user/NSLU2_V23R76_GPL/linux-2.4.x/arch/arm/boot/zImage /home/user/NSLU2_V23R76_GPL/images/zImage
    | Build Complete
    | Images are in /home/user/NSLU2_V23R76_GPL/images
    | As root, copy the images to /tftpboot
    |  Load the images using the RedBoot v1.92  commands:
    |    load -r -v -b 0x01600000 zImage
    |    load -r -v -b 0x00800000 ramdisk.gz
    |    go -n 0x01600000
    make[1]: Leaving directory `/home/user/NSLU2_V23R76_GPL/vendors/Intel/IXDP425'[/code]

    The image is the same size as the official firmware, which is a good sign

    root:# ls -laF
    total 22320
    drwxrwsr-x  3 2043 1505    4096 2008-11-02 22:04 ./
    drwxrwsr-x 16 2043 1505    4096 2008-11-02 22:00 ../
    drwxr-sr-x  2 2043 1505    4096 2005-03-16 06:06 CVS/
    -rwxr--r--  1 user user 8388608 2007-08-07 17:59 NSLU2_V23R76.bin*
    -rwxrwxr-x  1 2043 1505      78 2004-05-28 06:40 bb*
    -rw-rw-r--  1 2043 1505     113 2008-09-04 07:36 dongle.pid
    -rw-rw-r--  1 2043 1505     241 2004-05-28 06:40 image.par
    -rw-rw-r--  1 root 1505 8388608 2008-11-02 21:58 linux.bin
    -rwxrwxr-x  1 2043 1505   19862 2004-05-28 06:40 mipsBind*
    -rw-r--r--  1 root 1505 4740128 2008-11-02 21:42 ramdisk.gz
    -rw-rw-r--  1 2043 1505     376 2004-05-28 06:40 readme
    -rwxrwxr-x  1 2043 1505  245000 2004-05-28 06:40 redboot.bin*
    -rw-rw-r--  1 2043 1505     211 2004-05-28 06:40 version.txt
    -rwxr-xr-x  1 root 1505  987276 2008-11-02 21:42 zImage*
    redboot also compiles, but there are lots of warnings and image is way too small...

    -rwxr-xr-x  1 root 1505 161964 2008-11-02 22:01 redboot.bin*
    so I won't be trying that...
  55. lastdim

    lastdim Addicted to LI Member

    Cannot view all files

    Hi everyone,

    I have this V2.3R76 firmware installed on my NSLU2 and one NTFS 500GB drive connected to it .

    The problem is that I do not view all files or subdirectories in the directories; it displays more or less 300-400 files less at each directory.

    Anyone else noticed the same? Any fix for that?

    Also, if anyone has a more latest firmware from that will be highly appreciated.
  56. rodry

    rodry Networkin' Nut Member

    Could someone send me a copy of v2.3R76? Thanks very much.

    marcorod (at)tin.it
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice