NSLU2 Write-protect error

Discussion in 'Cisco/Linksys Network Storage Devices' started by ControlTech, Sep 6, 2005.

  1. ControlTech

    ControlTech Guest

    My NSLU2 has suddenly just decided that the attached hard drive is write protected. Whenever I try to copy a file to it I get the standard Windows message saying access is denied - make sure disk is not full or write protected. I haven't changed the configuration of the NSLu2 at all - in fact I have just reset it to the default config. The hard drive is not full (95% empty) HELP :cry:
  2. helsten2

    helsten2 Network Guru Member

    This is a known problem (read through the forum). Has happened to me 5 times. The NSLU2 may also suddenly tell you that the disk is unformated.
    The only way I was able to recover from the 'write-protect' error was to re-format the disk (you need to copy your data to another disk if you want to keep them)
    Reformat was also the only way I was able to recover from the 'not formated' error (lost all data, though).

    Needless to say, I am not using the NSLU2 anymore and I don't recommend it to anybody! Sorry.
  3. wkaml

    wkaml Network Guru Member

    I have been through the recovery process of coping all the data to a different disk, reformatting and coping the data back before. The second time my NSLU2 decided to show all data as write protected I could not believe it and decided that I am not willing any longer to copy 190GB somewhere else and reload.

    What has helped in my situation is a simple reboot of the NSLU2. Also, I gave it some minutes after the reboot and then reconnected my Windows share. I may have to reboot twice or three times at time, but usually that make the NSLU2 show all the data as normal again and not write protected.
  4. michb

    michb Guest

    write protect error

    What works for me is the following sequence:
    - Go to the web page of the NLSU2
    - Login as administrator
    - Go the the advance menu
    - Click on disk
    - Start Scandisk
    - The NSLU2 warns that all connections will be terminated
    - Click OK
    - Wait until Scandisk is started
    - Stop Scandisk

    If it works you write on the disk again.

    It always works for me.
  5. wkaml

    wkaml Network Guru Member

    Re: write protect error and network share not found error

    Hi michb,

    Thanks for the info. I'll try that next time to see if that approach works as well. For the past few times what worked truly best for me is to just disconnect the Windows XP network share and reconnect one more time. That's it.

    The challenge though seems to be to connect from one Windows XP machine. I have no idea, WHY??? For some strange reason, from one machine I can connect flawlessly, and from another machine I get the error message in Windows XP that the network share was not found. I have then to reboot the NSLU2 once or twice and just try to reconnect until it works. Most of the times though, a reboot of the NSLU2 and Windows XP works best to get the both reconnected. At that time however, I get pretty much a constant write error, which means I have to disconnect one more time and just do a simple reconnect.

    The one suspicion I have is that the NSLU2 stores some information as soon as you connect from a Windows XP machine using a network share. If I disconnect the NSLU2 drive from Windows XP before shutting down the computer I seem to be able to reconnect most of the times.
    However, if I do not disconnect the network share and shutdown the Windows XP machine with the NSLU2 attached as a drive, most of the times I run into problems reconnecting after a boot of Windows XP.

    Summary for write error: 99% of the times I can solve a write error by disconnecting the drive in Windows XP, give it a minute and reconnect the drive one more time.

    To avoid the network share not found error I open the NSLU2 in my webbrowser to spin up the disks and that seems to work fairly well too.

    For that problem it seem that the NSLU2 takes too long to spin up the drives or times out before it can respond to Windows XP.

    I hope that some Linksys folks help to figure the problems out.

  6. wkaml

    wkaml Network Guru Member

    Re: write protect error

    Until today a reboot of the NSLU2 and the PC worked for me. But today I have tried that about 10 times and I was not able to access my NSLU2 anymore.

    Your solution worked and you saved my day! Thank you michb!!! :clap:
  7. JRH147

    JRH147 LI Guru Member

    I just signed up to thank michb up there - this was a major problem for me, i searched all over the internet, stayed on "Live Assistance" with someone from LinkSys support for the past hour - but his suggestion - to run the ScanDisk, then stop - solved my problem.

    Thanks so much - and I'll definitely be bookmarking this site for any future linksys problems - quicker than their paid support!
  8. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Just to add to the discussion (probably unnecessarily) I recovered from the NSLU2 marking the filesystem as read only by attaching the USB drive to a Linux workstation and doing a proper "shutdown" of the OS. Seems that (please someone correct me if I'm wrong!) that like other Unix file systems EXT2 and EXT3 have to be properly shutdown and marked as 'OK' in order to access them. Similarly, you can do a fsck (Unix filesystem check utility) from your Linux/Unix host to do the same thing. All without reformatting.

    Pain, really. When I have the time, I think I will reformat my HDs to NTFS since it's easier to find a Windows PC around my house when I have a problem. :D

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice