NTP (Windows Internet Time)

Discussion in 'Cisco/Linksys Wireless Routers' started by OPaul, Dec 12, 2004.

  1. OPaul

    OPaul Network Guru Member

    How do I get NTP to work if I'm behind the WRT54G? On one machine I get "A error occurred while Windows was synchronizing with time.windows.com" and on the other I get "An error occurred getting the state of the last synchronization. The RPC server is unavailable.". I get the same things if I try and use time.nist.gov. I've tried forwarding the port to one of the machines but that's doesn't seem to help either. I am using the HyperWRT firmware.
  2. Esquire

    Esquire Mesquire Staff Member Member

    Which HyperWRT firmware version is it using?

    Honestly though, I haven't had any problems with synchronizing with other NTP servers. Did it work before you had the router or updated to HyperWRT?

    Check XP Windows Time service is running.
    Control Panel > Administrative Tools > Services.

    Try other time servers (simply enter them into the box):
  3. OPaul

    OPaul Network Guru Member

    Running 2.0b3, not sure if it worked before or not. Service is running and those other servers yield the same results. Did you have to do anything special to get it to work? Like forward the port or anything.

    = EDIT =

    Ah, the service hadn't started on one of the machines so that was the cause of the RPC error. So once that was started I got the "A error occurred while Windows was synchronizing ....." error.
  4. Esquire

    Esquire Mesquire Staff Member Member

    No, I didn't have to configure anything - it worked right out of the box.

    However, I do use port forwarding and UPnP, but it's for my private FTP, not for NTP.
  5. Esquire

    Esquire Mesquire Staff Member Member

    By the way, you mentioned you tried port forwarding on the port, for which port and protocol did you configure?

    Are you running any firewall on your client?
  6. OPaul

    OPaul Network Guru Member

    I appear to have gotten it working with a combination of reinstalling the service and forwarding the port.

    I forwarded the NTP port, 123. No software firewalls.
  7. Esquire

    Esquire Mesquire Staff Member Member

    Port 123 was right, but did you set to UDP protocol and not TCP?

    Anyway, it doesn't matter now that it's working.
  8. OPaul

    OPaul Network Guru Member

    Actually oddly enough they both work, which makes no sense because it's supposed to be UDP.

    Something else that's confusing me is that on another machine I have that is not behind a router but has a cable modem directly connected to it, I do not have to open the port within ICF (Windows Firewall on SP1).

    - EDIT -
    This may explain why both TCP and UDP worked;
  9. Esquire

    Esquire Mesquire Staff Member Member

    Interesting findings you have there, but have you noticed the description mentions UDP 123 for NTP as well as SNTP, but then lists TCP 123 for the summary underneath? :twisted:

    Anyway, my WRT54G runs on the older HyperWRT 1.3 and Windows Time works like a charm before and after switching to the firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice