$(nvram get wan_gateway) gives and VLAN strangeness

Discussion in 'Tomato Firmware' started by lanmtl, May 19, 2013.

  1. lanmtl

    lanmtl Addicted to LI Member

    Why is that? It says on the overview page that the WAN gateway is 64.230.xxx.xxx yet when I echo $(nvram get wan_gateway) I get
    The Tomato router is doing its own PPPoE session and the WAN port gets a public IP.
    The modem's GUI is accessible when I type

    In the routing table, I also have mention of this IP range and the ppp0 route comes last.

    In the VLAN section, the port 4 is in its own VLAN. Again, why?

    Here is my setup:

    Tomato (connects via PPPoE) -----------> My ISP's modem/router (default IP -----------> ONT

    The reason why I have to keep the crappy ISP's modem/router is because I need WAN packets to be tagged with VID 35 which of course my RT-N12B1 can't do with Tomato.

    Do I have a mess in my routing? Or is this normal?
  2. Mercjoe

    Mercjoe Network Guru Member

    Some questions to start:

    Version of Tomato used?

    Is this the default setup? or have you changed things?

    On your modem? Does it have a Ethernet bridged setting on the connection type??
  3. Bird333

    Bird333 Network Guru Member

    My vlan doesn't look like that and i have PPPoe. My 4 lan ports are on vlan1 and the wan is on vlan 2. Your vlan numbering may be different but I would think your 4 lan ports would be on the same vlan (vlan 0 in your case). I get when I do 'nvram get wan_gateway'. Is everything working ok? Are you able to access the internet?
  4. lanmtl

    lanmtl Addicted to LI Member

    Tomato Firmware v1.28.0501 MIPSR2Toastman-RT-N K26 VLAN-VPN

    The modem doesn't have a bridged setting because Bell removed it.
  5. lanmtl

    lanmtl Addicted to LI Member

    That would make more sense, I agree. I tried changing it this way but it won't accept it. It says it has to commit to nvram and reboot and when it has rebooted, it's back like that.
  6. mstombs

    mstombs Network Guru Member

    Do you have "route modem ip" or equivalent enabled - if so you have conventional tcp/ip enabled on the wan interface to communicate with the modems web gui - which has to happen outside the pppoe tunnel.
  7. lanmtl

    lanmtl Addicted to LI Member

    Yes it is enabled. But why would it make my VLANs so messed up and why would it show when calling the wan_gateway value from the nvram?
  8. lanmtl

    lanmtl Addicted to LI Member

    I flashed back to Tomato Firmware v1.28.0501 MIPSR2Toastman-RT-N K26 VPN

    But I didn't erase nvram so I'm guessing VLAN settings are still the same, it's just that they don't show up in the interface anymore?

    And I'm still getting as the wan_gateway
  9. philess

    philess Networkin' Nut Member

    You cant expect much support here if you dont follow one of the
    most basic rules: Erase NVRAM when changing firmware. Sorry.
  10. Monk E. Boy

    Monk E. Boy Network Guru Member

    Yes, the safest option when changing firmwares, even when upgrading to a newer version of the same firmware, is to long erase NVRAM and set everything up again from scratch.

    I keep a little text file around with all the options on every single page described in it. Takes about 30 minutes to put together but after that its a breeze to set up a router from scratch, just start at the top and work my way down.
    philess likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice