Odd problem with WRT54GS

Discussion in 'Cisco/Linksys Wireless Routers' started by links, Sep 24, 2006.

  1. links

    links LI Guru Member


    I've got a WRT54GS v1.0 (CGN1)

    I flashed it with OpenWRT and I've been having a few problems since. The first time I flashed with OpenWRT it worked ok and I changed a few settings. After I switched it off and switched it on some time later, I got the flashing power LED. I went about reflashing it assuming it was a corrupt firmware image. I missed the tftp window so I switched the router off and on again, but this time it booted in OpenWRT ok.

    I thought this was a bit weird but reflashed it anyway from the web interface. It was ok all day and I switched it off last night. This morning however, I had the flashing power LED again. I left it for a while and nothing changed. So I switched it off for 30secs and then back on again. This time, I had the link lights for the internet and LAN working but the power light was still flashing.

    I switched it off/on one further time, and it booted into OpenWRT this time (the DMZ light lit, which is what OpenWRT uses to signify booting). I am actually using it now and it seems fine as far as I can tell.

    Has anyway got any ideas as to what is causing this weird behaviour?

  2. slamcat

    slamcat Network Guru Member

    Possibly a bad power brick? Linksys power adapters are notorious for this, from my experience. I had one go bad on a brand new WRTSL54GS I had.
  3. links

    links LI Guru Member

    When I bought it the guy gave me a 7v 1A supply with it, which I thought was a bit odd, so I've been using the one from my WRT54GSv4 that I've got (the 12v 1A one). The supply works fine on the v4 router (I've been using my v4 for a few months, and it's been switched on and off plenty of times)

    I wonder if it's possible the power circuits in the router could have been damaged somehow. I may open it up and see if there's anything that looks odd inside I guess.
  4. links

    links LI Guru Member

    Just an update, I've tried it with another power supply (but an identical model) and it still does it. I've also managed to flash the original linksys firmware back via TFTP and still no luck. So I guess the issue is with the actual unit.

    I haven't got the receipt, but I might try contacting linksys support and see if they have an idea or can replace it under warranty (I don't want to void my warranty by opening it up and then still not find the problem)
  5. links

    links LI Guru Member

    I did try phoning linksys support, but I got cut off after 17mins. The guy just went through the usual stuff (ie. reset to defaults and then logon to the router webpage using static IP address)

    I have noticed a pattern though... The problem seems to be worse when the router it switched on from cold. As soon as I switch it on I get the flashing power light. I can try off/on again and get the same result.

    But if I leave it on flashing for 15mins and then try off/on, it's very likely to work (90% of the time) whereas if it's cold it will never boot up!

    I know when it's going to boot up ok, because all the lights flash on for 1 second or so when it gets powered on, and I eventually get a steady power light.

    Could these symptoms be due to some hardware fault in the router?
  6. u3gyxap

    u3gyxap Network Guru Member

    It does sound as a hardware fault. Most likely poor solder joint somehere. After being powered on, it warmes up and the connection is somewhat better.
    RMA the unit asap.
  7. links

    links LI Guru Member

    Unfortuately, I don't have the original proof of purchase because I bought it off ebay (I did actually try Linksys Technical support, but they wouldn't replace it without proof of purchase)

    The only thing I can think of trying is to build the serial port mod and see if I can get any clues from the console..
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice