Official Tomato v1.09.1180 Released

Discussion in 'Tomato Firmware' started by damwill, Sep 30, 2007.

  1. damwill

    damwill Network Guru Member

    Built on Sun, 30 Sep 2007

    Version 1.09
    • Fixed DDNS page error when using Internet Explorer.

    Version 1.08

    • Fixed forwarding a port with a source address and without a source address restriction at the same time may not work correctly. If you have this problem right now, please go to Forward/Basic and click Save to fix the entries.
    • Fixed Keep Alive's "redial" was not restarted.
    • Changed the keep alive "redial" method to a more simplier, safer way. Incase you experience a problem with this, please try "nvram set oldredial=1; nvram commit" and reboot. If that fixes the problem, then please let me know.
    • Fixed DHCP lease time resets when Dnsmasq is restarted.
    • Fixed UPnP may not start sometimes, changes made when deleting manually are not saved, connect may block for a long time.
    • Added detection of WZR-HP-G54, WZR-RS-G54, WZR-RS-G54HP, WVR-G54-NF, WHR2-A54-G54, WHR3-AG54, RT390W, WX-6615GT. Thanks to piggy for adding most of these and to others who sent in data.
    • Added Scott D's nice BlueGreen2 theme.
    • New DDNS system adds 3322, FreeDNS, OpenDNS, custom https:// URLs, external check ip support, retry on error, refresh after 26 days on all services to prevent expiring.
    • Added "Intercept DNS Port" option in Advanced/DNS which may be helpful when used with OpenDNS for parental control. When enabled, anything going out to UDP port 53 is redirected to Dnsmasq.
    • The GUI's SSL certificate SN is now randomized, CN is now also set to the router's LAN IP address, and the certificate can now also be saved in nvram and re-generated more easily if needed in Admin/Access.
    • The GUI's local HTTP/HTTPS port can now be changed.
    • A list of NTP servers from can now be easily selected in Basic/Time.
    • Updated dnsmasq 2.40, dropbear 0.50, iptables 1.3.8, l7-protocols-2007-07-27.
    • Some merging of code and pre-built binaries from WRT54GL 4.30.11.
    • Various minor changes.
  2. GeeTek

    GeeTek Guest

    Awesome !!!!Awesome !!!!Awesome !!!! Awesome !!! Gonna get it Flashed !
  3. GeeTek

    GeeTek Guest

    DDNS page does not work. It gives "Error on page" when I try to save any changes. Maybe I'm doing something wrong or have a bad test radio.

    The 109 release fixed the page. Looks like we now have an external address checker for DDNS. Coolness. !!
  4. Toxic

    Toxic Administrator Staff Member

    i'll check. i am upgrading as I type
  5. Toxic

    Toxic Administrator Staff Member

    I'm able to save, but my WRTSL54GS is behind another router, and it doesn;t want to play by the looks of it.
  6. Rudi1

    Rudi1 Network Guru Member

    I'am just flash my router and so far work like a sharm!
    Thanx a lot Jon for your hard work!
  7. lwf-

    lwf- Network Guru Member

    It was nice knowing you my 42 days uptime with 1.07 :p
  8. roadkill

    roadkill Super Moderator Staff Member Member

    at last...
  9. mraneri

    mraneri Network Guru Member

    I see 1.08 is now listed under rotten tomatos, and there is a 1.09...

    Changelog says fixed the DDNS problem identified here...
  10. GeeTek

    GeeTek Guest

    There was a big nasty green werm in mine when I bit into it. I'm still flashing the taste out of my mouth. :mad:
  11. der_Kief

    der_Kief Super Moderator Staff Member Member

    Great work

    Updated to 1.08 and then to 1.09. No problems so far.
    Thanks Jon for that great work :thumbup:

  12. klot

    klot Guest

  13. Larix

    Larix LI Guru Member

    I have flashed from 1.07 to 1.09. No Problems! :)

    But I have found a bug in 1.07 and now 1.09.
    When I make a traceroute to a website and there is no answer and I want change to another preference then I get an error message. I get i too, when I press Esc.

    I use Firefox with Adblock+.

  14. der_Kief

    der_Kief Super Moderator Staff Member Member

    OK confirmed :wink:

  15. roadkill

    roadkill Super Moderator Staff Member Member

    try to press on Trace while the process is still working..
    Firefox with Adblock+ on Ubuntu 7.10
  16. Larix

    Larix LI Guru Member

    Sorry I forgot to write. You must press Esc or change during the trace proces is working.

    I get the same message when I ping a website and during the process I change the optionspage.
  17. der_Kief

    der_Kief Super Moderator Staff Member Member

    OK. I reproduced it :wink: But i think this is harmless because there is no misfunction.

  18. Larix

    Larix LI Guru Member

    Yes, you're right. But a bug is a bug. ;)
  19. lyme

    lyme LI Guru Member

    uPnp - still doesn't work when trying to forward ports 80 and 443 to a webserver behind the router, even if you re-assign the router http and https ports the result is the same. The severity of this issue is low as you can manually assign them through basic portforwarding and it works, in addition the upnp works when forwarding other ports (my 360 worked fine).
    HTTPS security certificate - I've tracked down the issue that I was having where IE and Firefox would report it as invalid. The certificate is valid so long as you don't change the name of your router from "router". As soon as you change the name, the certificate for the machine called "router" is now incorrect. This is also a low severity issue as you can simply click through it.

    Everything else seems to be working so far. Great work!
  20. MarkFour

    MarkFour Network Guru Member

    v1.09 working fine on WHR-HP-G54.

    Nice job. Thanks for all your work, Jon.
  21. GhaladReam

    GhaladReam Network Guru Member

    1.09 working like a charm on my WRT54GS v2.0!
  22. srouquette

    srouquette Network Guru Member

    woot, thanks Jon for opendns update !!! :)
  23. MiseryQ

    MiseryQ Network Guru Member

    Thanks. Upgraded both routers with only minor problems on my part.
    I mistakingly upgraded the "Primary" GSv4 router when I meant to upgrade the "WDS" GSv1 router. And I did it wireless since I was wired to the 2nd router.
  24. dopee

    dopee LI Guru Member

    works fine for me,
    thanks for the feature to add comments to the wireless filter section :)
  25. pharma

    pharma Network Guru Member

    Upgrading to the new official Tomato version now! Thanks Jon for your excellence and hard work. :biggrin:
  26. As posted in other thread, the DDNS service with custom url doesn't work anymore (@IP is invalid). Jon already sent me an updated test version, which seems to work.

    So, now I need an updated OpenVPN mod ... :)
  27. pharma

    pharma Network Guru Member

    Please keep this thread only for the Official Tomato versions. Any posted requests concerning any Mods (OpenVPN) not directly related to Jon's work should be directly posted in separate threads.

  28. Rafatk

    Rafatk Network Guru Member

    Up and running just fine here!!!
  29. AeN0

    AeN0 Network Guru Member

    Yeah new version !

    I will missed my > 100 uptime

  30. lwf-

    lwf- Network Guru Member

    No meaning to flash from 1.08 for me, I use firefox and so does everyone else on my network.
  31. dopee

    dopee LI Guru Member

    everyone else on your net has access to your router? :rockon:
  32. what version is the broadcom wireless driver? You can check in the logs.

  33. mraneri

    mraneri Network Guru Member

    Jan 1 00:00:09 Router user.warn kernel: eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    Jan 1 00:00:09 Router user.warn kernel: eth1: Broadcom BCM4318 802.11 Wireless Controller
  34. njeske

    njeske Network Guru Member

    1.09 up and running here for over 24 hours. thanks jon!
  35. MadPriest

    MadPriest LI Guru Member

    successfully flashed over the air :)
    thank you!
  36. shadow_empire

    shadow_empire LI Guru Member

    also updated via ota successfully.
    @Jon: thx! but still missing the feature to monitor bandwidth consumption per ip-address. we still have to use scripting in firewall rules.
  37. siimo

    siimo LI Guru Member

    I live in New Zealand and the time is currently being displayed wrong. The day of DST change was brought forward this year so I guess Tomato isn't using the latest tzdata package? Using NTP it still stays 1 hour behind for some reason!
  38. GeeTek

    GeeTek Guest

    Trying to keep up with every new time zone in every country in the world is not practical. Jon should put a manual +/- one hour box in the time settings so you can adjust manually the time. Then all you will need to worry about is Venezuela which is off time by only 1/2 an hour, or North Bangladesh which is different by 15 minutes ! Jon, you had better make the field a minutes field, not an hour field. Make it +/- 90 minutes incase there are some time dimensions we are not yet aware of. Then we also need a special calender for the Chineese. They are 700 years ahead of us, their years only have 9 months and their hours are 100 minutes, not 60, to make up the difference.
  39. myersw

    myersw Network Guru Member

    Well was up for over 107 days. Now back to 1 day and counting.
    As always with Tomato the update went without any problems. Great firmware.
    Installed on wrt54gl v1.1.
  40. basmic

    basmic LI Guru Member

    One thankyou from me, also! Although it's not fixed anything for me, because I was running 1.07 just fine. :):cool:

    It's just nice to know Tomato is under continuous development. I might find it in my heart to make a small donation later this month. :tongue::biggrin:
  41. siimo

    siimo LI Guru Member

    I would still prefer if there was a way to actually manually enter time? >.<
  42. GeeTek

    GeeTek Guest

    There might be some folks around who could tell you how to use your PC as the time server. Just a suspicion.....
  43. mraneri

    mraneri Network Guru Member

    The clock in my Buffalo WHR-G54S is absolutely atrocious...
    When I check the logs, if I set the interval to every 24 hours, the clock adjustment is about 25-30 seconds!!!.. Yes, that means the clock in my router would drift 1 minute every two days...

    Good thing it has an NTP client or I'd lose 15 minutes a month...

    Can you just change the time zone for the few weeks where it's wrong and change it back when it would be right?

    - Mike
  44. Ruroni

    Ruroni LI Guru Member

    First time using Tomato, coming from Thibor WRT. Using a WRTSL54GS. Have to say its excellent. QoS works beautifully.
  45. habskilla

    habskilla Network Guru Member

    Will I lose my settings if I upgrade from 1.07 to 1.09?
  46. der_Kief

    der_Kief Super Moderator Staff Member Member

    No. Everything is OK afterwards. :wink:
  47. adlerfra

    adlerfra LI Guru Member

    Upgraded from 1.07. Smooth as butter! Awesome Awesome Firmware.
  48. Talon88

    Talon88 LI Guru Member


    If I enable [Avoid performing an NVRAM commit],
    Then after testing the setting, press [NVRAM Commit] to save
    the new setting. But the New setting doesn't keep after
    an reboot..........!

    Don't is it only me or is the bug. I don't have this problem
    when I am using v1.07

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice