Official Tomato v1.16 released

Discussion in 'Tomato Firmware' started by der_Kief, Feb 18, 2008.

  1. der_Kief

    der_Kief Super Moderator Staff Member Member

    A new version of Tomato firmware has been released.

    Changes are as follows:
    • More logging, fixes for PPPoE support. Thanks to Walter & Markus for lots of testing.
    • Updated igmprt. This might fix a problem with it dying unexpectedly.
    • Updated squashfs.
    • Updated Dnsmasq 2.41.
    • Updated L7 2008-02-10.
    • Fixed route was changed incorrectly on renew when using L2TP.
    • Fixed ping page.
    • Behavior of how the WEP keys are handled has changed. Previous versions forced the selected key to #1 internally. If you encounter problems, please make sure the key # is correct, or use key #1 manually.
    • Behavior of WHR-HP-G54's Enhanced RX's (Adv/Wireless) has been swapped. Please verify that it's working correctly.
    • Support for DynDNS via HTTPS added.
    • A separate test build with newer drivers (-ND) is now available. It's for the WHR-G125 and WRH54G, but it will also work on a few other routers. Not a lot of testing has gone into this, and it will definitely *not* run correctly on all routers that run just fine on the "normal" firmware, so *please use with caution*. Thanks to George for making it work on the WHR-G125.
  2. Toxic

    Toxic Administrator Staff Member

  3. srouquette

    srouquette Network Guru Member

    thank you :)
    seems to work fine ;)
  4. test100

    test100 LI Guru Member

  5. Talon88

    Talon88 LI Guru Member


    The High-Power Mode Setting boardflags of WHR-HP-G54 at
    the GUI is corrected...!

  6. madsul

    madsul Network Guru Member

    Wow you are really putting the work in on this! Thank you very much

  7. test100

    test100 LI Guru Member

    Image successfully flashed。
  8. pharma

    pharma Network Guru Member

    Up and running! :)

    Many thanks for your hard work ....
  9. Kiwi8

    Kiwi8 LI Guru Member

    Thanks for the information.

    By the way, is Jon releasing the firmware for WRT54G using the newer drivers?
  10. DeCex

    DeCex LI Guru Member

    These are loaded on the WRT54GS v4 version file.

    eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    eth1: Broadcom BCM4320 802.11 Wireless Controller
  11. Kiwi8

    Kiwi8 LI Guru Member

    Yup I'm talking about the newer drivers, which Jon compiled for WRT54G in an earlier release 1.15.1331_ND.

    The version of the drivers in that release is:
    eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    eth1: Broadcom BCM4320 802.11 Wireless Controller
  12. der_Kief

    der_Kief Super Moderator Staff Member Member

  13. Kiwi8

    Kiwi8 LI Guru Member

    Yes, before my first post in this thread I had already downloaded the zip file. But I did not find the file WRT54G_WRT54GL.bin in the zip file.
  14. elkabong33

    elkabong33 LI Guru Member

    Good stuff!

    BTW, When are we going to see an Official Tomato firmware with OpenVPN?


    El Kabong
  15. der_Kief

    der_Kief Super Moderator Staff Member Member


    i dont think Jon will release an official version with OpenVPN support ! Therefore you have to use Roadkills Tomato-Mod.

  16. LucasMoon

    LucasMoon Network Guru Member

    I just upgrade it to 1.16 from 1.15

    The moment that was done it did not want at all to connect by pppoe. I tried the reset button, tried uploading again and still no result. It would not connect at all.
    I put back 1.15 and reset connected over the internet.

    I have a linksys WRT54GS.

    Anyone had issues with what I had?
  17. devil-strike

    devil-strike Network Guru Member

    I have installed the 1.16 nb firmware and iits stabel with download 24Mbit and upload 2.5Mbit.

    But what is the difrance between 4.130.19 and the older 1.
  18. LLigetfa

    LLigetfa LI Guru Member

    Tried what with the reset button, a poke or a full 30 second factory reset?
  19. der_Kief

    der_Kief Super Moderator Staff Member Member


    just upgraded to version 1.16. No problems @ all.
    • the More logging, fixes for PPPoE support
    is a very nice and usefull improvment. Its working fast and stable here since a few days :wink:

    Thanks Jon for that nice piece of firmware :thumbup:

  20. purephase

    purephase Network Guru Member

    Thanks. As usual, flashed without any issues.
  21. LLigetfa

    LLigetfa LI Guru Member

    Dang, there goes my uptime bragging rights. The clock starts over.

    When I read about improved logging I had hopes maybe wireless associations... guess not... was hoping to flash all my other Buffalo HPs on my hotspot.

    Time to test the boardflags change... OK, Enhanced Receive is the right way around now... but there goes my uptime again.
  22. MiseryQ

    MiseryQ Network Guru Member

    Thanks No problems upgrading as usual.
  23. wupi

    wupi Guest

    Same here.
    Im using a Buffalo WHR-HP-G54, with 1.15 no problems.
  24. Kiwi8

    Kiwi8 LI Guru Member

    It's supposedly to have better wireless stability, which I have been having. Previously while using firmwares using drivers, I seemed to have access problems with the wireless bridge not working properly after a few days.
  25. szfong

    szfong Network Guru Member

    Tomato v1.16 compatible with WRH-54G

    According to this:
    Experimental Stuff:
    (use with caution or don't use at all)
    Tomato_1_16_ND.7z - Use for WHR-G125, WRH54G

    I realize the source codes for the WHR-G125 may be based on the Linksys WRH-54G. Can someone confirm if it's in FACT compatible with the Linksys WRH54G? I though WRH54G has 2MB flash/8MB RAM. These routers are quite reasonably priced.

  26. Odin-60

    Odin-60 LI Guru Member

    Tomato_1_16_ND.7z is for Buffalo WHR-G125 and Linksys WRH54G only;
    they need new drivers because they have different chip sets than the
    Broadcomm-based routers which were supported so far.
    Thus, "ND" does not mean "new Broadcomm drivers"; the naming is
    somewhat unfortunate, IMHO.
  27. szfong

    szfong Network Guru Member

    Hi, it's not necessary, I believe they are pretty much the same file, only the header is different, in order to flash from stock. I often flash my wrt54gl/wrt54g using the *.trx files without issue from 3rd party firmwares. If the new drivers worked, simply flash, it shouldn't brick your router.
  28. Kiwi8

    Kiwi8 LI Guru Member

    Well, apparently the newer drivers still work for the chipsets in WRT54G too, so it's not really wrong to say they are newer drivers.
  29. Kiwi8

    Kiwi8 LI Guru Member

    Yeah thanks. Indeed the tomato-ND.trx file works. :)
  30. unicorn02

    unicorn02 LI Guru Member

    I updated from 1.15 to 1.16. Now, sometimes I have to hit the connect button on the admins page to get connected to the internet. The router does not connect itself when a request for the internet comes (even tough it was always configured to do this and it worked without a hitch). But I have to dig deeper into the problem later when I have access to the router. Maybe a power cycle of the router will help?
  31. RonWessels

    RonWessels Network Guru Member

    DNS problem with 1.16

    I just had a problem whereby the DHCP server on the router was not forwarding the DNS address it got from being a DHCP client (to the ISP).

    Here's my best guess as to how to reproduce the problem. You will need a DHCP WAN type where the WAN DHCP server provides a DNS address. In Advanced -> DHCP/DNS, de-select "Use Internal Caching DNS Forwarder" and select "Use Received DNS With Static DNS". In Basic -> Network, I did not have any Static DNS entries (all, although I don't know if it makes a difference.

    Now, here's the annoying part. Wait for the router to automatically renew its DHCP lease. Then wait for a router client to automatically renew its DHCP lease. Now notice that the client has no DNS server listed, even though the router has got one.

    Interestingly enough, when I got into this situation, rebooting the router didn't help! Neither did Release/Renew on the WAN side followed by a Release/Renew on the client. The only thing that worked was selecting "Use Internal Caching DNS Forwarder" and renewing the client lease. Again, annoyingly, thereafter everything was working properly when I tried to reproduce the problem.
  32. DigiH

    DigiH Network Guru Member

    PPPoE automatic connection on request problem with 1.16

    I updated to 1.16 and now a lot of times I have to log into the router and click the "Connect" button manually to be able to get connected. The automatic connection on request doesn't seem to work for me any more.

    I also have to say that I never had any PPPoE or automatic connection on request problems in the past. So the "fixes for PPPoE support" in 1.16 has probably helped those people who experienced PPPoE problems before, but has broken the automatic connection on request feature for my PPPoE set up :(

    As always though, thanks a lot for all the efforts in improving Tomato :)
  33. der_Kief

    der_Kief Super Moderator Staff Member Member


    did you try a NVRAM reset or hard reset via reset button ? Maybe this solve your problem. Otherwise you can contact Jon about this.

  34. unicorn02

    unicorn02 LI Guru Member

    I can confirm the observings by DigiH. I disconnected all my equipment for 15 minutes, plugged it in again and waited for another 15 minutes. Then I started my PC and the router did not automatically connect to the internet (skype got no connection on startup).
    I went into the Tomato Setup and checked there-> "Disconnected".
    Then I went into "Basic/Network" and just changed out of curiosity the setting from "Connect on Demand" to "Keep Alive". As soon as I saved the setting, the router connected. I could also do a manual Connect, but I knew that this was working. So there seem to be definately something broken.

    If you are once connected, it is not easily possible to replay the problem. You can disconnect and it connects automatically correctly.

    So from what I observed, is that the problem occurs if the internet connection was idle (disconnected) for a longer time (Minutes?.. Hard to say). Then the connection can only be initiated manually. I'll write to Jon about this. In the meantime I will downgrade to 1.15.
  35. Sunspark

    Sunspark LI Guru Member

    Are you sure there is a problem? Read what you wrote again.

    Connect on Demand = YOU make it connect.
    Keep Alive = Router keeps trying to reconnect.

    Since day 1 I have always used Keep Alive.

    Stayin' Alive, stayin' alive!
  36. Rudi1

    Rudi1 Network Guru Member

    Yes this is correct.I always use "keep alive" settings and work without problems in this version.Big Thank you Jon for your work!
  37. pfoomer

    pfoomer LI Guru Member

    auto connect

    Actually this happens in 1.11, in mode Connect on Demand

    I went to my system after about 2hours (watching tv!!), could not initiate a connection when I scanned for email, so into router, manual connect.

    This is quite the norm for me.
  38. unicorn02

    unicorn02 LI Guru Member

    Sorry, but I have to correct you. "Connect on Demand" means that the router automatically connects to the internet when a packet demands to go out to the internet. When the connection is idle for a specified amount of time, the router disconnects from the internet.
    Keep alive will keep your connection essentially up all the time, as it sends keep alive packets in defined intervals.

    As I turn of my PC's at night, I do not want to keep my connection alive all the time. Also connecting only on demand to the internet gives me different WAN-IPs for each connection. Can be a good thing for security. But it is a personal taste.

    To cut a long story short. "Connect on Demand" always worked for me correctly until 1.16.
  39. der_Kief

    der_Kief Super Moderator Staff Member Member

    Did you try a NVRAM reset as i mentioned above ? Jon implemented a newer version of pppoecd in v1.16 and so you should try to reset and reconfigure your router, my guess !

  40. unicorn02

    unicorn02 LI Guru Member

    I did a NVRAM reset, but it is too early to say if it really solved the problem as it is not so easy to reproduce. Jon sent me a new build in the meantime (from today evening) that I can test now. That's what I call fast support!
  41. DigiH

    DigiH Network Guru Member

    Jon sent me a new test build as well, and so far my tests show that everything works fine again.

    Indeed a brilliantly fast and wonderful support from Jon!

    To unicorn02:
    I set the idle timeout to 5 minutes to test this new version, put my PC to sleep for 7 minutes then woke it up to see if it automatically gets a connection again. The router connection time showed me that a new automatic connection was started after the idle disconnect. You might want to try that as well to see if it works for you, instead of having to wait a whole night ;)
  42. rcordorica

    rcordorica Network Guru Member

    WRT54GLv1.1 working fine here with tomato-ND.trx. I'll have to spend more time with it to see how it affects the wireless stability and performance.

    1 bug. When I do a wireless survey it kills the radio and I have to reboot the router to bring it back.
  43. szfong

    szfong Network Guru Member

    On my WRT54G v2.0, tomato-ND.trx kills the radio for about 1 second using Site Survey during a large transfer and the transfer continues without issue. I've been testing it right now to determine its stability. My current router, a wrt54g v2.0 (unreliable with older tomato drivers), is based on the older bcm4712 cpu+ADM6996L switch chip. For me at least, the regular Tomato runs quite reliably on my whr-hp-g54, and randomly rebooted only once or twice in a month, and only under extraordinary stress by multiple wireless clients. I'm sure tomato-ND.trx still needs some more tweaking. When I have time I'm going to flash the spare whr-hp-g54 & a whr-g125 I have in storage with tomato-ND.trx.
  44. FRiC

    FRiC LI Guru Member

    Tomato has always bugged me that "Keep Alive" doesn't reconnect by itself if I manually disconnect. I see now that "Connect on Demand" is actually what I want. I set the Max Idle Time to the maximum value of 1440, and now my router stays connected permanently.
  45. LLigetfa

    LLigetfa LI Guru Member

    To me that is expected behaviour. Kind of a manual override. If you want to test the auto-reconnect, pull the WAN cable.

    Keep alive always keeps me connected unless the ISP boots me in which case it always reconnects.
  46. FRiC

    FRiC LI Guru Member

    Well, it's just different from other routers that I've used before. (I just switched to Tomato recently.) My ISP occasionally has problems that only a reconnect would fix, before I used Tomato, I would just login remotely and hit disconnect and keep alive would bring the line right back again. With Tomato I always had to call someone up to pull the plug.

    Just looked, my old routers' idle time behavior is different, which explains why I never tried it with Tomato. Anyway, I'm happy now. :)

  47. AF35

    AF35 LI Guru Member

    thanks for the new version. Tomato has been an excellent piece of firmware for my WRT54GL.

    however I'm still waiting to see this little piece of script be included in the firmware so alot of us who need detailed traffic monitoring can enjoy sharing broadband to other people.

    Cheers for the great firmware!
  48. Toxic

    Toxic Administrator Staff Member

    Thats script is specific for IP addresses, how would this be added if you did not use the same IP addresses? this is why we have firewall script for tailor you own specific settings.
  49. unicorn02

    unicorn02 LI Guru Member

    Connect on Demand is really fast (about 1-2 seconds), so it's really is a no brainer to use it. And as I said before you get the luxury of a new IP-Address every time you get a connect. (At least my provider gives a new ip for every connection, even if it is in short succession)

    Also, if you have a software running in the background that regularly polls the internet (like Email-pop3 client or skype), then you have essentially also a kind of "keep alive" as long as these services are running on the PC.
  50. GhaladReam

    GhaladReam Network Guru Member

    I'm having the EXACT same problem. After the router requests a DHCP renew from my ISP and after the clients request a DHCP renew from the router, the clients no longer have DNS addresses. I *could* use the internal DNS forwarder, but I'd rather the clients have the actual DNS servers assigned by my ISP.

    As RonWessels said, it's hard to reproduce because you have to wait until your router automatically requests a DHCP lease renew on the WAN side before this starts happening.

    Also, how does one contact Jon for questions/bug reports?
  51. puffer

    puffer Network Guru Member

    Wow I upgraded and my intel 802.11 a/g (mini pci) speed test are doubled from speakeasy. I would download around 10000 kbps before and now I am at 20000.. What the heck upgrade caused that.. woohoo!
  52. unicorn02

    unicorn02 LI Guru Member

    Scroll down on the FAQ page:
    There you will find his email as a graphic.
  53. mstombs

    mstombs Network Guru Member

    WANside dhcp/ dns broken for me too in Tomato 1.16 [wrt54gsv1.1]

    The problem is that dnsmasq is not restarted when the WAN comes up so does not pick up the ISP supplied dns servers.

    A work around is to use the command

    service dnsmasq restart

    and possibly putting that in the WANUP or firewall script may fix the problem, but its back to 1.15 for now...
  54. Odin-60

    Odin-60 LI Guru Member

    I can't confirm this bug. As soon as the WAN side of the router
    obtains a DHCP lease, dnsmasq re-reads /etc/resolv.dnsmasq and
    "learns" the new DNS server.
  55. mstombs

    mstombs Network Guru Member

    In the source code in wan.c, function start_wan_done, these lines have been commented out in 1.16

    //	stop_dnsmasq();
    //	start_dnsmasq();
    which exactly explains my problem, presumably the the change to dnsmasq in the readme means it should no longer need to be stopped and restarted?

    I do have an opendns server to be used "in addition" to servers allocated by dhcp, and domain ad blocking ... but 1.15 works fine with same config!
  56. Odin-60

    Odin-60 LI Guru Member

    I still do not understand your problem,
    but I hope that Jonathan will do,
    when you send him a bug report :cool:
  57. GhaladReam

    GhaladReam Network Guru Member

    Jon sent me a test build that he says may fix the DNS issue. I'll report back if it does indeed work.
  58. wahur1

    wahur1 LI Guru Member

    I'm not going to upgrade now :p my 1.15 version is rock stable and its up for 36days :)
  59. szfong

    szfong Network Guru Member

    Tomato_1_16_ND.7z Issue

    I was testing the New Driver release of Tomato v1.16 the other day and noticed that sometimes wired & wireless speeds became erratic, and in trying to diagnose the problem, I seem to remember somewhere recommending that the "Broadcom Ethernet Controller Driver" and the "Broadcom Wireless Controller Driver" should be of the SAME VERSION, as to prevent possible conflict since the two are so much more "integrated" compared to say a regular PC. Other 3rd party firmwares seem to consistently use same versions as well. The version in "Tomato v1.16 ND" are:

    eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    eth1: Broadcom BCM4320 802.11 Wireless Controller

    Was the author not able to find same version of the drivers? I'm sure stability will be enhanced if they are the same.

  60. devil-strike

    devil-strike Network Guru Member

    I dont think that is he problem, i have this version running 1 week whitout any los of signal or speed drops.
  61. szfong

    szfong Network Guru Member

    Which broadcom-based router did you test it on. I've only tested it on a wrt54g v2.0 & whr-g125. I saturated the wan-->lan & lan-->wan while at the same time doing a couple transfers across lan-->wlan & wlan-->lan.
  62. DeCex

    DeCex LI Guru Member

    DNS issue fixed?

    Well ? Did he fixed it the the test build you got?. Can you share it? so maybe we also can try it. Thanks
  63. Sopmod

    Sopmod Network Guru Member

    I flashed 1.16 as per normal with no issues. Started 2 torrents off over night and came back this morning to an offline, contactless WRT54G.

    Did the 30 second reset a few times. Did the power on whilst holding the reset button.

    Anyway this is the first time of many many versions of Tomato that has caused any problems.
  64. cwwang16

    cwwang16 LI Guru Member

    DHCP server dies off unexpectedly

    My WRT54GL with 1.16 DHCP server frequently dies off causing my clients unable to obtain DHCP lease from the router. Tried to diagnose the problem and looked into the log, but there is no error. Gonna try 1.16-ND to see if that fixes that problem otherwise back to 1.15 :frown:.
  65. M_ars

    M_ars Network Guru Member

    i am staying with 1.13 for now, no problems with that one
  66. devil-strike

    devil-strike Network Guru Member

    Tested on wl500gp.
  67. pharma

    pharma Network Guru Member

    That is good news! I agree with you that different Broadcom drivers are not the issue ... :) I have no problems using Tomato 1.16 ND on my WRT54G v4.
  68. houman

    houman LI Guru Member

    no problem here, flashing to 1.16 from 1.13, the only problem I had was slow download w/ 1.6 (dsl setup to cable modem setup) and an nvram reset helped the cause. I am using the WRT54GL
  69. DeCex

    DeCex LI Guru Member

    anyone else feel like DNS lookup and DNS cache slower? or just me? or is thare anywhare to tweak it within webgui settings ?
  70. sirsanka

    sirsanka LI Guru Member

    Flashed from 1.11 to 1.16. Did nvram reset. Found that if I use "Use Received DNS With Static DNS" option only (unchecked "Use Internal Caching DNS Forwarder"), I get no internet. I still can access the router gui. Looks like the domain names are not being resolved with that option. I even renew the dhcp lease just in case. if I check "Use Internal Caching DNS Forwarder" in the gui and uncheck "Use Received DNS With Static DNS", it works perfect.
  71. Sunspark

    Sunspark LI Guru Member

    It also works perfect if you have checked on 'Use internal caching' and 'use received dns with static' and have some entries in the static which I do for backup as the ISP can suck sometimes.

    I'd like to learn here, so why would you not want to have either of those options checked people?
  72. mstombs

    mstombs Network Guru Member

    Tomato 1.16 didn't work for some of us if both are checked! What is your ISP connection type dhcp or pppoe? How many static dns servers do you have? I had a problem in previous versions that Tomato was only using a total of 3 dns servers, so I have 1 static and 2 dynamic from ISP and it works fine in 1.15 and before. I recall dnsmasq reports in the log what servers it is using.
  73. Sunspark

    Sunspark LI Guru Member

    Mstombs: dhcp assigned ip over pppoe. DSL. I am using 3 static DNS servers.

    This is what it looks like after a manual disconnect and then manual reconnect in my log:
    Feb 25 02:21:00 router pppoe[4054]: Sending IPCP Configuration-Ack
    Feb 25 02:21:00 router pppoe[4054]: IP Address:
    Feb 25 02:21:00 router pppoe[4054]: Primary DNS:
    Feb 25 02:21:00 router pppoe[4054]: Secondary DNS:
    Feb 25 02:21:01 router dnsmasq[4053]: reading /etc/resolv.dnsmasq
    Feb 25 02:21:01 router dnsmasq[4053]: using nameserver
    Feb 25 02:21:01 router dnsmasq[4053]: using nameserver
    Feb 25 02:21:01 router dnsmasq[4053]: using nameserver
    Feb 25 03:02:51 router -- MARK --

    and when it booted up the first time around:

    Dec 31 19:00:06 router pppoe[82]: Sending IPCP Configuration-Ack
    Dec 31 19:00:06 router pppoe[82]: IP Address: xx.xx.xx.xx
    Dec 31 19:00:06 router pppoe[82]: Primary DNS:
    Dec 31 19:00:06 router pppoe[82]: Secondary DNS:
    Dec 31 19:00:07 router dnsmasq[103]: started, version 2.41 cachesize 2048
    Dec 31 19:00:07 router dnsmasq[103]: compile time options: no-IPv6 GNU-getopt no-RTC no-ISC-leasefile no-DBus no-I18N no-TFTP
    Dec 31 19:00:07 router dnsmasq[103]: asynchronous logging enabled, queue limit is 5 messages
    Dec 31 19:00:07 router dnsmasq[103]: DHCP, IP range --, lease time 1d
    Dec 31 19:00:07 router dnsmasq[103]: reading /etc/resolv.dnsmasq
    Dec 31 19:00:07 router dnsmasq[103]: using nameserver
    Dec 31 19:00:07 router dnsmasq[103]: using nameserver
    Dec 31 19:00:07 router dnsmasq[103]: using nameserver
    Dec 31 19:00:07 router dnsmasq[103]: read /etc/hosts - 0 addresses
    Dec 31 19:00:07 router dnsmasq[103]: read /etc/hosts.dnsmasq - 2 addresses

    It SEEMS ok unless I am reading this horribly wrong. If it is ok, I also ran the build 1351 beta too for fun and I don't do router resets between upgrades since it seems fine.
  74. GhaladReam

    GhaladReam Network Guru Member

    Yes, the build Jon sent me has been working fine for me the last few days. Build number on it is 1.16.1378.. I'm sure Jon will send it to you if you ask him, but I don't want to post it here because it's only a test build and I don't know if Jon would like it to be public.
  75. mstombs

    mstombs Network Guru Member


    My reading of your log is that tomato/dnsmasq is ignoring the ISP supplied DNS servers - because you have 3 user defined ones. I believe this is a Tomato limitation, not dnsmasq? My problem was with 1 user defined + 2 dynamic, and with a cable modem/dhcp connection, and I guess similar problem to that just fixed in the test version GhaladReam.
  76. kaplanfx

    kaplanfx Network Guru Member

    I still have an old HyperWRT-Tofu firmware (from 95-96 maybe?) on my router but I've finally decided to upgrade and I'm going with Tomato. Anything special I should know about this upgrade path, or can I just use the firmware loader in the old firmware?


    P.S. I searched the forum but couldn't find a specific answer so I apologize if this info is already somewhere.
  77. king2000

    king2000 LI Guru Member

    Good job, something needed for L2TP connection

    I've upgraded to 1.16 and works fine, however, if there can be a change in the option to allow a name of server in the L2TP server name and not only IP. As in Israel using the cables with our ISPs there are domain names for the L2TP servers, the IPs sometimes changes which makes a problem connecting back if needed without a change to the server IP. I've seen this option on other routers to have a name instead of the regular IP used as a L2TP server.

    Thanks, hope this will be available soon, as I see the great work done on this firmware which I got to love at first sight.
  78. pharma

    pharma Network Guru Member

    You can probably use the old firmware loader. I guess you know that Jon (Tomato author) was also the author of the old Tofu HyperWRT version. You might want to check the FAQ on his website for specifics, but you should be alright.

    I would probably clear NVRAM after the upgrade, but you may also choose to do it before the upgrade.

  79. kaplanfx

    kaplanfx Network Guru Member

    Thanks for the info, looks like I shouldn't have a problem.

  80. LucasMoon

    LucasMoon Network Guru Member

    I have tried everything and this version Tomato_1_16.7z does not like WRT54GS. I have put back 1.15 and did a full clear nvram and a full reset by clicking in the back of it and also from the menu of Tomato and then install Tomato_1_16.7z with success.

    But it wont connect by pppoe at all. I even try connect by demand but nothing works.

    Went back to 1.15 and no problem at all.

    Anyone else having issues of running Tomato_1_16.7z on WRT54GS?
  81. voxabox

    voxabox LI Guru Member

    I'm running 1.16 on 2 wrt54gs (v1.0, v1.1) without any problems here
  82. Rafatk

    Rafatk Network Guru Member

    Yes I hava WRT54GS and I am having PPPoE problem. It will not connect no matter what.

    LucasMoon, what version is your WRT54GS? Mine is a v4.

    voxabox, did you make your settings from scratch? Because if I do the settings from scratch it will no work at all. But if I restore the settings saved from my previous Tomato version (1.14) it will connect.

    I did not test the ND version, and I did not find the new version that others got from Jon. But I think they had an issue related to keep alive or connect on demand in PPPoE. If anyone could share for me to test, if it solves the problem.


  83. Sopmod

    Sopmod Network Guru Member

    Further to my issues with 1.16.

    Set about downloading two torrents last night. Came in this morning one had completed and the other was stalled with the "NAT has a problem" light on.

    I couldn't browse to the router address. It just timed out. So I rebooted my PC and all is now working as expected. Router uptime is 2 plus days which is correct.

    This has never happened before and the only change to my setup has been 1.16 on my WRT54G.

    Any thoughts?
  84. voxabox

    voxabox LI Guru Member

    No, I just upgraded, the settings migrated themselves
    I don;t use PPoE as I have cable internet
  85. LucasMoon

    LucasMoon Network Guru Member

    V4 also. It wont work on pppoe.

    Has for the person saying it work for him....well yeah I believe it does cause you are on cable...pppoe does not affect you. Different connections.

  86. voxabox

    voxabox LI Guru Member

    my bad, I did not read his post carefully:redface:
    I'm truly sorry for the any inconvenience that might have caused
  87. Merlyn_3D

    Merlyn_3D Network Guru Member

    I've been having throughput problems on wireless with 1.16 and the WHR-HP-G54. Streaming from my macbook pro to PS3 was terrible. I reverted back to 1.15 and everything's back to being quick as ever.
  88. szfong

    szfong Network Guru Member

    After nearly 4 days of uptime, my WHR-HP-G54 randomly rebooted under Tomato 1.16. It was under 24/7 constant load and heat is definitely NOT an issue, especially since it's cold as heck at night. It is connected to a UPS along with 2 other "3rd party firmware" based routers. All were restarted at exact same time. Running in AP+WDS mode.

    On a side note, Tomato_1_16_ND.7z seems quite stable, so far.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice