Official Tomato v1.21 released

Discussion in 'Tomato Firmware' started by Rudi1, Jul 26, 2008.

  1. Rudi1

    Rudi1 Network Guru Member

    Thanx Jon for his great work!!!

    Tomato Version 1.21

    • Updated to dnsmasq 2.45. Fixes crash problems in 2.43.
    • Automatically restarts dnsmasq if it dies.
    • /etc/dnsmasq.custom is appended to dnsmasq config if it exists.
    • Added EveryDNS DDNS.
    Routers that are known to work with Tomato:
    • Linksys WRT54G v1-v4, WRT54GS v1-v4, WRT54GL v1.x, WRTSL54GS (no USB support)
    • Buffalo WHR-G54S, WHR-HP-G54, WZR-G54, WBR2-G54, WBR-G54, WZR-HP-G54, WZR-RS-G54, WZR-RS-G54HP, WVR-G54-NF, WHR2-A54-G54, WHR3-AG54
    • Asus WL500G Premium (no USB support), WL500GE
    • Sparklan WX6615GT, Fuji RT390W, Microsoft MN-700
    This will not work on Linksys WRT54G/GS v5 or newer WRT54G/GS routers.
  2. kmindi

    kmindi LI Guru Member

    Thank you J0n.
  3. nvtweak

    nvtweak LI Guru Member

    Thanks Jon,

    up and running just fine on WHR-G125!
  4. JensG

    JensG Network Guru Member

    1.21 has been running now for a little over 4 hours on my WRT54GS, without any problems. TY Jon.
  5. der_Kief

    der_Kief Super Moderator Staff Member Member


    upgraded to ver. 1.21 and running it since 16 hours without any problems.

    THX Jon for new version :thumbup:

  6. averylinden

    averylinden LI Guru Member

    I seem to have having problems keeping a /jffs filesystem mounted after reboot with 1.21. Is anyone else having trouble?
  7. kwag

    kwag LI Guru Member

    1.21 problems!

    This tomato (1.21) is rotten!
    Please roll back.
    I've had two issues since the upgrade, where I can no longer browse, and I've had to reboot the router.
    Never had an issue with 1.19 for weeks!
    I'm running on a WRT54GL v1.1
    A software reboot didn't fix. I actually had to power down.
    Went back to 1.19, because 1.20 seemed unstable because I saw about three different builds, so I never upgraded to 1.20.
    Definitely there's an issue with 1.21
  8. adlerfra

    adlerfra LI Guru Member

    Uptime over 36 hours. No issues.
  9. nvtweak

    nvtweak LI Guru Member

    Still going strong. No problems with DNS.

  10. kiskakas

    kiskakas Network Guru Member

    I patched 5 wrt's yesterday and all works fine, without problems! :)
  11. guillaumy

    guillaumy LI Guru Member

    Updated to 1.21 at the first opportunity.

    No issues here.

    By the way, nvtweak, yours is a custom compile, so your observations are not strictly applicable ... :wink:
  12. Mastec

    Mastec Network Guru Member

    You must have done something wrong. Or seeing how it's your first and only post you might be trying to deter others of using the almighty Tomato.

    Nearly 24 hrs uptime on my WRT54G and WHR-HP-G54 with absolutely no issues.

    Thanks Jon
  13. TexasFlood

    TexasFlood Network Guru Member

    I would have to agree, up here since upgrading, 1 day 15 hours, with no issues. I should add that I upgraded to the later v1.20 test builds and had no issues with those either.

    It isn't clear to me what is meant by the request to "roll back". If v1.19 was stable on a given router and v1.21 has issues with that router, then the "roll back" to consider would be going back to v1.19. If there really is an issue with v1.21 (although I don't see one), the best approach would be to spend some time diagnosing the issue and "roll forward" with whatever fix is required.

    Sometimes when Tomato is upgraded there are a few interim builds until it reaches a stable plateau. This is not necessarily any defect with Tomato itself but can be the result of issues with underlying components such as DNSmasq in this case. Anyone with much experience with other 3rd party router firmware builds, this churn is relatively quite minimal and speaks well IMHO of the stability and support of Tomato.
  14. nvtweak

    nvtweak LI Guru Member

    Sure not strictly applicable, but still applicable nonetheless.. :wink: If my router is stable for long, it's because Jon's work helped make it so.
  15. a9988cd

    a9988cd LI Guru Member

    TOMATO 1.21_ND

    WL-500GP V2 can be detected and running it 6 hours without any problem.(only wirless LED cannt OFF).

    Thanks Jon
  16. xargs

    xargs Network Guru Member

    Is dnsmasq so unstable that it needs a workaround like this?

    For now, I've just disabled dnsmasq to work around the DNS security issue and stuck with 1.19.
  17. TexasFlood

    TexasFlood Network Guru Member

    My understanding is that was put in place to help with the problematic DNSmasq 2.43 and 2.44 releases - 2.45 is supposed to be solid but that restart logic was left in place.
  18. kwag

    kwag LI Guru Member

    Sorry, but 1.21 just didn't cut it, under heavy use.
    Went back to 1.19, and now everything is all fine.
    Try to put about 7 machine behind your router and do some heavy surf/torrents/etc and then see if you can get 2 days uptime. 1.21 failed on my GL *TWICE*, so there has to be some issues.
    And yes, it was my first post here, but I have been using Tomato for over a year without any issues ;)
  19. Mastec

    Mastec Network Guru Member

    9 full time and 2 part time clients good enough?

    - My desktop - wired
    - My wifes desktop - wired to WDS router
    - My wifes laptop - wireless
    - My 16 yr old sons desktop - wired
    - My 18 yr old sons desktop - wired
    - My 14 yr old daughters desktop - wired
    - My neighbors desktop - wireless
    - My sons xbox 360 - wireless
    - My sons PSP - wireless
    - My sons friends PSP - wireless
    - My sons friends desktop - wireless

    Everything is connected to the Internet all day everyday except my sons friend who brings his machines when he spends the night.

    1.21 is running flawless

    Attached Files:

  20. M_ars

    M_ars Network Guru Member

    @Mastec: with more than 6 MB free memory :biggrin: ... this does not count. Your router just didnt do much the last 24 hours and more. Try heavy load like kwag said.
  21. TexasFlood

    TexasFlood Network Guru Member

    From the changelogs, the following are the listed changes from 1.19 to 1.21.

    -Fixed setting custom scheduler time doesn't save correctly
    -Updated to L7 patterns 2008-04-23
    -Static DHCP limit increased to 100
    -Added EasyDNS HTTPS support
    -Added date format option for Bandwidth/* pages
    -Updated to dnsmasq 2.45
    -Automatically restarts dnsmasq if it dies
    -/etc/dnsmasq.custom is appended to dnsmasq config if it exists
    -Added EveryDNS DDNS

    On the surface, nothing jumps out (to me) as a candidate to introduce instability. But it's really hard to know.

    I think someone mentioned in an earlier thread something about a suspected memory leak in the recently upgraded versions of DNSmasq. Memory leaks are always possible. They can be hard to track down, especially on a router with limited support utilities.

    You could track the memory by writing memory status to a cifs mounted filesystem or a syslog server. Just periodically run "free" to get the total free memory and/or "ps" to track process memory. Safest to do both so you can see if a process is growing but still get state of the total free if not.

    I'd do it, but it's not happening to me.
  22. Mastec

    Mastec Network Guru Member

    Wife plays her online game, boys computers are either playing WoW, Wolf Team or some other online games. They also download and seed torrents to update their games. My daughter is watching music videos and playing Habboo. Friends are playing the XBox 360. Son watches videos and streams music through his PSP. I am always surfing, listening to music, streaming movies or downloading torrents. My Buffalo gets a workout.

    EDIT... I am not getting into a stupid ass pissing match over the Internet. It's about as ignorant as one can get. I am done on the subject... Have a good day. :biggrin:
  23. sorian25

    sorian25 LI Guru Member

    After 24 hours, no issues.

    Love this firmware.
  24. kwag

    kwag LI Guru Member

    Good for you!
    Now just keep an eye on the change log when 1.22 is released :biggrin: :biggrin:


    The problem might be related to Wireless WAN connection.
    I don't connect to the Internet via Cable/DSL.
    I connect as a Wireless client to a provider about one mile from me, via 24DBi Grid antenna + a Hawking .5W Amp/Preamp.
    The connection might drop (Renew DHCP) two or three times a day, so this might not be seen as much on a wired connection.
    After several hours of use, the system just stops browsing, and a soft reset wont cure the problem.
    Only a power down/up is the only way to bring the system back to operation.
    And yes, I have cleared the nvram, reset all to defaults, etc. and no go.
    Anyway, back to 1.19 until 1.21.x or 1.22 comes out.

  25. dewx

    dewx LI Guru Member

    Yes, dnsmasq is very unstable. You can't appreciate the fix until it happened to you. There were a few times where my network completely went down because of dnsmasq problems and low memory. How do you disable dnsmasq?
  26. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Using victek's 1.21 mod here. No problems and am using 3 router config with one in wireless wds+ap "slave" kinda mode, one in wired pure ap mode, one in gateway mode.
  27. xargs

    xargs Network Guru Member

    Advanced...DHCP/DNS. Uncheck "Use Internal Caching DNS Forwarder." This disables the DNS portion of dnsmasq, but I don't know if it also disables the DHCP portion.
  28. nvtweak

    nvtweak LI Guru Member

    do clients get ISP's DNS servers by DHCP instead of the router's IP? If this is the case, you might actually make it less secure.
  29. i1135t

    i1135t Network Guru Member

    I assume that the DHCP serves the DNS server entries as well, so what ever is set in the router is what it hands out to its DHCP clients.
  30. nvtweak

    nvtweak LI Guru Member

    yes, I can assume as much. But I was wondering if someone who uses that configuration could provide a definitive answer.

    Are clients getting the IP addresses of the ISP DNS, or the actual router's IP?
  31. gregg098

    gregg098 LI Guru Member

    The clients WILL see the DNS Server IP addresses and NOT the routers IP.

    EDIT: Misread the question.
  32. xargs

    xargs Network Guru Member

    Why do you say that?
  33. tempralflux

    tempralflux Network Guru Member

    2 days 7 hour all seems to be fine. Normally have about 15 meg free just used top command in telnet box dnsmasq using 5.8 %.
  34. taavi

    taavi Guest

    Strict Rule Ordering

    New with Tomato, but can't find the answer from the forum to the question which seems to be up since 1.19
    Why isn't "Strict Rule Ordering" there under QoS, like it is in wiki pages?
    Can I switch it on via nvram command?

    So far I like Tomato over DD-WRT:)
  35. gregg098

    gregg098 LI Guru Member

    It is now always on.
  36. Talon88

    Talon88 LI Guru Member


    Do anyone know, after update to v1.20 or v1.21,
    I have many of the following when I am using
    Bit Torrent.

    Thanks In Advance!


  37. dewx

    dewx LI Guru Member

    I saw the "ip_conntrack_pptp.c: bad csum" in the syslog in even back in v1.19. After BT, the whole syslog is filled with that message.
  38. tehgeek

    tehgeek Network Guru Member

    ip_conntrack_pptp.c: bad csum
    I saw it several times in logs after updating to the original 1.20 I think it was. I haven't seen it since the 1.20test2 version or at all on 1.21 however. :)
  39. i1135t

    i1135t Network Guru Member

    Well I have DNSMASQ disabled (unchecked), and do a tracert, but it hits

    C:\Program Files\Windows Resource Kits\Tools>tracert
    Tracing route to []
    over a maximum of 30 hops:
      1     4 ms     1 ms     1 ms  router []
      2     9 ms     7 ms     9 ms
    Is is supposed to do that? I thought that by disabling DNSMASQ, it would bypass line 2, and go straight to line 3? I know that network performance is negligible, but that's one more hop my packets needs to pass through.
  40. Sunspark

    Sunspark LI Guru Member

    To the guys getting the bad csum message, it's because you're running BT on port 1723 and it's interfering with the GRE/PPTP helper. Change port and you'll not have the problem again, probably also by disabling the GRE/PPTP helper.. what I don't know is, if you disable the helper and someone on your LAN wants to use VPN, will it still work?

    Try using port 3183 instead, it's used by something called cops-tls and is maintained by some guy from ellacoya, a company that makes throttling/DPI boxes, so the port might be whitelisted. I had good luck with it the other day, but I don't d/l that much anyway.
  41. bigclaw

    bigclaw Network Guru Member

    DNS resolution merely tells you is actually It does not affect how the packets will flow from your PC to In your case, all packets have to pass through because that's your gateway to the entire Internet, and DNS has nothing to do with it.
  42. i1135t

    i1135t Network Guru Member

    If that's the case, why does it pass through ? I have no reference to what that is. I can ping it and it replies, but I DO NOT have my PCs or any network device utilizing that IP. It must be within the router, which is what I don't understand. Please, can anyone explain?

    I know that DNSMASQ caches DNS entries and have noticed slowdowns when enabled & when my router is heavily used. So I disabled it. I thought that DNSMASQ uses that unassigned IP and is why I was confused. Hmm...

    edit ---

    OK, now it doesn't make sense that is the second route outside my router... how is that possible? The second route in the traceroute should be external to my router, correct?
  43. fyellin

    fyellin LI Guru Member

    Well, presuming your netmask is, then is external to your LAN. Could it be your modem?

    When you look at Status > Overwiew > WAN > Gateway, there should be an IP address. All network traffic to the outside ought to go from your router to that IP address, and only that IP address.

    You're not doing any mucking with iptables, are you?
  44. Talon88

    Talon88 LI Guru Member


    Thanks Sunspark, look like it's like you said. I am using port
    1723 to BT. I will try to change to what you suggest & see.


  45. i1135t

    i1135t Network Guru Member

    Nope no IPtables...scripts or anything fancy. Just basic setup with QoS...which shouldn't affect it.

    Well, my WAN IP is a routable IP ... 24.250.x.x, so that's not it. Yes my LAN netmask is so that's why it puzzles me like crazy!?!? It's definitely outside my Gateway, which is I have a simple cable connection for high-speed internet connected through a cable modem to my tomato router.

    I'm using Victek's mod (1.19 still), but sad part is that I never tried a traceroute with original tomato or SpeedMOD firmware. Anyone willing to try and see what comes up on their computers when doing a traceroute? I would feel better if I was not the only one having this issue. Thanks!
  46. humba

    humba Network Guru Member

    @i1135t: Since you have a cable connection it's normal that you have another non routable IP address before things hit the public Internet. The additional IP comes from the way cable networks are built.. afaik the address is from the CMTS (where the signal is taken from your Coax cable and sent along over a fibre connection).
  47. RonWessels

    RonWessels Network Guru Member

    I just checked my cable connection, my router also has a routable WAN IP address. However, I also know that the cable modem responds to and is inbetween my router and the outside world.

    Now, my cable modem doesn't show up in a tracert, but the way that tracert is implemented that might not be surprising. The tracert algorithm is to send out packets with very short TTL (time to live) values, increasing by one for each subsequent packet. When an IP router (here used in the general sense) forwards an IP packet, it is supposed to decrement the TTL value and forward the packet if the resultant TTL value is above zero, but send back an ICMP error message if the TTL value gets decremented to zero. The intent is to prevent circular routes from building up an infinite packet backlog. By setting the initial TTL to 1, then 2, then 3, etc, the tracert program can monitor the ICMP errors coming back to determine what systems lie in the packet path.

    That's the way it's supposed to work. But if you get devices (such as perhaps my cable modem) that doesn't decrement the TTL value since it wants to remain "invisible", it won't show up on a tracert even though it is in the packet path.
  48. i1135t

    i1135t Network Guru Member

    Thanks for the info guys... much appreciated. I did'nt know there was a non routable IP within the cable modem itself... that explains it alot.. I dunno why it would show up on a tracert for some networks and not for others... interesting nevertheless.
  49. linsook

    linsook Guest

    having issues resolving some domains names however the ip works ie: google. gets messed up everyday, super annoying.
  50. kwag

    kwag LI Guru Member

    Yep. Same here. Waiting for 1.22
  51. hardc0re

    hardc0re Network Guru Member

    Is this the same problem as 1.20?

    So far I'm using 1.21 (SpeedMod) and DNS seems to be okay (unlike 1.20). Uptime almost 3 days.
  52. alpine1

    alpine1 Network Guru Member

    My uptime is 8 days. So far no complaints from any of the users. Thank you.
  53. Talon88

    Talon88 LI Guru Member


    Name Tomato
    Model Buffalo WHR-HP-G54

    Time Mon, 11 Aug 2008 23:57:54 -0400
    Uptime 8 days, 03:28:20
    CPU Load (1 / 5 / 15 mins) 0.00 / 0.00 / 0.00
    Total / Free Memory 14.19 MB / 1,104.00 KB (7.60%)

  54. F157

    F157 LI Guru Member

    Uptime is now 15 days, no problems =)

    Router is WRT54GL
  55. bogderpirat

    bogderpirat Network Guru Member

    i'm having problems using BT. if i'm maxing the line (~1.6MBps), ksoftirqd_CPU0 consumes a hell of a lot of cpu. load averages are usually well above 1.00. this gets better when i throttle the bandwidth, however didn't occur with 1.20 (or .19, and it didn't bother me as much in .20).

    log is clean though.
  56. fun.k

    fun.k Addicted to LI Member

    Uptime: 3 days, 01:49:01

    except for some occasional temperamental browsing lag (could be due to OpenDNS issues) no biggie so far

    i do get this funky error though:

    Aug 16 18:18:21 unknown user.warn kernel: KERNEL: assertion (newsk->state != TCP_SYN_RECV) failed at tcp.c(2225)
    Aug 16 18:18:21 unknown user.warn kernel: KERNEL: assertion ((1<<sk2->state)&(TCPF_ESTABLISHED|TCPF_CLOSE_WAIT|TCPF_CLOSE)) failed at af_inet.c(689)
    Aug 16 18:18:28 unknown user.warn kernel: KERNEL: assertion (newsk->state != TCP_SYN_RECV) failed at tcp.c(2225)
    Aug 16 18:18:28 unknown user.warn kernel: KERNEL: assertion ((1<<sk2->state)&(TCPF_ESTABLISHED|TCPF_CLOSE_WAIT|TCPF_CLOSE)) failed at af_inet.c(689)

    after further observation, looks like 1.21 does not like OpenDNS syncing, every time the router tried to sync, i'd get the error above in the Log...

    Switched back to 1.19 and all systems are go!
  57. kallsop

    kallsop LI Guru Member

    Ran 1.19 for the longest time, not a single glitch. 1.21 ran for about two weeks and wireless clients were connected but lost WAN, wired was working fine. Rebooted, ran for one day, wireless lost WAN again. Put 1.19 back in, let's see how long it runs.
  58. kwag

    kwag LI Guru Member

    For months!
  59. Gewehr98

    Gewehr98 LI Guru Member

    Sorry to say...

    I reluctantly switched back to v1.19 last night, after the router locked up for a third time in as many days. We hit our little WRT54G v1.0 pretty hard on a regular basis, with 6 computers and 4 users, lots of WarCrack, P2P, 3 SnapServers, VBrick video/audio security camera traffic traffic, Vonage, and more. Sometimes newer isn't necessarily better? :frown:
  60. asterger

    asterger Network Guru Member

    Nonbroadcast SSID not Shown in Wireless Survey


    In a comparison with my laptop's Broadcom Wireless Utility, noticed an extremely high signal from a nonbroadcast SSID in a nearly adjacent channel. This signal was not indicated within Tomato v1.21 Wireless Survey.

    Is there a way to see nonbroadcast SSIDs in Tomato's Wireless Survey? If not, I recommend inclusion of these signals in a follow-up release.


  61. Would it be possible to implement 'Src or Dst' IP matching a QOS rule?


    any traffic from or to should be matched within one qos match rule.

    thx in advance



    i noticed that when using the 'router' mode (No NAT/FW) instead of the Gateway mode the Remote Access is not working.

    This is probably because Remote Access is using a simple Port Forwarding, but since in the router mode there is no nat, it doesn't work properly.
  62. der_Kief

    der_Kief Super Moderator Staff Member Member


    Jon released a new testing version !


    "This is a test build that uses the newer Busybox 1.12.1. Busybox is used in various areas of the firmware for something as simple as copying a file to DHCP. Since it is used in a lot of areas, there may be a few minor problems that have yet to be discovered. Note there are no significant 'visible' improvements in this test build, so please use the regular versions above for normal installations

    He also implement an option to disable/enable "extended" logging for PPPoE ( nice upgrade :wink: ).
    Please try it and give Jon a feedback ! THX.

  63. F157

    F157 LI Guru Member

    Thanks for the update, I guess I install as soon as my router reboots and my uptime is gone ;)

  64. pharma

    pharma Network Guru Member


    Thanks for the update on Jon's new 1.21 test firmware. The flash went smoothly and everything is running quite well! :)

  65. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi @ll

    whats your experience with the updated busybox ? For me its stable for now 16 days. No problem at all. Hope Jon will integrate this in next version. But please give Jon a feedback when trying "new" version. Thanks.

  66. Slimey

    Slimey Network Guru Member

    feels good here ;)
  67. asterger

    asterger Network Guru Member

    Tomato v1.21.1545 stable for 16 days and counting.

    -- asterger
  68. Dashiell

    Dashiell Network Guru Member

    1.21.1545 up on WRT54GL 9 days no problem! I have even been experimenting with dnsmasq scripts.
  69. Toastman

    Toastman Super Moderator Staff Member Member

    Appears to be quite stable!
  70. Dashiell

    Dashiell Network Guru Member

    Jon has posted yet another test build!

    "Some changes from above: Enabled ebtables (note: use modprobe), more flexible DHCP start/end, display rolling total from last 30 days in Bandwidth:Daily."


    Please send feedback and comments!
  71. Dashiell

    Dashiell Network Guru Member

    One small issue so far:

    When using IE7, the "Basic" tab under "Network" malfunctions, and completes with "error on page." Settings seem permanently fixed on "wireless bridge mode," with various functional problems. Error on page reveals "object required." No changes can be made. When clicking on save changes nothing happens.

    None of these problems exist in Firefox or Google Chrome.

    Using 081105_1-21-1558.7z on WRT54GL v1.1
  72. Dashiell

    Dashiell Network Guru Member

    Few other small issues:

    In the Status: Overview page, the DHCP range shown does not reflect the range entered on the Basic: Network page.

    This does not seem to affect functionality (the logs show the correct range set), just cosmetic/informational.

    The number entered in Advanced: DHCP/DNS for Max Number of DHCP leases will not stick after save. Reverts back to 255 every time (using a 192 based lan).

    Jon, your work is brilliant I might add.
  73. asterger

    asterger Network Guru Member

    I concur with the errors Dashiell dicovered on Basic: Network page. "wireless bridge mode" appears fixed. IE 6 indicates 2 errors, 'object required' (line 363) and 'prefix' is null or not an object (line 1756).

    Thank you Jon for your efforts.
  74. der_Kief

    der_Kief Super Moderator Staff Member Member

    @Dashiell & @asterger

    did you mail this issues to Jon ?
    Jon doesn't visit this forum alot !

  75. Dashiell

    Dashiell Network Guru Member

    Indeed I have. Thx!
  76. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi @ All,

    Jon released a new testing version:

    Changes from above: Fixed Basic:Network would not work in IE, fixed several GUI problems related to DHCP changes, proper id/support for WL520GU thanks to Michael G.

  77. SirDracula

    SirDracula Network Guru Member

    Do these new versions fix the periodic reboots caused by 'wl' and Intel wireless clients?
  78. Dashiell

    Dashiell Network Guru Member

    WRT54GL running 081108_1-21-1562.7z since release, no problems so far... anyone else?
  79. Odin-60

    Odin-60 LI Guru Member

    v1.21.1562 on WRT54GL, working as a router/gateway
    in conjunction with an ADSL modem: no problems so far.
    Thank you, Jon!
  80. JPorter

    JPorter LI Guru Member

    For those using the new builds... did your prior settings preserve, or did you have to reconfigure?
  81. Dashiell

    Dashiell Network Guru Member

    I always do an nvram erase/restore defaults after flashing. Always. It just gives me the peace of mind about the whole thing. I cannot tell you the troubles in the past that have come up from NOT doing this, especially back in the day when I attempted to use DD-WRT.
  82. der_Kief

    der_Kief Super Moderator Staff Member Member

    No problems at all :thumbup:

    This is from official FAQ:

    If you're upgrading from an older version of Tomato, you don't need to perform a reset. Unless indicated in the release notes, Tomato will automatically upgrade older configurations if necessary.

    If you upgraded from another firmware, a complete reset is recommended. Go to Administration/Configuration and select "Erase all NVRAM..." after installing Tomato.

    For me i only reset if i run in troubles or if Jon mention to do so.

  83. Sunspark

    Sunspark LI Guru Member

    I have 28 days of uptime on build 1544 of the ND version on this WRT54GL.

    The wireless 'freezes' were due to neighborhood problems with cordless phones, N routers, or something else, but since I went to channel 11 I haven't had any more 'wireless deaths' on my laptop so that's great.

    Only thing I notice that is different about this build compared to 'release' 1.21 of the 3.90 old drivers, is that less free memory is available in the router.. about 800 to 1024 k. But as long as it doesn't go too low, that's fine. This caught my attention as I worried it might have been a memory leak, but it seems stable enough.
  84. Dashiell

    Dashiell Network Guru Member

    Perhaps you should mention that memory bit to Jon. Send him an email.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice