Official Tomato v1.22 released!

Discussion in 'Tomato Firmware' started by TVTV, Nov 17, 2008.

  1. TVTV

    TVTV LI Guru Member

    Official Tomato v1.22 is OUT!

    Changes from previous version(s):

    Routers that are known to work with Tomato:
    • Linksys WRT54G v1-v4, WRT54GS v1-v4, WRT54GL v1.x, WRTSL54GS (no USB support)
    • Buffalo WHR-G54S, WHR-HP-G54, WZR-G54, WBR2-G54, WBR-G54, WZR-HP-G54, WZR-RS-G54, WZR-RS-G54HP, WVR-G54-NF, WHR2-A54-G54, WHR3-AG54
    • Asus WL500G Premium (no USB support), WL500GE
    • Sparklan WX6615GT, Fuji RT390W, Microsoft MN-700
    This will not work on Linksys WRT54G/GS v5 or newer WRT54G/GS routers.

  2. davidehue

    davidehue Addicted to LI Member

    Nice.. I have downloaded the newest firmware and upgraded my WRT54GL.
    Could somebody tell me how to activate the usb support (for printer and storage) using WL-520gu?

    I have followed the tutorial:

    But my HP 1410 printer was not recognized by the p910nd driver. Anyone knows how to update the p910nd driver?

  3. flor1n

    flor1n Addicted to LI Member

    Great news ! Thanks for the notification !

    BIOYAM Guest

    Thank you!!!
  5. valerima

    valerima LI Guru Member

    memory leak in newer 21v.builds

    Originally Posted by Sunspark
    I have 28 days of uptime on build 1544 of the ND version on this WRT54GL.

    The wireless 'freezes' were due to neighborhood problems with cordless phones, N routers, or something else, but since I went to channel 11 I haven't had any more 'wireless deaths' on my laptop so that's great.

    Only thing I notice that is different about this build compared to 'release' 1.21 of the 3.90 old drivers, is that less free memory is available in the router.. about 800 to 1024 k. But as long as it doesn't go too low, that's fine. This caught my attention as I worried it might have been a memory leak, but it seems stable enough.
    Did you test this in version 22?
  6. minimario

    minimario Addicted to LI Member

    I think you can thank me for the new release. I just put v1.21 on a new WHR-HP-G54 last night! ;-)

    Nah I think Jon still deserves bigger chunk of the credit. :)

    How's the "extra caution" ND-series progressing? Any reason to try it on the standard supported hardware?
  7. The-Kevster

    The-Kevster Addicted to LI Member

    Alot of people are running the ND build including myself and I find it MORE stable. Just need a 1.22 SPEEDMOD-ND version now :)
  8. TVTV

    TVTV LI Guru Member

    So far, so good: Uptime: 0 days, 12:32:24.
    I'ven't had any issues yet.
  9. Morac

    Morac Network Guru Member

  10. spliff

    spliff LI Guru Member

    So will a direct flash to the WL-520GU work without having to flash to DD-WRT first? It is supported now?
  11. davidehue

    davidehue Addicted to LI Member

    I think you can use the Asus Firmware Restoration to flash the wl-520gu to Tomato firmware directly (CMIIW)
  12. der_Kief

    der_Kief Super Moderator Staff Member Member

    Upgraded without any problems. Nice work Jon :thumbup:

  13. Dashiell

    Dashiell Network Guru Member

    If my memory serves, Victek was waiting for the 1.22 release to implement all of his "new" stuff in his mod...
  14. digitalgeek

    digitalgeek Network Guru Member

    I don't understand how people are using the ND driver on a GL when it not intended for that router?
  15. TVTV

    TVTV LI Guru Member

    Well, it may not be intended for that router, but that doesn't mean it won't work with it. Not that i'm using it or that i would use it.
  16. Dashiell

    Dashiell Network Guru Member

    I must admit I'm unclear on that as well... but instead of "how," I'm thinking more like "why?"
  17. katapaltes

    katapaltes Guest

    WL-520GU needs the ND version?

    Regarding the WL-520GU, I just sent the following to the author. Maybe I did something wrong, but wanted to mention it to you / him just in case. I can now do WPA/AES + WDS! I couldn't get that to work with DD-WRT on my hardware.

    "Hi! I just switched from dd-wrt to get WPA/AES + WDS between my WHR-G125 and my WL-520GU, two almost identical routers.

    Your home page says to use the ND version of 1.22 with the Buffalo WHR-G125. I did that and it works great on my WHR-G125. The same page mentions that the ASUS WL-520GU is "known to work with Tomato," but the reader (or should I say *I*) might assume that he can use the regular, non-ND version. While this may work for some, it momentarily bricked my WL-520GU router. I then loaded the ND version of 1.22, and it sprang back to life.

    Much grass for Tomater.
  18. Dashiell

    Dashiell Network Guru Member

    1 day, 11 minutes. Seems to be completely solid. Been bashing at it pretty hard. 4 wired PCs, 3 wireless.
  19. gjcomputer

    gjcomputer Addicted to LI Member

    wow, a new release right after i upgrade to a WRT310N... any news on when there might be a release (support) for this router?

  20. Toastman

    Toastman Super Moderator Staff Member Member


    The driver is backwards compatible with the GL chipset and works just fine.

    To answer your question as to *why* people may want to use the ND driver on a GL - probably because it is a partial solution to the problem of reboots when certain Intel wireless cards attempt to associate with the router. If you search the forum for 2200BG you will find much information on the subject.

    The final cure will be an upgrade to a newer Linux kernel so that a much more recent version of the Broadcom wireless driver can be used. DD-WRT has already done so.

    Some others have also reported that the ND driver gave a speed improvement with this router.

    1.22 stable so far :clap2:
  21. guillaumy

    guillaumy LI Guru Member

    I tried to deploy 1.22 ND version on some Buffalo routers WHR-HP-G54.

    Suddenly one of the Dell laptops (with Intel 2200BG wireless) could not associate.

    So a quick switch was made to the non-ND version of 1.22.

    No issues at all so far.
  22. TVTV

    TVTV LI Guru Member

    Is Jon planning to upgrade the kernel? Or is it just a wild guess? :D
  23. M_ars

    M_ars Network Guru Member

    Works fine for me. Updated from 1.19 without any troubles :)
  24. Talon88

    Talon88 LI Guru Member


    Cool, Thanks for the update...!

  25. Rafatk

    Rafatk Network Guru Member

    Thanx Jon!
    Working just fine!

    Uptime 1 day 13 hours and 15 minutes.
  26. teddy_bear

    teddy_bear Network Guru Member

    Does this release fix the slow running clock issue for WL-520GU?
  27. davidehue

    davidehue Addicted to LI Member

    Work fine without any problem with my WRT54GL ver. 1.0
    Uptime: 3 days, 02:37:31
  28. tin68

    tin68 Addicted to LI Member

    Thanks a lot for this upgrade - works well with WRT54GL V1.1 in our private network (LAN and WLAN) with laptops and PC's under XP and W2k.

    But: But there is now a problem with the laptop running Vista (there we didn't change anything in the configuration): Going to neighborhood - the other PC's and laptop are missing now after the upgrade to Tomato version 1.22.

    Any help?
  29. PaCkEtGrEmLiN

    PaCkEtGrEmLiN Network Guru Member

    Noticed a logging glitch introduced in this release while testing on WRT54G v1.1. Not tested on my GS's yet.

    To get logging to a "Remote System" to work you have to Enable the "Log Internally" option as well.

    Anybody else noticed this?
  30. averylinden

    averylinden LI Guru Member

    Same here, 1.22 ND on a WRT54Gv4
  31. blackrhino

    blackrhino LI Guru Member

    Same here..on WRT54G
  32. Odin-60

    Odin-60 LI Guru Member

    Maybe only the label text for the uppermost checkbox is wrong:
    It should read "Enable Logging" rather than "Log Internally". :wink:
  33. TVTV

    TVTV LI Guru Member

    Well, i've changed my mind. After reading some stuff about the ND (new drivers), i've decided to give them a try. So, after upgrading from the "normal" "Tomato Firmware v1.22.1570" to the "ND" "Tomato Firmware v1.22.1569", i can (almost) safely say that the ND version works like a charm on the WRT54GL v1.1 (installed the .trx straight from Tomato's WEB interface).
    The brief tests i've managed to do so far show that the transfer speeds are in the same area as with the "non-ND" version of Tomato 1.22 and the overclocking capabilities are the same. I'll report on stability after a few days, although i have a scheduled power outage in my area on Monday (something to do with changing an old fusebox, blah-blah - i should really get an UPS).

    Why did i upgrade to the ND version of Tomato? Boredom, maybe, 'cause everything worked just fine with the non-ND version aswell. I wouldn't recommend using the ND version if your router works fine with the standard build or you don't have an unbricking solution at hand.


    Apparently, there is a way to check if your router is compatible with the N(ew)D(rivers).

    To "examine" wl0_corerev you must type "nvram get wl0_corerev" in your router's console.

    My WRT54GL v1.1 returned a 9, that's why i gave the ND's a try. Anything lower and i wouldn't have installed.

    ND's help solve the Intel-wireless NIC reboot problem and have been reported to be faster for some poeple. Other than that, they support multple SSID, feature which isn't, AFAIK, yet implemented in Tomato.
  34. Sunspark

    Sunspark LI Guru Member

    Yes.. 2x the memory is available in the 1.22 so it must have been debug code. But you know, it wasn't unstable then, and it isn't now. I'm happy enough!
  35. rhester72

    rhester72 Network Guru Member

    The only issue I've found with 1.22 so far is inaccurate bitrates in the real-time bandwidth graphs. They are pretty far off, and completely fail to line up with the "real-time" QOS graphs (which do display accurate outbound bitrates). :/

  36. pupu

    pupu Guest

    Had same issue with Dell laptops (with Intel 2200BG wireless) could not associate with WL-520gu flashed in Tomato ND v1.22.
    Tried flased with non-ND version but no luck, not working at all.
    Hopefully the ND issue with Intel 2200BG wireless client can be resolved soon.
  37. 4char

    4char Network Guru Member

    I do have the same problem with Dell laptop with Intel wireless (I'm using WRT54GSv3). I could not connect that laptop with the tomato 1.22ND version (with none ND version it's still not easy to connect). I switched back to 1.21 and the laptop connected right way and has no problem. I'm sticking to 1.21 for now.
  38. KLink

    KLink Guest


    Yes -- using a WRT54GS v4. It's only a minor annoyance but it took the better part of an hour to figure it out.
  39. PaCkEtGrEmLiN

    PaCkEtGrEmLiN Network Guru Member

    FYI - Jon has already addressed the logging glitch in test build. I suspect another release is forth coming.
  40. Edrikk

    Edrikk Network Guru Member

    If Jon is reading this forum, it would be great to also have a dropbear upgrade. 0.52 was release a couple of weeks back.
  41. der_Kief

    der_Kief Super Moderator Staff Member Member

    Jon is not very often here @ Linksys. Maybe you should contact him by email.

  42. test100

    test100 LI Guru Member

  43. ziddey

    ziddey Network Guru Member

    g125 on 1.22nd + dell xp with 2200bg no go :(
  44. TVTV

    TVTV LI Guru Member

    I see that Jon has released a new test build that fixes the remote logging not working if local logging is turned off issue and adds dnsmasq v2.46. Maybe someone whom he has talked to before can ask him to add TCP Vegas support (also via GUI) to the next official revision of Tomato?

    this is from polarcloud:
    (please don't link the files directly - Thanks)

    TVTV edit: oops, sorry, the power of habit! :)
  45. jksmurf

    jksmurf Network Guru Member

    I seem to have a similar problem with 1.22 and the network map in Vista, and looking around the internet seems to suggest that the router (yes I have installed the Link Layer Hotfix update for WinXP PC's) may not be recognised? I also seem to have a problem with UVNC and resolution of hostnames within the LAN, not sure if this is related? Will try 1.19 downgrade.



    This is the error and the info about it:

  46. der_Kief

    der_Kief Super Moderator Staff Member Member

    New dnsmasq is working without any problems with my setup !
    Logging bug seems to fixed as well. Good work as ever :thumbup:

    THX Jon
  47. TVTV

    TVTV LI Guru Member

    A new test build is out!

    Will install it in a few minutes.
  48. The-Kevster

    The-Kevster Addicted to LI Member

    Has now been added in version 081127_1-22-1586 ready for download :D
  49. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi @ All,

    just upgraded to the new testing version. No problems as ever :biggrin:

    But now i have two questions about the new features:

    - Does TCP Vegas & QoS work together without affect each other ? Or is it better to disable QoS when TCP Vegas is enabled ? I read about it but its not clear whats better.

    - Is it usefull to enable SYN cookies ? All i read about it should help to prevent DoS attacks. So enabling shoud be good for security but are there some sideeffects when enabling this feature ?

  50. TVTV

    TVTV LI Guru Member

    Thank you Jon, Kevster. ;) I'm testing the new build's stability and functionality as we speak.

    So far i haven't noticed any performance impact or odd behaviour when using Vegas with QoS enabled. However, HTTP seems more responsive under heavy P2P traffic. I will conduct some more tests in the morrow.


  51. der_Kief

    der_Kief Super Moderator Staff Member Member

    This is the answer from Jon :biggrin:

    I love tomatos :thumbups:

  52. Talon88

    Talon88 LI Guru Member


    Thanks Jon for the hardwork & update.
    I love Tomato!

    One things I hope Jon can add to Tomato GUI is,
    have the Default value next to the settings.
    This can help us to try some setting &
    easy to set them back to default. I hope it
    is not so hard to apply.


  53. djeanprost

    djeanprost Addicted to LI Member


    I just tried to upgrade to 1.22ND on wrt54g v3.1, and it seemed to work until I noticed that dns on my local network didn't work after upgrading. I mean I couldn't ping a name on my network, I only could ping an ip address.
    After going "back" to 1.22, it worked well.

    I add that I had never tried any ND firmware before.
    Hope this helps someone.
  54. djeanprost

    djeanprost Addicted to LI Member

    Well after noticing that my dns problems still occured, I swithed back to 1.22ND and reseted settings to default and rebooting, it seems to work.
  55. vanhh

    vanhh Network Guru Member

    I'm using tomato test build version 1-22-1586. It's running really good, but I have noticed it takes a slightly longer to establish internet connection with 1-22 version than 1-21 after reboot. Is it just me or someone else notices that?
  56. Sunspark

    Sunspark LI Guru Member

    Right Der Kief..

    Well, my question still stands.. what's the difference between the settings of 2-6-2 versus 1-3-1 ? I don't see anything in this thread where it is mentioned, just talk about how to turn it on, and whether it plays nice with QoS.
  57. Morac

    Morac Network Guru Member

    I'm using 1.22 and today I noticed that DNS for stopped working all the sudden (it worked one instance and then it didn't). nslookup failed, so I unchecked the "Use Internal Caching DNS Forwarder" option which allowed nslookup to work, but I still couldn't get there on my laptop. I ended up checking "Use Internal Caching DNS Forwarder" and then rebooting the router and finally "repairing" my wireless network which seemed to fix the problem.

    This happened with about a 2 week uptime on 1.22. My prior uptime with 1.21 was a few months.

    Has anyone had DNS forwarding failures with 1.22?
  58. der_Kief

    der_Kief Super Moderator Staff Member Member

    So i think you should contact Jon and ask him. Or you can try to find the answer in this thread.
    If you are successful please share your answer to the community.

  59. rhester72

    rhester72 Network Guru Member

    The documentation on tuning Vegas was supplied in my FAQ - Jon accepted my backport but I doubt he has any in-depth knowledge of the Linux implementation of the algorithm. The docs on the URL I supplied are pretty sparse, granted - but in the end, some experimentation is required to find the best results for your usage pattern.

    If you truly want to know what the alpha, beta, and gamma parameters are actually adjusting, a somewhat-detailed answer is at that URL under Vegas Tuning (it involves how many packets are kept in queue), and a much more detailed explanation is in the kernel source itself (written by the original implementor).

  60. callous

    callous Network Guru Member

    Hello, Tomato's a great firmware!

    I have found a bug that with the view graphs for QOS.

    If you selected "Default class" as "Lowest", then for Bandwidth Distribution (Outbound) it wont show up at all in the outbound bandwidth, as there is no unclassifed class for bandwidth, and unclassified class isnt known by the firmware to be the same as the "Default class", which in my case is set as "Lowest".

    I have rules for everything other than bittorrent, and bittorrent then by default becomes "lowest" and that wont show up at all in the outbound bandwidth even though it takes out around 80% of the outbound bandwidth at any time.

    Is there any plans to perhaps look into this for the next revision? :)
  61. rhester72

    rhester72 Network Guru Member

    I'm not sure I understand the problem. I have Lowest as my default classification, with no specific classification rules to that class (so torrents and such go there), and Lowest shows up as expected on my QOS graph and correctly represents the connection count and bandwidth.

    Unclassified is LAN traffic and doesn't really play a role here, which is why it is included in the connection count but not the bandwidth distribution.

    I don't see a bug.

  62. callous

    callous Network Guru Member

    What could have went wrong so that even though torrents show up as lowest in connections distribution it doesnt show up in lowest for bandwidth distribution ?

    How should I go about troubleshooting this one?
  63. rhester72

    rhester72 Network Guru Member

    Not sure - have never seen this happen. Have you tried rebooting the router after applying the rules? (I did not need to do so, but perhaps it will help.)

  64. callous

    callous Network Guru Member

    ah ok I found the issue - I put the Lowest as: NONE - 100% bandwidth, that is why it isnt showing up the bandwidth distribution graph

    Does "none"-100% mean torrents can have 0-100% of bandwidth, and 0% bandwidth if the higher priority items needed all the bandwidth? or does it mean no bandwidth at all?

    I actually wanted 0-100% for lowest. I find none"-100% for lowest still meant my torrents continued to run
  65. mikester

    mikester Network Guru Member

    Does the WRT54GL work using the "Tomato_1_22_ND.7z" version? I am trying to resolve random drop outs of the WAN.
  66. rhester72

    rhester72 Network Guru Member


  67. der_Kief

    der_Kief Super Moderator Staff Member Member

    Jon released a new testing firmware:


    "Removed the ebtables patch which appears to be causing a few problems. Sorry guys... If you had connectivity problems after installing 1.22, please try this. "

    So nothing special but for those who have troubles its maybe interesting !

  68. fun.k

    fun.k Addicted to LI Member

    i also experience strange surfing since upgrading to 1.22: youtube won't load and most .swf content would become unloadable

    gotta try jon's latest test build or switch back to 1.19...
  69. Paramedic

    Paramedic LI Guru Member

    W-lan-homenetwork does'nt work under 1.22, same computer, same settings connected with lan, everything is o.k! Gone back to 1.19 w-lan-homenetwork is o.k. again!
  70. flor1n

    flor1n Addicted to LI Member

    I'm running latest test build (081205_1-22-1590.7z) since few days and until now everything works fine !
  71. Odin-60

    Odin-60 LI Guru Member

    After upgrading from "regular" v1.22 to the test build 1.22-1586, the
    internet connection used to "hang" unusually often: Web pages sometime
    needed several seconds (up to a minute) before they would start to load,
    Thunderbird needed some time before it would start downloading new
    messages etc.

    It seemed _not_ to be a problem with DNS; name resolving used to occur
    immediately; only _afterwards_ the connections used to stall.
    Note that installing 1.22-1590 didn't improve anything. In contrast, the
    problems grew worse.

    I am fully aware that it may happen from time to time that a server is
    unresponsive or that there is a "traffic congestion" somewhere in the
    internet. However, this happened _unusually_ often in the last 2 weeks.
    My ISP is providing a user forum; there were no particular reports regarding
    speed problems or backbone congestions in the last weeks. Also my
    DSL connection was running flawlessly.

    Two days ago I switched back to the normal 1.22 release and -- voilà --
    the problems are gone. Lucky coincidence?

    FYI: I'm using a WRT 54 GL.
  72. Kye-U

    Kye-U Addicted to LI Member

    I'm scared of upgrading to 1.22; I think I'm going to wait for 1.23 to come out ;)
  73. flor1n

    flor1n Addicted to LI Member

    @ Kye-U I think it would be better to wait for 1.67 version to come out... or maybe 2.43 it surely be better :) . Just in case you didn't noticed the statement from "about" section of your Tomato here it is :
    "Thanks to everyone who risked their routers, tested, reported bugs, made suggestions and contributed to this project"
    No offence :tongue:
  74. brookie

    brookie LI Guru Member

    Clicking on Shutdown will corrupt all QOS classifications. Internet cannot be reached.

    Router and Cablemodem can be reached but no internet access. All connections revert to unclassified. COnfirmed by viewing QOS\Details.

    Disabling QOS and deleting classifications works sometimes. Other times I had to upload an old configuration file to access the internet again.

    Tried going into Advanced/DHCP/DNS and click save to reset DNS but no go. At least on this system the Shutdown seems to corrupt the classifications, or turn off some type of process.

    Hard reboot of router and cable modem had no effect.

    Is there some service I can restart via putty or telnet?

    System, WRT54G v2.2, Tomato 1.22
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice