Official Tomato v1.23 released!

Discussion in 'Tomato Firmware' started by nvtweak, Dec 14, 2008.

  1. nvtweak

    nvtweak LI Guru Member

    Thanks to Jon!

    Get it here.

  2. CBR900

    CBR900 Network Guru Member

    10x alot

    can some1 explain this

    "DDNS now works even if WAN is disabled as long as DDNS uses an external checker or a pre-defined IP (Basic:DDNS:IP Address)."

    How it will work when WAN is disabled? you can not reach the router from the internet?
  3. peyton

    peyton Network Guru Member

    GG ! :smile:
  4. nvtweak

    nvtweak LI Guru Member

    DDNS can work on a router that isn't directly facing the net because it is the DDNS provider who should check/log/update your external WAN IP address. Even if the WAN IP is on another router.
  5. jeradc

    jeradc LI Guru Member

    TCP Vegas was added, very nice. Glad to see community effort "pay off" like this.
  6. flor1n

    flor1n Addicted to LI Member

    Great news ! thanks !
  7. CaNsA

    CaNsA Network Guru Member

    Anyone know if there is WPA2 support in wireless bridge mode yet?
  8. az2008

    az2008 Addicted to LI Member


    Does anyone think it's right for uPnP to be enabled by default?

    I've noticed strange behavior, like ports being opened that I didn't authorized. When I just installed 1.23, within 5 minutes two ports were opened.

    I noticed all this a few weeks ago when running Wireshark and seeing a ton of activity to strange locations (I'm not familiar with, like .pl domains, etc.).

    I know this sounds like I'm infested with spyware, spambots, viruses. But, I run anti virus, a software firewall (in addition to the hardware firewall), and I ran adware to look for spyware.

    So, I don't really understand it. But, to me, being enabled by default seems like a bad choice. Is this just me?

  9. nvtweak

    nvtweak LI Guru Member

    I don't like it either. This is partly the reason I compile my own version of Tomato. To disable some features like UPnP and open (unencrypted) wireless.
  10. der_Kief

    der_Kief Super Moderator Staff Member Member

    Just upgraded right now without any problem. The testing version before didnt make troubles to me either ! So nice work Jon and THANKS for the usefull enhancements + upgrades.


  11. rickh57

    rickh57 Network Guru Member

    I just upgraded my two WRT54g routers with v1.23. No problems so far....
  12. flor1n

    flor1n Addicted to LI Member

    Also I have upgraded and no issues so far ! already 1h 36 uptime :)
  13. Odin-60

    Odin-60 LI Guru Member

    To my opinion, uPnP should not be enabled by default.
    This is a security hole.
  14. nvtweak

    nvtweak LI Guru Member


    Some have argued that UPnP is more secure because it closes ports when they are no longer in use. I disagree with that. A manually forwarded port is also closed when it is no longer in use.

    UPnP is about convenience. Not security.
  15. mstombs

    mstombs Network Guru Member

    upnp is convenient, miniupnp could be more secure, but a rogue task on a PC in your lan does not need to open ports to phone home - so not enabling upnp doesn't help much!
  16. nvtweak

    nvtweak LI Guru Member

    It doesn't need to be a rogue task. It can be anything. Even something legit which just so happens to be exploitable. Personally I would rather decide myself whether or not ports should be open to the internet.

    I haven't read up on miniupnp. What makes this more secure?
  17. teddy_bear

    teddy_bear Network Guru Member

    Hi nvtwek and others,

    Could anyone please help me with building Tomato from sources? I want to make a few changes to it - including these defaults you described above and some other stuff. I'm a developer myself (windows though), and can make source changes I need but compiling under linux is a bit over my head yet.

    I'm trying to build it under Ubuntu 4.2.3-2ubuntu7 (Linux ver. 2.6.24-22-server). I can compile original Linksys sources without errors, and it creates firmware images. However, if I apply changes Jon described in Tomato's README file (remove some file, extract Tomato and Tomato-ND sourced on top of Linksys files, set PATH etc), I'm getting errors compiling Tomato. It goes on for a while (it seems to compile the kernel ok), and then there's a message in output:
    make[3]: Entering directory `/home/[username]/tomato/release/src/router/shared'
    In file included from shared.h:4,
                     from process.c:14:
    tomato_profile.h:7:2: #endif without #if
    followed by a bunch of errors. When I look at the tomato_profile.h, it contains the following:
     -e #ifndef TOMATO_PROFILE
    #define TOMATO_G 1
    #define PROFILE_G 1
    #define PROFILE_N 2
    Notice the "-e" in the first line? Somehow it gets there - any idea how? If I manually fix the tomato_profile.h and run "make" again, compilation goes further, but then I get another error later:
    make[2]: Entering directory `/home/[username]/tomato/release/src/router/www'
    rm -rf /home/[username]/tomato/release/src/router/mipsel-uclibc/install/www/www
    mkdir -p /home/[username]/tomato/release/src/router/mipsel-uclibc/install/www/www
    cp *.gif *.png *.ico robots.txt /home/[username]/tomato/release/src/router/mipsel-uclibc/install/www/www
    for F in *.{js,jsx}; do \
    		sed '/^\/\*\s*$/,/\*\//! { s/^\s\+//; s/\s\+$//; /^\/\/ --\+\s*/d; /^$/d }' < $F > /home/[username]/tomato/release/src/router/mipsel-uclibc/install/www/www/$F; \
    /bin/sh: cannot open *.{js,jsx}: No such file
    make[2]: *** [install] Error 2
    This one I don't know how to fix. The command above (for F in ... do ... done) is executing normally when ran manually.

    I hope if I find the reason for, and fix the 1st problem with "-e", maybe it will resolve all other issues and Tomato will compile. Does anyone have any idea what could be wrong in my environment?
  18. nvtweak

    nvtweak LI Guru Member

    I compile mine in Ubuntu.

    I had to change shells. I use this (thanks to roadkill for the tip).

    #On Ubuntu, relink /bin/sh to /bin/bash instead of dash (dash is not 100% compatibile with bash)
    mv /bin/sh /bin/sh.dash
    ln -s /bin/bash /bin/sh
  19. teddy_bear

    teddy_bear Network Guru Member

    Yes! Thank you - it worked!
    Now I'm off to actually change what I want :).
  20. TVTV

    TVTV LI Guru Member

    I've noticed a problem which i don't think was present in the lastest 1.22 test build: 1.23 shows a link to the "Wireless Filter" even under the MAC addy of a wired PC, under "Device List".
  21. mstombs

    mstombs Network Guru Member


    can alternatively use NAT-PMP which is a more restricted form of UPNP.

    can use a "secure mode" clients can only port forward to themselves (by default even windows GUI can 'manage' port forwards to other lan clients).

    can set rules to restrict what internal/external ports to what clients.

    Jon has looked at Miniupnpd - there are #defines in the source for MINIUPNP_TEST, but to be properly integrated would need a custom config box sim to dnsmasq.
  22. nerdtalker

    nerdtalker Network Guru Member

    Looks like another sweet release! Flashed this onto my WRT54G-TM and putting it through its paces right now. I disabled UPNP, but that's just because I'm paranoid. TCP Vegas is on as well.

    Are default settings still considered optimal? Seems pretty good right now.
  23. brookie

    brookie LI Guru Member

    can tomato firewall stop dos attacks?


    i was getting dos attacks (outpost security suite notications) yesterday with v1.22 after letting utorrent run all night. outpost stopped them all but that means they got through my router. i upgraded to v.23 today.

    upnp is off. ut port forwarded correctly. switched ut port today.

    is there any way to set up tomato v.23 firewall to stop dos attacks?


    system and settings:
    wrt54g v2.2, tomato v23

    Respond To ICMP Ping - unchecked
    Allow Multicast - unchecked
    NAT Loopback - forwarded only
    SYN Cookies - unchecked

    QoS - disabled. it was slowing down speedtests with comcast powerboost
  24. der_Kief

    der_Kief Super Moderator Staff Member Member

  25. brookie

    brookie LI Guru Member

    thanks for the suggestion and the link. i read up on syn cookies and i'll give it a shot.
  26. srouquette

    srouquette Network Guru Member

    need an updated OpenVPN build :(
  27. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    I updated the VPN GUI build yesterday about an hour after I saw the new Tomato release. Or were you referring to roadkill's?
  28. srouquette

    srouquette Network Guru Member

    yes, I was referring to his build.
    but it's been a long time since he made an update (and he switch to Kamikaze so... :) )

    is it easy to switch from roadkill's build to yours ?
    I saw you added a GUI to configure easily the VPN, and I'm currently using generated files in the WAN Up form.
    I ask because I use this firmware to connect 2 routers, and the other one is 1000km away... :)
  29. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    Sure. You don't even have to use the GUI. If you want to continue using your WAN Up scripts, they would continue to work with my build.

    Roadkill included several other features (serial port, sd memory, etc) that I didn't (and don't plan to), so I wouldn't switch if you need those.
  30. srouquette

    srouquette Network Guru Member

    I don't need those, I think I'll try to switch this week (during Xmas, I'll see my parents, so I'll be able to manage their router if there's a problem ;) )

    thanks for your answer.

    I hope the community effort with the SVN repository will bring something good for all these mods :p
  31. Meffy

    Meffy LI Guru Member

    I only understand what wan(vlan1),wl(eth1),br0 means on the real time logging.Anyone mind explaining what exactly is eth0 and vlan0?
  32. gsan

    gsan LI Guru Member

    how to enable multi ip for the DMZ ??
  33. nvtweak

    nvtweak LI Guru Member

  34. mk500

    mk500 Network Guru Member

    After upgrading my WRT54GL to 1.23, I keep losing the ability to get to any websites after about 2-3 minutes. A reboot fixes it for 2-3 minutes. Even the internal ping/trace seems to fail. I wasn't able to diagnose the problem, but reverting to 1.22 seems to have worked.

    Sorry I have so little information.
  35. az2008

    az2008 Addicted to LI Member

    I'm using a WRT54GL (1.1 I believe). No problems. I upgraded it from DD-WRT to a test version of 1.23. Then to the official version of 1.23.

    I do some power-on resets (3-4 in a row) before flashing. Hold down the reset button, power on, release the button after 30 seconds. And then I use Tomato's admin->configuration->erase all NVRAM (thorough) after flashing (and before, if I'm flashing from Tomato).

    Maybe I'm wrong to do that. But, I just want to be sure I'm starting fresh, less chance to brick my router, etc.

    I guess I'd try the "erase NVRAM" I were you.

  36. mk500

    mk500 Network Guru Member

    If I follow your procedure; wouldn't I lose all my configuration settings? That's quite a bit of work to manually re-configure. Do you backup and re-load your settings?
  37. nvtweak

    nvtweak LI Guru Member

    That's the whole point. Reconfigure from scratch.

    This way you determine whether or not it was your config that was causing problems in the first place.
  38. az2008

    az2008 Addicted to LI Member

    I don't. But, my setup isn't that complicated. You could backup your settings. Clear everything. Then see if a more plain-vanilla configuration produces the same problem for you. If not, maybe restore the settings and see if it starts again. If it does, maybe clear NVRAM again and then manually recreate your settings.

    The problem I'm always concerned about is something left in NVRAM that would affect a new version (or a different firmware). Maybe a variable location gets mapped to a different location that happens to contain a value.

    I even recycle the power of the router after doing the NVRAM clear (with Tomato's UI). I even power on and off a time or two between each of those power-on resets I described.

    Maybe I'm paranoid. I just want to reduce any potential for something to be wrong prior to a flash, or leaving debris after a flash.

  39. fyellin

    fyellin LI Guru Member

    Has anyone written a script than generates a page: "Here is how your configuration differs from the default"?

    One of the things I hate about having to reconfigure from scratch is that I have to look at every Tomato page trying to remember what's the default vs what I changed six months ago. Then I have to write it all down. A single easily printable page with all the information would be great.
  40. mstombs

    mstombs Network Guru Member

    The router must store everything in nvram so login via Telnet/ssh and give the command

    nvram show
    capture the output, and compare using a diff program - there are

    498 entries, 12489 bytes used, 20279 bytes free.
    in mine.

    I do have a copy of most text boxes in a text file, but firefox now remembers most entries for me!
  41. quirK

    quirK LI Guru Member

    Take screenshots of your settings.
  42. bripab007

    bripab007 Network Guru Member

  43. Damarr

    Damarr Addicted to LI Member

    I just upgraded to 1.23 and I'm now getting an 'Error reading file' message when I try to restore my bandwidth stats.

    I used the same procedure as I did for 1.21 -> 1.22 - I backed up my stats, switched bandwidth monitoring to use RAM instead of JFFS2 and then turned JFFS2 off.

    After upgrading, I re-enabled JFFS2 and formatted it. I then switched bandwidth monitoring back to JFFS2, but I can't restore my most recent backup. I've tried a few versions of my stats, and only a 1.21 file from over a month ago works.

    Any ideas? I'd rather not lose most of my Nov/Dec data.
  44. az2008

    az2008 Addicted to LI Member

    FYI, I found out what caused this. A month ago I installed BitTorrent for a specific purpose. Uninstalled it a week later. It turns out BitTorrent installs something called "btDNA" which performs torrent-like processing in the background. It is a separate "add/remove programs" option which I didn't realize I needed to perform because I thought I only installed BT.

    So, I can see the possible merits of letting processes automatically configure the firewall. It was cool that this thing configured itself and was performing some kind of service for me without me having to be involved.

    But, the fact that I didn't know why those ports kept being opened, or even the process that was doing it is also an example of the tangible downsides of UpNp.

    Anyway, sorry for being off-topic. I just wanted to post the conclusion to my story.

  45. Rafatk

    Rafatk Network Guru Member

    Updated to 1.23 my WRT54GSv4, so far so good for my use!

    Uptime 16 hours.
  46. kripz

    kripz LI Guru Member

    What are good settings for Vegas Alpha, Beta and Gamma? What do they even do?
  47. aholodak

    aholodak LI Guru Member

    I upgraded to 1.23 on my WRT54G v4.0 from 1.22. I had a similar problem, my configuration is very simple, just a few open ports and SSID settings, and web pages would load extremely slowly. At times web pages wouldn't load and I'd have to reboot the router to get it to respond. Its similar to the problem above.

    I've reset the router and reconfigured my settings with the config file and still had the trouble. Just downgraded to 1.22 and loaded my config file and now everything seems okay, but not as it was. I'm going to wipe it out and reconfigure manually as suggested. Thanks guys!
  48. Sarkelaru

    Sarkelaru Addicted to LI Member

    Tomato 1.23, 10km link 1.5mB transfer, everything works fine. Thanks to Jon and Rodney
  49. TexasFlood

    TexasFlood Network Guru Member

    That's what I've been using lately and agree it works quite well. The only exception is my static IP settings which are still in an excel spreadsheet.
  50. j.m.

    j.m. Network Guru Member

    With 1.18 I got around 700 KB/s across my WDS link (WRT54G to WHR-G54S), after upgrading to 1.23 I got only 30-40 KB/s. I tried erasing NVRAM and starting from scratch, but it made no difference. Flashed back to 1.18 and all is well again. Anyone else experience similar issues with WDS on 1.23?

    When I get more time, I may try flashing the versions in between 1.18 and 1.23 to see if I can identify the point at which these problems appear for me...
  51. weaklinks

    weaklinks Guest

    Thanks Jon again without a hitch ... Quality work.
  52. gsan

    gsan LI Guru Member

    possible to fix the same MAC address for both LAN and Wireless of Asus WL-500g Premium V1 ?
  53. baldrickturnip

    baldrickturnip LI Guru Member

    I have not used the vanilla 1.23 but am using 1.23 with VPN GUI and when I add a static route then save it it does not show up in the routing table unless I save the config , do a nvram wipe and import the config back.

    can anyone verfiy if there is a problem with static routes with plain vanilla 1.23.

  54. bripab007

    bripab007 Network Guru Member

    I've noticed that, in the Device List, Tomato 1.23 no longer shows the device/client's hostnames all the time. Now, most of my devices/clients show up with asterisks instead of hostnames.

    In all the previous versions I've used, when I had the devices all assigned static DHCP leases (as I do now, as well), that they'd all show the hostname assigned on the client.

    Anyone have any ideas?
  55. i1135t

    i1135t Network Guru Member

    Dunno, that's been happening since 1.22 for me for just one hostname. Did a thorough NVRAM clear and still the same after reconfigure. Hmmmm...
  56. guillaumy

    guillaumy LI Guru Member

    No problems here. XP and Vista clients, on different workgroups, all showing up
  57. Dashiell

    Dashiell Network Guru Member

    It's been happening to me as well, but only with an HP Photosmart printer.
  58. Toastman

    Toastman Super Moderator Staff Member Member

    Also happened here, but only with one client in the building! Can't see any reason why...
  59. pharma

    pharma Network Guru Member

    No problems here using Vista 64 bit with vanilla Tomato 1.23. If people having problems are using one of the mods you might try posting in the specific Mod thread you are using.
  60. callous

    callous Network Guru Member

    is Class E a lower QOS priority than say Class A or Lowest classes?

    The wiki suggests this is not the case, but I like confirmation on this!
  61. bripab007

    bripab007 Network Guru Member

    You can define/adjust the classes to be ordered in whatever way you want.
  62. callous

    callous Network Guru Member

    How do i order the classes to what I like??
  63. Toastman

    Toastman Super Moderator Staff Member Member

    There are 10 classes in Tomato, "Highest" is really the highest, but class "E" is the lowest. I seem to remember this was in the wiki and somewhere in Jon's release notes.
  64. rhester72

    rhester72 Network Guru Member

    It is. They are prioritized in the order presented in the GUI.

  65. way2quik

    way2quik Addicted to LI Member

    I have a question.
    The * (asterisk) shows up on Device List and I have no idea who client/program it is.
    Previous versions of Tomato does not show an asterisk, anywho...
    I have 3 computers hooked up to router so .102.
    Problem is I have no idea where .103 came from. It is under br0.
    Clicking on OUI brings up "AzureWave Technologies, Inc."
    Is this someone who hacked into my wireless or is it some application I installed, or is it something else?

    Any input is greatly appreciated.
  66. bripab007

    bripab007 Network Guru Member

    Yeah, if you only have three devices hooked up, .100, .101 and .102, then I think a .103 would throw up some red flags. Sounds like someone's probably on your Wi-Fi.

    Are you using a password-protected and encrypted SSID? If not, I would do so immediately, then delete the .103 device's DHCP lease from Tomato's device list.
  67. callous

    callous Network Guru Member

    Ok thank you!
  68. way2quik

    way2quik Addicted to LI Member

    Yep, WPA Personal TKIP secured. Deleting the lease didn't do anything, they can easily reconnect right away, I believe?

    The issue I have is switching to WPA2 Personal may or may not have an impact on my PS3 wireless. But I'll figure this one out myself.
  69. spicoli

    spicoli LI Guru Member

    Hey Rodney, any chance for speedmod 1.23? I like to be as close to the official build (don't need bells and whistles really) but speedmod really helps and your builds are "nvram safe". :3
  70. Toastman

    Toastman Super Moderator Staff Member Member

    Several people, including myself, have had this asterisk thing happen, usually it is with people who have full permission to access the internet, but we don't know where the asterisk comes from. The thread is on this forum somewhere, but I couldn't find it quickly...

    Yours shows on br0 - which is the LAN - do you have open access to your LAN?

    On my network, the machine in question is assigned a static IP and should have displayed the PC's hostname C105 ... not an asterisk !!!
  71. pharma

    pharma Network Guru Member

    I have an "*" showing up when my iPhone is connected to my home network via wireless. In order for my iPhone to use my home network, I have to enter the "Shared Key" password in my iPhone's wireless setup. Since I am using WDS, I'm using WPA-AES for the security and seems to work quite well.

  72. davidehue

    davidehue Addicted to LI Member

    I have upgraded my WRT54GL ver 1.0 using tomato 1.23, and it restarted again and again every 2 or 3 days. Any idea?
  73. The-Kevster

    The-Kevster Addicted to LI Member

    Had the same problem with mine.....until I used the ND firmware. I'm betting you have a Laptop which has an Intel wireless card. This seems to be the issue which is fixed with the newer drivers.

    My current uptime is 20 days :D
  74. davidehue

    davidehue Addicted to LI Member

    Did you mean using the ND version on WRT54GL? I've used this ND version on my Asus WL-520GU and it worked fine.
    Is the ND version can be used for WRT54GL?

  75. davidehue

    davidehue Addicted to LI Member

    Yeah you were right, my laptop wireless card is Intel. Btw, I have flashed my WRT54GL using the ND version.
    The new problem is, my QoS didn't work. Maybe I have to downgrade to ver. 1.22 again :(
  76. VeNT

    VeNT Addicted to LI Member

    so I've currently got 1.21 running on my router, is it really worth me upgrading to 1.23?
  77. nvtweak

    nvtweak LI Guru Member

    21.4 days here :wink:

    I log into the router to fiddle with it many times since then. For example to enable/disable QoS/Vegas, set up port forwardings, etc.

    All is great. No stability problems whatsoever. :thumbup:
  78. way2quik

    way2quik Addicted to LI Member

    Is there a memory leak for 1.23?
    I notice for the past two weeks that in 3 days, the memory goes down to 600K from 4MB
  79. nvtweak

    nvtweak LI Guru Member

    No memory leak that I can tell. Going on 24 days uptime and 1MB free. This version is as solid as a rock.
  80. der_Kief

    der_Kief Super Moderator Staff Member Member

    I can confirm this. Running it with xcooling's Ad blocking script at about 1MB free memory. No problems at all.

  81. fun.k

    fun.k Addicted to LI Member


    running .23 on 2xWRT54GS + 1xWRT54GL, ever since .23 came out

    kudos 2 jon
  82. kwag

    kwag LI Guru Member

    Quick way to crash a 1.23 firmware

    Go to "Access Restrictions"
    Make a rule that runs "All day/Every day"
    TCP/UDP, any port, and ENABLE IPP2P

    That's all.

    Now run some p2p apps for a while, and your router will go to never never land eventually.

    Happened on both of my routers (WRT54GL) at home, and also one at work.

    After disabling IPP2P on all routers, everything seems stable again.

    I can't seem to reproduce the problem when I select several L7 rules, so it seems there are bugs in the IPP2P filtering.
  83. Dex38

    Dex38 Addicted to LI Member


    I've just installed Tomato after years of DD-WRT and it is perfect. Bandwidth stats was the trigger for my move.

    I was having the same thing on DD-WRT, not tested on Tomato yet. This happens when I connect my laptop with a cable on the Lan.
    From memory, for my eeepc, I've the same "AzureWave Technologies, Inc." as posted earlier but when connect wireless, the OUI reports "Asustec something".
    Two different MAC for wireless and wired card so no issue so far except for the '*'.

  84. Slimey

    Slimey Network Guru Member

  85. Daggerx

    Daggerx LI Guru Member

    is there any word on the next release?
  86. pug76

    pug76 Network Guru Member

    Installed on my WRT54GL and my clients have problems connecting to it. Either they cannot connect at all or it takes very long to connect. Anyone has any solution or encountered the same problem?
  87. valerima

    valerima LI Guru Member

    Router WRT 54 GL 1.1.
    2 my kids both with DELL laptops had severe connection problems. Solved when I flashed back to Tomato19.
  88. Toastman

    Toastman Super Moderator Staff Member Member

  89. pug76

    pug76 Network Guru Member

    Thanks. Working now :)
  90. krux01

    krux01 LI Guru Member

    Is there a mailing list I can sign up for or maybe run a script from my router that will notify me when a new version is available?
  91. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    You can subscribe to email notifications (link taken from Tomato site).
  92. krux01

    krux01 LI Guru Member

    Thank you SgtPepper. I did not notice that notification list.
  93. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    That's probably because, as I just realized, that link is not visible from the actual Tomato page or FAQ - only when you look at items tagged "firmware". I've updated my previous reply to be clearer.
  94. kiskakas

    kiskakas Network Guru Member

    I found an interesting issue with all ND versions (original 1.23 tomato, victek ND, thor versions) and original tomato 1.24 beta.

    When i try to connect to the router (wrt54gl) _without_ any encryption, cannot connect, the connecting process fail or not start.

    Then i reflashed with original 1.23, and connecting without encryption works well!
  95. krux01

    krux01 LI Guru Member

    Is there a 1.24 beta? where can I download?
  96. Mercjoe

    Mercjoe Network Guru Member

    Yes there is (Jon sent me a 1.24 beta to address an issue I found), but there is no public download available that I am aware of.

    I wish there was, I would happily test builds for him and provide feedback.
  97. der_Kief

    der_Kief Super Moderator Staff Member Member

    Did you suggest this to him ? Maybe somemore people will test Jon's beta versions and he is willing to create a BETA section !?
    Let me know.

  98. vanhh

    vanhh Network Guru Member

  99. tunasashimi

    tunasashimi LI Guru Member

  100. valerima

    valerima LI Guru Member

    Which tomato build is most popular

    It appears that recent builds of tomato are undoubtedly buggy.
    I returned to version 19. Colleague from the messagve above- 11.

    Which is most popular and most stable....?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice