Official Tomato v1.24 released!

Discussion in 'Tomato Firmware' started by nvtweak, May 23, 2009.

  1. nvtweak

    nvtweak LI Guru Member

    Thanks Jon!

    Get it here.

  2. FattysGoneWild

    FattysGoneWild LI Guru Member

    Sounds good. Will be interesting reading impressions. Seems not much has changed. Which is a good thing in my book. Less bloat and more stability. I am currently using Victek's ND mod version of Tomato. Any benefit upgrading to 1.24? If you advise upgrading. I can use 1.24 ND release right?

    # nvram show | grep wl0_corerev
  3. Assman

    Assman Addicted to LI Member

    Like you said not much has changed, plus I'm on victek's mod, and it's working perfectly fine. No upgrade for me :)
  4. The Doctor

    The Doctor LI Guru Member

    No changes that matter to me (I think), but nice to see Jon still active.

    What is improved by latest Busybox? Any chance of better router throughput with latest?


    WRT54G-TM with Tomato RAF 1.23.8515.5 ND @250 here also :biggrin:
  5. mstombs

    mstombs Network Guru Member

    The implementation of miniupnpd doesn't have all the features that teddy_bear and Victek have through the GUI - such as rule cleaning and hiding the icon in windows with blank presentation URL, but maybe these are compiled in and can be enabled by script?

    But a good reason for the slick performance of stock Tomato is the streamlined set of feratures - see how little memory it is running in:-

    Total / Free Memory29.98 MB / 23.98 MB (80.00%)
    Yes, I do tick count cache memory as free, "top" reports:

    Mem: 10364K used, 20336K free, 0K shrd, 1244K buff, 4232K cached
  6. PeterT

    PeterT Network Guru Member

    Installed on the secondary router that is in WDS+AP mode. So far no problems.

    Am loath to do it on the main router as that has a 143 days of up time.
  7. FattysGoneWild

    FattysGoneWild LI Guru Member

    I might have a possible brick. I could not resist and wanted to check it out. Upgraded to the 1.24 ND release from Victek's ND mod release. Made sure every thing was done properly. The router will not sink with my modem. I have tried reboots and every thing. Watching the lights. It will start to sink and then drop every time. Flashing back to Victek's mod and hope I do not have a brick. This is with a Linksys WRT54GL v1.1 bought about a month ago new. Be care full guys.
  8. larsrya8

    larsrya8 LI Guru Member

    Did you do an NVRAM clear? Or was that included in "reboots and every thing"?
  9. FattysGoneWild

    FattysGoneWild LI Guru Member

    Before flashing. I set every thing back to defaults. Then cleared NVRAM. Flashed and then cleared it again. The good news is. No brick. I went back to Victek's ND mod release and it is all back to normal. The bad news is. Since so many setups exist. The 1.24 ND release has an issue with sinking between the modem and router.

  10. FattysGoneWild

    FattysGoneWild LI Guru Member

    My cable modem is a Linksys CM100 might be a compatibility issue as well?
  11. The Doctor

    The Doctor LI Guru Member

    FattysGoneWild, perhaps your MAC address changed because of the upgrade. Unplug power & ethernet from modem, wait about a minute. Power up the modem, wait for it to finish establishing connection. Now connect router, bet it works.

    You don't have a brick if you can access router.


    PS, make sure connection type is still correct (probably DHCP). Clearing NVRAM before you started this is assumed.
  12. Sheepeh

    Sheepeh Guest

    I just upgraded from 1.23ND to 1.24ND without clearing, and it worked perfectly as soon as I rebooted. Just came back to life, resynced, and kept on trucking.

    I have a WRT54GL 1.1 with an NTL (Ambit) 250 (255?).
  13. FattysGoneWild

    FattysGoneWild LI Guru Member

    Hmm. I did clone my mac. I have always done that since being on cable. Maybe some thing got messed up in the process. I may try that flashing again. Not sure though. Don't wanna push my luck and keep flashing firmwares.

    p.s. Instead of resetting every thing back to defaults and then clearing NVRAM before flashing. Can I just clear NVRAM and then go on with the flash?

  14. phuque99

    phuque99 LI Guru Member

    If you cloned your mac on your current build, flashing to a new firmware will revert back to the default hw mac. Changes in mac addresses would require you to reboot both the router *and* the cable modem.
  15. FattysGoneWild

    FattysGoneWild LI Guru Member

    I went ahead and tried every thing again. The modem and router would still not link together. Some thing is going on. Flashed back to Victek's firmware again and all is well. It is surely a firmware issue or compatibility issue. To sum it up.

    Linksys CM100 cable modem (I think that is the culprit)
    Linksys WRT54GL v1.1
    Tomato 1.24 ND

    That combo is not working for me. I hope some people might have the same set up and will report.
  16. Morac

    Morac Network Guru Member

    I installed it on a WRT54GL1.0 and it seems to be working fine. I can't find the following option in Basic:Network though.

  17. eegorr

    eegorr Network Guru Member

    Didn't work for me...

    Not me. I did exactly the same thing - upgraded my remote access point (WRT54GSv4) to v1.24 - and I couldn't connect wirelessly from two different laptops: one running XP and one running Vista. Are you sure you are connecting to your secondary router and not your gateway? Do they have different SSIDs?

    I reloaded v1.23 and all is fine. No changes to NVRAM, other than to disable my JFFS drive during the upgrade.

    From what I could see, there were no differences in network settings between the two versions. Does anybody have any ideas?
  18. neoufo51

    neoufo51 Network Guru Member

    I can confirm what you're showing as I did the exact same thing you did. It didn't brick the router, but it definitely made it nearly un-syncable to the modem, if there is a such a word.

    I got it to finally work however, by connecting to the router with a wired connection and flashing to the regular 1.24 release and clearing the NVRAM. I guess I'll just stick with it until Victek's 1.24 ND mod comes out.
  19. Toastman

    Toastman Super Moderator Staff Member Member

    Everything seems to be working for me, ADSL PPPOE connection. Wireless is fine.

    EDIT: Not so - one hour later everyone has disconnected from that AP and gone to another one...

    Morac, the WAN port switch is at the top of the Basic / Network page, not in a sub menu, do you see it?

    I believe the parameter pa0_maxpwr=251 has not been set, and the default country is still Japan.
  20. Victek

    Victek Network Guru Member

    Oaaaaa!!! Time to run!!! ... I'll check what's new (deep) in 1.24 and RAF release will be released.

    'Toastman - saving the world from the Bad Guys...' LOL :)
  21. FattysGoneWild

    FattysGoneWild LI Guru Member

    I went ahead and flashed with the non ND release. Guess what? It works perfectly fine. Now I know some thing is up with the 1.24 ND release.

  22. mstombs

    mstombs Network Guru Member

    I don't see the Web GUI "regulatory mode" setting, so does the ND version not have the Intel client fix?
  23. Toastman

    Toastman Super Moderator Staff Member Member

    mstombs - I erased nvram and then read out the nvram defaults - the reg mode setting was there - set to off.

    UPDATE I said earlier my wireless was OK, about 5 users had connected to that AP. However, one hour later I notice they have ALL disconnected from that AP (or been dropped) and moved to another one... (ND version).
  24. jnappert

    jnappert LI Guru Member

    Same here. ASUS WL500gp can not establish WDS-Links to my 7 WRT54GLs when using 1.24 ND. Had to revert to 1.23 ND.
  25. mstombs

    mstombs Network Guru Member

    Are these the correct wireless drivers for ND version?

    eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    eth1: Broadcom BCM4320 802.11 Wireless Controller
    I'm sure teddy_bear and Victek using much newer ones!
  26. TVTV

    TVTV LI Guru Member

    1.24 (NON-ND) works fine for me. I'll keep you posted on the uptime.

    BTW, you can only use the WAN port as LAN if you disable the WAN/Internet completely. :)
  27. kiskakas

    kiskakas Network Guru Member

    i found a 'bug', (1.24 standard), you cannot connect to the AP (wrt54gl) without security. The clients (msi notebook with a realtek wlan, and a hp notebook with an intel) cannot get ip address from the AP. :(
  28. mw1001

    mw1001 Network Guru Member

    I've tried upgrade 3 times to 1.24 ND. Every time my WRTSL54GS become a brick!
    1st time my router was running RAF ND mod. Second time was from 1.23 ND with default setings. 3rd time I try from DD-WRT selecting "restore to default setings after upgrade".

  29. Morac

    Morac Network Guru Member

    I see a "WAN / Internet" section, but that's not new. It contains is "Type" and "MTU", the same as it did in 1.23. Does the "WAN port switch option only show up for certain WAN types? Mine is set to DHCP.
  30. TVTV

    TVTV LI Guru Member

    You can only use the WAN port as LAN if you disable the WAN/Internet completely. And that means setting the "Type" to "Disabled".
  31. pharma

    pharma Network Guru Member

    Flashed both routers (WRT54G 1.1 and WRT54G V4) with the "ND" version and upgrade went smoothly. Running both in WDS mode.

    Thanks Jon for superb firmware! :biggrin:

  32. devilkin

    devilkin LI Guru Member

    Any idea if any of the N-models of Linksys are going to be supported?

    Kind regards, and thanks for the update?
  33. neoufo51

    neoufo51 Network Guru Member

    I can confirm this bug. I had to connect with a wire just to enable security.
  34. Jadefalcon

    Jadefalcon LI Guru Member

    Problems with the 1.24 stardard version

    I upgraded my GL v1.1 1.23 non-nd with the 1.24 non-nd version and it worked fine wired but nothing would connect wirelessly. Some machines would not even see it. I did the nvram clear and reset to factory default before hand. Even tried flashing again. No luck. pokeing around it did the corerev check and mine is 9. been haveing no problems useing the non-nd versions so far. Could that maybe be a cause?? Thank you.

    Edit : I have WEP security enabled.
  35. der_Kief

    der_Kief Super Moderator Staff Member Member

    Upgraded to the new "non ND" version 1.24 without any problems on my WRT54GL ( as ever :thumbup: ). Thanks Jon for new release.

  36. Talon88

    Talon88 LI Guru Member


    Just Updated. No Problem found yet!


  37. BryanC1968

    BryanC1968 Addicted to LI Member

    I just upgraded to v1.24 and now my download & upload speeds are very slow...

    I had the same issue with v1.23 and I had to go back to v1.22 to get my speeds back up...

    Anyone know what changes in the last two tomato firmware versions could be causing this issue..?

    I did a factory reset to default settings erasing all data in NVRAM both before and after the upgrade with both v1.23 & v1.24 and both times my internet speeds were in the tank after the upgrades... I also re-entered all my settings by hand.. I didn't restore them from a backup...

    I forgot to mention that I have a Linksys WRT54GS v2 router..
  38. BryanC1968

    BryanC1968 Addicted to LI Member

    I just finished running some tests..

    I re-flashed back to tomato v1.22 restoring default settings and erasing nvram before and after the install... I ran several speed tests from different test servers on 2 different sites using just the default settings... and my speeds were excellent every time...

    I then upgraded to the new v1.24 firmware again.. restoring default settings and erasing nvram before and after the install.. Ran several speed tests again as before from the same sites using just the default settings.. and my speeds were horrible... 1/2 or less what they are suppose to be...

    As I mentioned before.. I had the same issue with v1.23 when it was released...

    I don't know what to make of it... I guess it's not meant for me to stay up to date with the latest firmware...

    If anyone has any ideas about what is causing this issue in the latest firmware versions please let me know.. But for now I guess I'm stuck with v1.22...
  39. sardaukar

    sardaukar Addicted to LI Member

    I experienced a problem upgrading from 1.23 non-ND to 1.24 (also non-ND).

    I just went to "Upgrade" on the menu and was told I could not, since JFFS2 was enabled. I disabled it and went to "Upgrade" once more and uploaded the 1.24 file for my model (WRT54GL) - all this with a wired connection, no wireless upgrades for me thank you :D

    Everything went smoothly, the router rebooted and everything (apparently) was ok, except for two things:

    - realtime bandwidth view was not recording anything! I had to reboot the router once more for it to work (but it does now).
    - wireless was not working! I mean, the SSID was still being broadcast, but "Signal Strength" in both Vista and Linux clients was 0%, so no association was possible. I changed the channel from 6 to 9 and it now works again. I'm sure that if I change back to 6, it will also continue to work.

    So, apart from these 2 "issues", everything went OK.
  40. ghostknife

    ghostknife Addicted to LI Member

    Any ideas what these might be?
    Just interested for my WL520gu.
  41. nvtweak

    nvtweak LI Guru Member

    he used Teddy Bear's fixes for the slow running clock and WLAN/AIR Led
  42. ghostknife

    ghostknife Addicted to LI Member

    OK, which i'm already running so no advantage then, thanks.
  43. TVTV

    TVTV LI Guru Member

    Uptime 20+ HRS for me, no slowdowns or issues. Throughput is steady as a rock on a 50 mbps line.
  44. kripz

    kripz LI Guru Member

    Thank god i didnt update...
  45. pharma

    pharma Network Guru Member

    Updated 1 router wired, 1 router wirelessly to 1.24 and rock solid for 19+ hours. No problems, slowdowns or wireless issues - download speeds are as fast as ever. Just downloaded 100 MB video driver at 1.79MB/sec. :thumbup:


    Attached Files:

  46. asterger

    asterger Network Guru Member

    Updated my Linksys WRTSL54GS, without clearing nvram or reset. Upgrade indicated successfull.

    While Authentication Type was still set to Shared Key, Security (WEP), Encrytion (64-bits) with correct Key 1, none of the wireless clients were conneting. Re-entered and re-saved Key 1. All wireless clients then became actve.

    Thanks for the upgrade Jon.

    -- asterger
  47. tacotime

    tacotime LI Guru Member

    All my wireless devices were not working until I did this.


  48. dvaskelis

    dvaskelis Network Guru Member

    NAP-PMP seems to work, but I get these in my log:
    The mappings are, however, removed from the forwarded ports screen.
  49. teddy_bear

    teddy_bear Network Guru Member

    I noticed Jon removed all TCP Vegas related code from the kernel, but kept all settings in the GUI. I know there were almost religios discussions on this and other forums about usefulness of TCP Vegas, and whether it does anything at all - but if Jon decided to get rid of it, it seems strange that he left all the GUI settings. Makes me wonder if removing kernel code was intentional or accidental...

    Another strange thing about this update is that Jon used newest but unstable Busybox 1.14.0. If he wanted to use the latest Busybox, why not wait a little longer until at least 1.14.1 when most bugs should be addressed, and they move it to a "stable" branch? I suspect that this Busybox update might be causing these connectivity issues reported by some people...

    Don't worry about these messages. Miniupnpd tries to delete the mapping even if it's no longer there, and writes these messages to the log in this case.
  50. eegorr

    eegorr Network Guru Member

    Incorrect Wireless MAC Address

    This didn't work for me, but I did find something that might be causing the problem. Running v1.24, this is what the Status/Overview page says:

    Router MAC Address 00:16:xx:xx:xx:2B
    Router IP Address
    Subnet Mask
    DHCP Disabled

    MAC Address 00:90:4C:5F:00:2A
    Wireless Mode Access Point + WDS
    B/G Mode Mixed B+G
    Radio Enabled
    SSID xxxxx-ap2
    Security WEP
    Channel 3 - 2.422 GHz

    Note the wireless MAC address - it is INCORRECT! It should be 00:16:xx:xx:xx:2D, two higher than the wired MAC address (I've never changed this). When I go to Basic/Network setup page, it shows the same, incorrect MAC address in the Wireless section, but if I click on it, it takes me to Advanced/MAC Address setup page. Now, here is the strangest part: on this page it is CORRECT!

    If I save the changes on that page (even though I haven't actually changed anything), I first get a popup asking if I really want to do this. When I click on OK, the "change" is apparently saved, because it shows the correct MAC address on both the Status/Overview and Basic/Wireless pages, but I STILL CANNOT CONNECT WIRELESSLY from either of two laptops!!!

    So, I figure I need to reboot, but when the router comes back up it is showing the wrong MAC address again for the wireless interface. I have gone through this entire sequence a couple of times now to no avail. I suspected that the only reason the router is connecting to my gateway is because I have both of them set up to connect automatically (no MAC address specified), but when I look at the device list for my gateway it shows the CORRECT MAC address (ending in 2D) for the remote router!

    It seems to me that this MAC address error might be the root of my problem, but I don't know what to do about it. Can anyone confirm this behavior on either a working or non working set of WDS connected WRT54GSv4 routers running Tomato v1.24?
  51. TVTV

    TVTV LI Guru Member

    So there is no more TCP Vegas support?
  52. rkloost

    rkloost Addicted to LI Member

    Works fine with the standard (Not ND) build. Factory defaults before and after flashing.
  53. FattysGoneWild

    FattysGoneWild LI Guru Member

    Same here. It is the ND version that is not working for me and some other people. I just don't understand why it is working for some and not others.

  54. rkloost

    rkloost Addicted to LI Member

    maybe related to the first 4 positions of the serial

    CL7A = WRT54GL v1.0
    CL7B = WRT54GL v1.1
    CL7C = WRT54GL v1.1
    CF7C = WRT54GL v1.1

    My GL's are CL7B:
    # nvram show | grep wl0_corerev

    So I seem not to be able to run the ND version.

    From victec's site:
    What versión should I use?
    *- 1.23.8025 For Router with wireless (wl0_corerev) < 9
    *- 1.23.8515 ND For Router with wireless (wl0_corerev) => 9
    *- 1.23.8623 ND + USB from TB version + RAF features (IP/MAC Limiter). For ASUSTEK Router and USB available socket.

    How to find the wireless hardware revision?
    Enter in terminal mode and Telnet the router
    root@WRT54GL:# nvram show | grep wl0_corerev
    wl0_corerev=9 When digit is =>9 then use ND version. If <9 use normal version
  55. FattysGoneWild

    FattysGoneWild LI Guru Member

    Mine is the following:

    CL7C = WRT54GL v1.1

    # nvram show | grep wl0_corerev

    Which confirms I can run the 1.24 ND version if it worked right.

  56. Elbart

    Elbart LI Guru Member

    My WRT54GL is a CL7B (thus 1.1) too, but wl0_corerev is 9 and the WLAN's working fine (WPA2 Personal, AES).
  57. asterger

    asterger Network Guru Member

    Message From Jon:

    Warning: A problem in 1.24 may cause some users to have various WL problems and a possibility of getting locked out. I'll put up a new version later today.
  58. FattysGoneWild

    FattysGoneWild LI Guru Member

    Maybe this will fix the link issue between the modem and router in the ND release as well? Is there a way to contact the maker of Tomato? If not. Hope fully he stops by here and reads through the Tomato forum.

  59. eegorr

    eegorr Network Guru Member

    UPDATE: After trying this for the third time, it is working now - has been for about 12 hours. The status page is now showing the correct MAC address for the wireless interface, and I am able to connect to the router from both laptops.

    I found that errant MAC address in the NVRAM data, but I still don't recognize it:


    I checked my gateway router and it has the same setting in NVRAM - it is the only place that MAC address appears in the NVRAM of either router. I cleared NVRAM and re-setup everything when I went from Thibor to Tomato firmware, so if this is not related in some way to my network hardware, it must have migrated there from something in the developer's setup.

    Does anyone know the significance of this NVRAM setting? Is there a list of definitions somewhere, like possibly in the source code?

    BTW, I see now that Jon has warned us about using v1.24 and that he will put up a new version to fix a possible WL problem:
    I wonder if it has anything to do with this?
  60. eegorr

    eegorr Network Guru Member

    Tomato v1.25

    Here it is:

    Tomato 1.25
    Submitted by jon on Mon, 2009-05-25 21:17
    Version 1.25
    •Fixed WL MAC address may not be set properly. This seems to have caused various connectivity problems, including a possibility of getting locked out.

    I'm going to give it a try this morning... but I think I might go back to v1.23 first, just to be safe.
  61. nvtweak

    nvtweak LI Guru Member

    I think it's stable but they just haven't updated the site.

    They are working on 1.15 now.
  62. eegorr

    eegorr Network Guru Member

    Tomato v1.25 is working for me!

    I did go back to v1.23 and reload my latest NVRAM backup first, but I don't know if it was necessary.

    BTW, I could not find "il0macaddr" anywhere in the source, but I did find some references to it via a Google search. It is apparently the MAC address looking in from the WAN port - from the "outside world." In my case, it is what my DSL modem sees looking back at my gateway router. I guess it is the same for everyone, unless the NVRAM value is set differently.

    Jon must have accidentally referenced that MAC address instead of the WL MAC address in some part of his code. I didn't get the source for v1.24 so I can't do a comparison, but maybe someone else can... if we care!
  63. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    The fix in 1.25 can be seen here.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice