Official Tomato v1.27 Released

Discussion in 'Tomato Firmware' started by The Doctor, Nov 27, 2009.

  1. The Doctor

    The Doctor LI Guru Member


    * Fix DDNS "-1" error when service used HTTPS.


    * Allow a different port to be entered in Basic:Network:Static DNS (enter as "ip:port"). Be aware that dnsmasq must act as the DNS server (the default setting) when not using the normal port 53.
    * Allow DHCP to serve the user-entered gateway (in Basic:Network) if the option in Advanced:DHCP is enabled.
    * Do not start miniupnpd early to avoid warning messages.
    * Update Australian DST (need to re-select), add Darwin, Brisbane TZ. Thanks to Peter O. for the info.
    * Avoid double loading of tomato.css
    * Fix possible null dereference in sendpage
    * Collapsed all menus. For the old look, set nvram: "web_mx=status,bwm,tools"
    * Obscured some key/password fields when not in focus.
    * Accept more than two MAC addresses per IP address (ex: one IP for a laptop either wired or wireless [one at a time]). Note: Some computers may not like seeing the same IP unless it's restarted.
    * Added LED options back in Admin:Buttons/LED.
    * Added ID for WLA2-G54L, TrueMobile 2300 thanks to Nick B. and David J.
    * Added EditDNS thanks to Keith M.
    * Added UTC+4:30 Kabul time zone.
    * Fixed port set validation allowed more than what could be handled.
    * Allow rstats to log if WAN port is used for LAN.
    * Update dnsmasq to 2.51, miniupnpd 1.4, busybox 1.14.4, matrixssl 1.8.8.
  2. benny.shen

    benny.shen LI Guru Member

    cool. thanks a lot for the author
  3. occamsrazor

    occamsrazor Network Guru Member

    Thanks, I look forward to this being incorporated into the various mods...

  4. though

    though Network Guru Member

    thanks for the new release, much appreciated!
  5. M_ars

    M_ars Network Guru Member

    thx for the update :)
  6. der_Kief

    der_Kief Super Moderator Staff Member Member

    Just updated to new version. No problems at all.
    Thanks Jon. :thumbup:

  7. brookie

    brookie LI Guru Member

    Just updated WRT54GS v2 & WRT54G v2.2 setup as WDS WPA/WPA2 AES. Everything is working great! Thanks Jon!

    Going to try and set up "Accept more than two MAC addresses per IP address (ex: one IP for a laptop either wired or wireless [one at a time]). Note: Some computers may not like seeing the same IP unless it's restarted." for wired/wifi laptops so that they can be plugged in or used wifi with static ip addresses.

    I think they need different names in the Static DHCP Hostname because logs kicked out:

    dnsmasq[4795]: not giving name "hostname of wireless card, pc1" to the DHCP lease of because the name exists in /etc/hosts.dnsmasq with address
    Nov 27 17:30:14 ? daemon.warn dnsmasq[4795]: not giving name "hostname of wireless card, pc2" to the DHCP lease of because the name exists in /etc/hosts.dnsmasq with address

    Is that right?
  8. though

    though Network Guru Member

    1.27 = RT-N16 support????? i could only dream....
  9. TVTV

    TVTV LI Guru Member

    Installed as soon as i got the e-mail from Polarcloud. Running rock steady. :)
  10. rickh57

    rickh57 Network Guru Member

    I have 1.26 running on both of my routers. No issues so far.
  11. azjerry

    azjerry Addicted to LI Member

    Took almost 15 minutes for the upgrade to complete. Other than that it running weel since then.
  12. larsrya8

    larsrya8 LI Guru Member

    I'm having some difficulty getting this to work. I have a static entry for my laptop with the MACs for the wired and wireless cards and a static IP. I've restarted the laptop and the router a few times now. When it comes up, one of the network interfaces is able to get online and the other is not and keeps retrying over and over. My router's log is full of DHCPDISCOVER, DHCPOFFER, DHCPREQUEST, DHCPACK messages coming in every second.

    When I upgraded to 1.26 I did a full NVRAM erase. Running Windows 7 Ultimate.

    Any ideas?

    Edit: forgot to add that if, for instance, the wired is working but the wireless is not, disconnecting the wired does not cause the wireless to start working. Instead I'm completely offline.
  13. TexasFlood

    TexasFlood Network Guru Member

    I'm not sure I understood what you're trying to do, so if I got it wrong, ignore my comments.

    But if you're trying to use the same IP for a wired and wireless interface at the same time, you can't. It's for convenience to assign the same IP to two different MACs, like one wired and wireless, so the computer gets the same IP with either one. But you can't have both active at the same time. If you need both interfaces active at the same time, assign different IPs to them.
  14. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    While that may be true for Windows, my Ubuntu laptop is more than happy to have the same IP address on wired and wireless.
  15. TexasFlood

    TexasFlood Network Guru Member

    Was referring to my earlier observations of Tomato 1.26 in this situation and trying to say that you shouldn't have the same IP for more than one MAC address active at the same time. This isn't a Windows thing, it's a network thing. The relationship of IP/MAC should be unique for arp to resolve and routing to function. If only one of the interfaces, wired or wireless, is up at once, then they can both have the same IP. I'm typing on an Ubuntu laptop right now. It would probably allow me to set both the wired and wireless interfaces to the same IP but if both were active at the same time then the network might not function correctly causing delays, dropped packets, asymmetric routing etc. Whether or not the OS allows you to do it, it's not a good idea.
  16. cpgbg

    cpgbg LI Guru Member

    Looking at this thread I think that there are some issues with Tomato 1.26.

    Can anyone test if HTTPS Web Admin is broken too or only DynDNS updates through HTTPS?
  17. M_ars

    M_ars Network Guru Member

    I think DynDNS updates through HTTPS is broken? anyone else? without HTTPS its working
  18. PeterT

    PeterT Network Guru Member

    Version 1.27 is out that has one fix

    Fix DDNS "-1" error when service used HTTPS.
  19. TexasFlood

    TexasFlood Network Guru Member

    Yes, it is for static DHCP. The way I foresee using it is as in the example given in in the release notes:

    ex: one IP for a laptop either wired or wireless [one at a time]). Note: Some computers may not like seeing the same IP unless it's restarted.

    I would use only the wired or wireless interface, not both at the same time, and would get the same IP address using either one so any IP address based port forwarding rules or access restrictions, for example, would only need to consider that one IP address.
  20. der_Kief

    der_Kief Super Moderator Staff Member Member

    Fixed first post.
    Just upgraded right now. No problems at all. Thanks Jon for fast reaction.

  21. Morac

    Morac Network Guru Member

    Upgraded from 1.25 to 1.27. So far so good.
  22. FlashSWT

    FlashSWT Network Guru Member

    I just upgraded and had really been looking forward to this feature:
    * Accept more than two MAC addresses per IP address (ex: one IP for a laptop either wired or wireless [one at a time]).

    It is working great and is a very welcome addition.
  23. landa

    landa LI Guru Member

    Upgraded to 1.27. Uptime 0 days, 03:58:39. No problems found, so far.
  24. siimo

    siimo LI Guru Member

  25. kovacsr89

    kovacsr89 Addicted to LI Member

  26. TVTV

    TVTV LI Guru Member

    Also be sure you are using the modem in bridge mode. ;)
  27. siimo

    siimo LI Guru Member

    What do you mean? its a standard WRT54GL 1.1, why should i need a custom build? Yes modem is in bridge mode.
  28. szfong

    szfong Network Guru Member

    Bandwidth Totals Broken When "Use WAN port for LAN"

    Bandwidth Totals are "Blank" When "Use WAN port for LAN" w/ DHCP disabled, everything else being default except router IP. I've seen it this happen and quickly fixed by Jon pre-1.26 beta releases. Somehow the missing Daily, Weekly, & Monthly Totals is once again preset.

    Can anyone confirm this before I e-mail Jon??

  29. Azuse

    Azuse LI Guru Member

    Then I'd wait for the 1.27 version of the raf mod. You could use the 1.25 but I found I had flash and erase 3 times before I stopped having issues, stubborn memory. Try installing and erasing nvrm (thorough) more than once, uses IE and don't import old setting - start again.
  30. siimo

    siimo LI Guru Member

    Not sure if its relevant but the modem is actually in half bridge mode. As i have PPPoA I can't use full bridge. and WRT is set up to use DHCP for WAN.
  31. naptime

    naptime LI Guru Member

    I have been using 1.25 for months with my WRT54GL, and have not had any downloads abort. My connection is pretty slow, though, averaging 500kbs down.
  32. ocseagleforlife#82

    ocseagleforlife#82 LI Guru Member

    will it up the range vs 1.26 tomato or should i get hyperwrt or dd-wrt
  33. TexasFlood

    TexasFlood Network Guru Member

    I've gotten similar range out of all versions of Tomato, Hyperwrt and DD-WRT.

    The 1.27 release is, like most, about new and/or enhanced features and component upgrades, or downgrades as the case may be, to improve stability and/or security. If you go back and read the first post in this thread, you'll find the changelog notes for 1.26 and 1.27. Only change from 1.26 to 1.27 was to fix a dynamic DNS error when service used HTTPS.

    I really don't think going to another firmware is going to increase your range in and of itself. Changing the settings, like transmit power and/or channel, your antenna or antenna position, or router location, could all impact range.

    I periodically cjeck the signal level of remote routers & clients and move my router and antenna around for the best signal. Moving mine a few inches this way or that can have a significant impact on the furthest reaches of my home. It's probably due to stuff in the walls which I can't see blocking the signal path.

    Good luck.
  34. siimo

    siimo LI Guru Member

    So you need to clear NVRam 3 times atleast?
  35. TexasFlood

    TexasFlood Network Guru Member

    I never have, but maybe I've just been lucky. Maybe worth a try if you're having problems.
  36. siimo

    siimo LI Guru Member

    Ahh I figured out what my problem is now exactly! :) But still no solution. :-(

    Basically this is happening:
    1. I use half bridge modem and set WAN to DHCP
    2. My modem gives 60 second DHCP lease to tomato
    3. When lease expires it resets connection!! (This didn't use to happen in 1.23 or older)

    So anywhere between 0 to 30 seconds when the lease is renewed, connections are interrupted. This is pretty serious!! I guess most of you aren't affected cause you don't use DHCP with a half-bridge modem. This lease can't be extended and shouldn't be either because when I get disconnected at ISP and get new IP tomato will not get it, right now it gets a lease every 30 seconds so if i am cut off I am back up within 30 seconds.

    Any ideas how to resolve this? Basically I had this since 1.24/1.25 so downgraded to 1.23 but didn't realise why it was the case at the time but i did a little more investigation today and found the problem.

    Edit: Found another thread about this issue

    Edit2: Solved the problem!!
    Had to add this firewall rule as said in above thread: iptables -I INPUT -p udp --sport 67 --dport 68 --source -j ACCEPT

    But still, used to work without this rule till v1.23
  37. siimo

    siimo LI Guru Member

    Teddy_bear: please see my post updated above. Contains the firewall script that solved the problem. But thanks a lot!
  38. M_ars

    M_ars Network Guru Member

    What happend to v1.27? Its not on the downloadpage anymore... :confused:

    Seems like my FireFox is playing tricks with me... weird! With IE8 everything is alright
  39. mstombs

    mstombs Network Guru Member

    Remembering that old thread - this command didn't fix everyones problems. I have not seen the problem with my 'hacked' modems or a stock SpeedTouch with any version of firmware - but do need a firewall script to fix the routing.

    Is your modem a 2-wire ?
  40. Morac

    Morac Network Guru Member

    I don't know if this is 1.27 related or not, but today I noticed I was getting ping timeouts to the router and at some point Windows told me that there was a connection problem (I had no ip address but had a signal).

    I'm not seeing that now, but I did notice a lower signal strength than normal. I was seeing a "Good" signal at 36.0 Mbps as opposed to the normal "Excellent" at 54.0 Mbps. It's back to Excellent/54 again. I'm not sure why the signal strength is fluctuating today.
  41. szfong

    szfong Network Guru Member

    Since no one in the forums helped, I asked Jon, he was GREAT!!, pointed me out how to fix it immediately. For those having similar issues with 1.27, apparently Tomato must now be able to get to a NTP server for the totals to work.... Many thanks to Jon!
  42. mejobloggs

    mejobloggs Addicted to LI Member

    NTP server? Can you write a quick noob guide on how to do it?
  43. ntest7

    ntest7 Network Guru Member

    NTP Server == a time server. The tomato Basic->Time tab must list a time server the router can access, and the Status->Overview page must show the time. If the router can access the internet, "default" will usually suffice.

    If the router doesn't have access to the internet, you need a time server on your local network. Any Linux/Unix server should work, see your system docs for how to enable ntpd. I think Win XP/Vista/7 includes a time server that can be turned on in the registry; google for details. If you can't get Win built-in time service to work, there's a free port of ntp for Windows (google for it), or a program called Tardis 2000 (not free, $20).

    After you get your local network time server running, enter that computer's IP as a custom entry on the tomato Basic->Time page.
  44. mcala

    mcala Addicted to LI Member

    I have a small issue that didn't happen when using "1.25 ND Victek mod". My ISP is Comcast and they offer the service called "PowerBoost" which gives a boost of speed while downloading. I no longer have that feature anymore since upgrading to 1.27. I have their 8000/2000 plan and while hooked up to the router which is a wrt54g ver 3 and doing a few speedtest sites i am just getting 8000/898. I bypassed the router for a direct connection and i received 23000/3000 @ multiple test sites. Back on the router now and still capped @ 8000/800. When i installed the new stock 1.27 i did a NVRAM reset. Has anyone found this also while using Comcast? I am still waiting for the Victek mod to update.
  45. johnny2002

    johnny2002 LI Guru Member

    I am waiting for Victek's mod
  46. karogyoker

    karogyoker Addicted to LI Member

    Oh hai!

    I would like the following to work:
    If i push the Cisco button, then
    if the "Enable QoS Limit" is disabled, then
    enable it, and light up the button with white light,
    disable it, and turn off the light.

    Thanks for the tips.

    edit: Oh sorry, only Victek's mod has Enable QoS Limit. A generic solution is OK too.

    edit2: Here is the solution:
    if [ `nvram get new_qoslimit_enable` -eq 0 ];then
     nvram set new_qoslimit_enable=1
     sh /tmp/
     led amber off white on
     nvram set new_qoslimit_enable=0
     sh /tmp/
     led amber off white off
  47. Rafatk

    Rafatk Network Guru Member

    So far so good! No problems at all!!!!
    Uptime 1 day 18 hours yet...

    Let`s see what victek comes up with the RAF...
  48. hclarkjr

    hclarkjr Addicted to LI Member

    hi, i just installed this on my WRT54G version 2 and am unable to access the GUI. it will not accept admin or root for username and admin for password. i have tried resetting the router too. the internet connection works fine but i want to be able to access my router. i have tried accessing it via IE8 and firefox 3.5.5 any help would be appreciated. i upgraded from a linksys firmware, i forgot to add that. thanx
  49. spicoli

    spicoli LI Guru Member

    Getting a flood of

    unknown daemon.notice miniupnpd[574]: /ctl/IPConn not found, responding ERROR 404
    Any ideas?
  50. landa

    landa LI Guru Member

    I found one problem in this version. Limit Connection Attempts function does not work.
    SSH activated
    Remote Access activated
    Remote port 2222
    Port 22
    Allow Password Login activated
    Limit Connection Attempts SSH activated / Telnet dezactivated
    3 every 60 seconds

    I have tried with Allowed Remote IP Address configured and without; the same result.

    2 pictures atached with complete setup.

    From the logs:

    Dec  5 13:12:53 router dropbear[1965]: Child connection from
    Dec  5 13:12:56 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:12:58 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:12:59 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:00 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:01 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:01 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:02 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:03 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:03 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:04 router authpriv.warn dropbear[1965]: bad password attempt for 'root' from
    Dec  5 13:13:04 router dropbear[1965]: exit before auth (user 'root', 10 fails): Max auth tries reached - user 'root' from
    Can anyone try this function?

    Attached Files:

  51. hclarkjr

    hclarkjr Addicted to LI Member

  52. szfong

    szfong Network Guru Member

    I remember getting those in previous version.. 1.27 should have fixed it. Try resetting to default before and after flashing. Just an idea..
  53. szfong

    szfong Network Guru Member

    try holding reset, then add power, then continue holding reset, then release. If all else fails you may have a corrupt flash. It happens sometimes. To avoid it in future, I always reset to default prior to flashing. It's always fixable using tftp, or a serial connection if you couln't get the timing just right. jtag is your last resort. I also have a wrt54g v2, it's a xh rev. w/ modified CFE that I really like using. Not sure if you have such a xh/xb v2 wrt54g router, but I modified the CFE for easy recovery, and support for 32MB of ram.

    good luck
  54. TexasFlood

    TexasFlood Network Guru Member

    I've got one WRT54G v2 but never checked the revision, hmm, now you got me curious. Do you have to pop it open to check?, don't remember any more, I'd planned to check it years ago but obviously that plan feel by the wayside. Either way it's been a hell of a router, think I've had it running contstantly for almost 8 years, only recently retired from being my main router as a test, but could make a return to service I guess.
  55. szfong

    szfong Network Guru Member

    Yes you must open it up to see, I also checked the RAM chips to make ABSOLUTE certain. You will brick your router if you issued those commands with a router that does not have 32MB. I also modified the CFE for easy recovery using tftp or from a bad overclock. I 1st backed up my CFE, then issued those commands to support 32MB and afterwards I modified the backed up CFE w/ a hex editor w/ those commands built-in and finally used a CFE writer to rewrite the CFE w/ my own under openwrt as dd-wrt didn't work w/ the CFE writer. A jtag cable might have been easier if you have one handy. Went through all these steps in order to have my own defaults + 32MB which will survive a router reset w/o having to re-issue those "dangerous" commands each time the router was reset. I also bought my 1st serial ttl cable at about the same time which allowed accessed the router's serial console w/o even opening it. But that's another mod story. In the end, not sure if it's worth all the trouble but I learned alot from it :)
  56. TexasFlood

    TexasFlood Network Guru Member

    Did a little googling after I responded earlier.
    Not familiar with the CFE writer you used, might have to check it out. Never got around to building a jtag cable but should since I have a WR850G v3 that I managed to kill testing my attempt and nvram backup & restore script (that's when I gave up on that idea).

    Anyway, found a picture of an XB board and the revision number is pretty clearly labeled, and could see the two MIRA P2V28S40BTP chips in the picture. I suppose this isn't the only possible correct chip though. Guess the key is to lookup whatever chip number I find to make really really sure so I don't I bork it up. Seems that at least with the rev XH that not all have 32MB, not sure about the rev XB but guess it's safe to assume nothing. Also read that WR850G v2 and WRT54G v2.2 might have 32MB, the examples I saw said chips in these cases were 2 either ISSI I!S42S16800xx-7t or ISSI IS42516800A-7t (maybe the same thing). One guy who bought a lot of used WRT54G v2.2 units found about 30% with 32MB so certainly worth checking.
  57. landa

    landa LI Guru Member

  58. ntest7

    ntest7 Network Guru Member

    Works here. Note the feature limits connections, not login attempts; there can be multiple login attempts per connection.
  59. Morac

    Morac Network Guru Member

    Well I had the router restart after about 9 days. It did so when I disabled my wireless network card on my laptop and then hooked my laptops ethernet port into a wireless bridge on my network.
  60. TexasFlood

    TexasFlood Network Guru Member

    Weird, it's got gremlins in it. Any chance static electricity was involved? Gremlins thrive on it you know, so any static involved would have gotten them all stirred up. :biggrin:
  61. karogyoker

    karogyoker Addicted to LI Member

    Can I see somehow the connections' bandwith?
    I can see the connections in terminal:
    cat ./proc/net/ip_conntrack

    but used bandwidth is not showed.
  62. brookie

    brookie LI Guru Member

    Did anyone else notice that DNS entries in Tomato 1.27 are used in the reverse order that they are entered under Basic > Network > Static DNS.

    You can see it in the logs when you add three DNS servers, and you can test it with this cool google tool ( ).

    The logs show that dnsmasq uses the DNS entries in the 3,2,1 order that they were entered in the GUI.

    I reversed the entries and the logs show that they are using them 3,2,1 order again but in the order I want.

  63. regadpellagru

    regadpellagru Addicted to LI Member

    Hi everyone,

    Just wanted to give a feedback:
    • I was running 1.21 since ... can't remember. Was so freaking stable ....
    • I prepared the update carefully (backup, ready to start from scratch) due to the large difference in versions
    • I updated via web interface
    • Et voila, all running OK. Didn't loose a thing !

    What a superb firmware. Hats off to the author !
  64. StevenG

    StevenG LI Guru Member

    Still running 1.19

    I have been wary of upgrading off 1.19. It's been rock solid for me, and as I've watched updates comes and go, it seems they've all had their share of issues. 1.27 seems promising. It's really great firmware though on my Buffalo router.

    One question though - is it a pipe dream to think I might one day see a whitelist feature in the access restrictions section, vs having to use IPtables (which I've never been able to to get to work).

  65. WRobertE

    WRobertE Addicted to LI Member

    Send a request to Jonathan Zarate, the author of Tomato. His email address is on the bottom of this page:
  66. AvPyro

    AvPyro Addicted to LI Member

    If I activate reconnect by scheduler I retrieve 2 pppX connections. Additional pppX removed only by reboot.

    Haw can I create reconnect by scheduler without this error?

    tomato 1.27- l2tp internet - dhcp local
  67. letyos

    letyos Addicted to LI Member

    I am having trouble compiling 1.27 from source. It fails to read a .config file that seems to exist in the correct place:

    make[4]: Entering directory `/home/me/Code/TomatoSource_1_27/tomato/release/src/linux/linux'
    rm -f include/asm
    ( cd include ; ln -sf asm-mips asm)
    /bin/sh scripts/Configure -d arch/mips/
    # Using defaults found in .config
    scripts/Configure: line 556: .: .config: file not found
    scripts/Configure: line 558: .: .config-is-not.7868: file not found
    * Code maturity level options
    Prompt for development and/or incomplete code/drivers (CONFIG_EXPERIMENTAL) [N/y/?] (NEW) 
    At the end it asks for the settings contained in .config manually. The file .config exists in tomato/release/src/linux/linux so I dont see the problem. Anyone have any ideas?
  68. AvPyro

    AvPyro Addicted to LI Member

    Today received additional ppp1 connection after click 'Disconnect' on Overview page.
    reboot removed it only.

    tomato 1.27- l2tp internet - dhcp local
  69. mstombs

    mstombs Network Guru Member

    Its typically a sh bash/dash problem, you can try changing your default sh shell, or edit the appropriate calling program to explicitly select /bin/bash for example.

    There's also problems elsewhere with non-standard "echo" commands, search the forums for the fix which is also in the mod git repository.
  70. letyos

    letyos Addicted to LI Member

    I tried changing the shell to bash but the same problem still happens. About the echo fix, are you referring to ? Because I don't see how I could fix the problem with that.

    I tried compiling the straight linksys source code and it compiles fine, if that means anything. I am using Ubuntu 9.10.

    Edit: I switched to Ubuntu 8.10 and it compiles fine now. It resolved the issue somehow.
  71. valerima

    valerima LI Guru Member


    Recently I got 100mb/s fibre cabel connection and decided to change my wrt54GL with Tomato firmware. It is a bit old, but still working perfect device. However now I own Linksys WRT160NL router with usb port. It is with Linksys fiormware still although I miss tomato firmware very much as Linksys firmware is rather poor in options and functionality.
    Anybody heard if Tomato firmware is planned to write also for this device?

    By the way it is interesting that via googling I found alternative firmware on one Russian site- torrent client included to router firmware, therefore they can make downloads directly to HDD if it is external and connected to router.
    Link is here.
  72. kallsop

    kallsop LI Guru Member

    1.27 is running but randomly rebooting my WRT54GS version 4. It goes a few days, and when I check the Uptime status, it will be less than that. About 5 days is the best I've seen.

    I suppose the Uptime reporting could be off, but I think the router is doing a reboot. The last version loaded (1.23 I think) ran without rebooting.
  73. agentsky1919

    agentsky1919 LI Guru Member


    Are you using ND version for your GS?
  74. kallsop

    kallsop LI Guru Member

    No, it's version WRT54GSv4.bin in the Tomato_1_27.7z file. The ND version is only for WHR-G125, WL520GU, yes? Is there a way to inspect which version is loaded?
  75. rviteri

    rviteri Addicted to LI Member


    Will Ebtables be included in future versions?
  76. TurtleFang

    TurtleFang Addicted to LI Member

    Someone was just asking the same question on another thread, or two, or three. In fact, you are a perfect 5 out of 5... 100% of all posts asking for ebtables.

  77. rviteri

    rviteri Addicted to LI Member

    Sorry about that mate.. will not repeat the post.
  78. kiskakas

    kiskakas Network Guru Member

    Are there any hope for a dualwan release? Is it to difficult to translate the chinise dualwan version's text?
  79. LucasMoon

    LucasMoon Network Guru Member

    I got the WRT120N router. Does tomato support that router yet?
    Thank you
  80. kiskakas

    kiskakas Network Guru Member

    Dualwan tomato_dual_1.25.0341.7z works fine! :)

    my config is:

    WAN1 - 8m ADSL wired
    WAN2 - 4m WIFI wireless client mode

    my torrent download is 12m ;))
  81. kallsop

    kallsop LI Guru Member

    I went back to 1.23 and that rebooted today. Now I think it's the QoS that is causing the reboots. When I was running 1.23 before, I wasn't using QoS, and that ran for months and months and never rebooted. 1.23 or 1.27 with QoS enabled and it's rebooting every few days. I'll run 1.27 without QoS and see how that goes, and report back in a week or so.
  82. pharma

    pharma Network Guru Member

  83. fun.k

    fun.k Addicted to LI Member

    Been using .23 ever since it came out, and the only reboot (260 days ago) was due to a major network cabling re-hauling:

    Just upgraded to .27 and everything seems smooth so far. You guys rock :)
  84. wasp87

    wasp87 Network Guru Member

    My router restarted 4 days ago running Tomato 1.27, not sure why but, I guess that means it's unstable :(
  85. lokk

    lokk Guest

    VPN server supported?
  86. pharma

    pharma Network Guru Member

    Why not try the official 1.28 beta and see if you notice the same behavior?
  87. clweb

    clweb Network Guru Member

    Here the uptime with V1.27 is more than 103 days. So, I don't think it's unstable.
  88. Silviu

    Silviu Addicted to LI Member

    Uptime 90 days, 19:40:22
    I would say verry stable :) 1.27
  89. landa

    landa LI Guru Member

    One possible bug in 1.27:

    I have unchecked DHCP Client option from Adminsitration - Logging, but my router continues to save logs when someone asks an IP from DHCP server.
    How to stop this kind of logs?
  90. wasp87

    wasp87 Network Guru Member

    Running 1.28 Beta and it restarted 2 days ago, again not sure why, but seems like it crashed.
  91. Toastman

    Toastman Super Moderator Staff Member Member

    landa, you unchecked the DHCP client logging option, but are talking about the DHCP server?
  92. devilkin

    devilkin LI Guru Member

    Same issue. 1.27 started rebooting out of the blue. Used to be rock solid (uptime 50+ days), now it reboots every two-three days. Highly annoying. Will try 1.28 beta to see if it's any better.
  93. szfong

    szfong Network Guru Member

    I've had this issue on one of my Tomato routers last month. I suspected flash related issues. So, I flashed the largest dd-wrt firmware that will fit AFTER performing 30/30/30 reset. Then flash back to Tomato 1.27, after-wards do 30/30/30 again. Auto-Rebooting seems to have been fixed. As router age, can also cause reboots, it seems.
  94. callous

    callous Network Guru Member

    I too experience tomato firmware corruption (for 1.22?), until i flashed first to ddwrt, then flashed back to tomato.
  95. Flup64

    Flup64 Guest

    I had the same issue starting to use 1.27.
    Every 24 hours the router (WRT54G v2) would reboot.

    After turning of all logging, I've no longer seen any reboot (fingers crossed) :biggrin:

    I have a question....
    Can I go from 1.27 to 1.27ND without nvram erase?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice