Official Tomato v1.28 Released

Discussion in 'Tomato Firmware' started by FattysGoneWild, Jun 28, 2010.

  1. FattysGoneWild

    FattysGoneWild LI Guru Member

    Tomato 1.28
    Submitted by jon on Mon, 2010-06-28 12:48 Firmware

    Version 1.28


    * Fixes for udhcpc. Thanks to fedor for his help.
    * Warn if saving an empty Access Restriction since it's the same as blocking everything.
    * Add option in Admin:Access to select which menus are permanently expanded.
    * Increase PPPoE username and password length.
    * Increase limit for web_printf to avoid problems handling very long variables.
    * Update Dnsmasq to 2.55.

    This is basically beta 1812 with an updated Dnsmasq.
  2. pumpkin

    pumpkin LI Guru Member


    successful flashed, no Probs. Thanks a Lot for the Update.

  3. FattysGoneWild

    FattysGoneWild LI Guru Member

    I will be holding off for a few days. Usually with a new release. Well actually the last 2. A small minor issue comes up and always gets fixed right away.
  4. kiskakas

    kiskakas Network Guru Member

    i used 1.28 beta since about 2-3 weeks and works fine.. now i updatet to final 1.28 :)
  5. 5hi7h34d

    5hi7h34d Addicted to LI Member

    Still running 1.25. Is it best to default everything while flashing and reset my forwards etc manually? Or can I do an "in-place" upgrade?
  6. FattysGoneWild

    FattysGoneWild LI Guru Member

    I always clear NVRAM (thorough) before and after when upgrading to a new version.
  7. Talon88

    Talon88 LI Guru Member


    Thanks Jon for the Hard Work...!

    But Look like there are some problem at [Port Forwarding].
    The Port doesn't open after I've set the rules.

    I have checked the [Access Restriction] already.
    No Blank Rule there. Just 1 setting by me enable, & other one is
    the Example rules but disable.

    Anybody have problems on this issue...?



    The Strange is, even I roll back to v1.27 with v1.27 Config Backup,
    I still have Port FW problem. Not sure is my ISP problem today or
    Flash v1.28 mess up my router. I tried clear NVRAM already....

  8. szfong

    szfong Network Guru Member

    You should 30/30/30 reset, flash to latest, largest pre-sp2 dd-wrt that will fit (tftp preferred), reset again, flash to tomato, and reset once again.

    As always be careful & do not interrupt flashing, and know the various recovery methods.

    I suspect you forgot to RESET & RESTART before flashing to 1.28. nvram corruption can occur to config, especially if you have very high uptimes when flashing. Writing dd-wrt completely write over the area that "updates" do not usually touch.
  9. Talon88

    Talon88 LI Guru Member


    Thanks szfong for the reply.

    I never have this problem before, just update the newer firmware
    at tomato GUI.

    I have Tried the [Erase all NVRAM] at GUI & reflash but no use.

    I am thinking maybe ISP problem. I will wait for few days & see
    if the problem will go away.

  10. Talon88

    Talon88 LI Guru Member


    Umm, Look like is the ISP problem.

    The Port FW is back to normal all of suddent.

    Sorry for the false alarm...

  11. myersw

    myersw Network Guru Member

    Some folks are waiting for Victek to put out a new release based on 1.28 I suspect. I had issues with 1.27 on a WRT54GL but not Victek's 1.25. Also for my Asus upgrade from the WRT I run teddy-bear's mod.
    I suspect most folks have moved to teddy's or are waiting for Victek. Jon did a great job on the original Tomato (many thanks, Jon) but I get the feeling he is not interested in doing support for newer then the WRT54's. He has worked long and hard and deserves are rest.

    OPPS, meant this for the excitement waning thread. ;-)
  12. comet.berkeley

    comet.berkeley LI Guru Member

    I installed a day ago it and it runs fine for me.

    Thanks Jon!

    Most of the "problems" that I have are with other software such as Firefox or Windows 7, which squawk about certificates and other non-issues with "security".
  13. TVTV

    TVTV LI Guru Member

    Using it for 3 days. Uptime is OK, no crashes or anything. Transfer speed is the same as it was with 1.27 - close to 5 MB/sec w/QOS on and overclock active.
  14. Morac

    Morac Network Guru Member

    I haven't updated to this yet, but I've been running the 1.28.1811 ND version on my WRT54GLv1 for a few months. The only problem I've found is that measuring the noise floor on the device list page permanently kills the wireless interface. The only way to get it back is to either reboot the router or do something that causes the wireless interface to reset such clicking "Save" on the Basic Network page.

    I emailed Jon about this (twice), but I'd be surprised if it's fixed since I never heard back.


    Just updated to 1.28.1815 ND and it's still a problem. :(
  15. LanceMoreland

    LanceMoreland Network Guru Member

    I can confirm this bug. Same issue on my units.
  16. Trademark

    Trademark Network Guru Member

    I can also confirm this issue on a WRT54G-TM. In fact I have had this issue as far back as v1.23 with Standard ND and Victek ND.

    This, along with increasing the Transmit Power having no effect in the ND versions (Victek included), are the only annoying bugs I've found with an otherwise superb firmware.

    I wonder if this is all tied to the v. Ethernet/Wireless driver and could be alleviated with a different driver update? Just a thought...
  17. LanceMoreland

    LanceMoreland Network Guru Member

    Is there a command that could be sent to the router via telnet to change the transmit power in the meantime? I don't see any change in transmit power via the web interface either.
  18. Trademark

    Trademark Network Guru Member

    Take a look at this thread.

    Although it is said to be fixed in Victek or using the script in regular Tomato, I beg to differ, as I have tried it all to no avail. The signal just doesn't change for me.

    DD-WRT uses Ethernet/Wireless driver v4.150.10.31 in their NEWD version, and people say increasing Transmit Power works correctly, but I personally have not tested it.

    I think there may be a connection to the driver itself, but I do not have the skills to compile it myself. Anyone willing to give this a go? Jon, Vic, Teddy, anybody?
  19. LanceMoreland

    LanceMoreland Network Guru Member

    I am not sure how this happened but it may help the developers fix the transmit power issue. I have two dedicated WDS routers that only talk to each other wirelessly; they are set to WDS only. So recently with the ND version of Tomato, I have been playing with the transmit power setting and no matter where I set it there was no noticeable change in the signal strength. The results were the same with 1.25 Victek ND and 1.28 Tomato ND.

    After seeing the posts regarding the issue, I decided to try the non-ND version of Tomato on both WDS units. For whatever reason I also saw no real increase in signal strength by increasing the number with the non-ND version either, so I gave up and reflashed the ND version after having set the transmit power to 84 while using the non-ND version. I did not clear the navram and I am now seeing a 5 dBm signal increase from both units with the ND version.
  20. lwf-

    lwf- Network Guru Member

    Confirmed. 1.28.1815 ND, WRT54GS v1.1.
  21. landa

    landa LI Guru Member

    I use Victek ND mod on my WRT54GL and measuring the noise floor on the device list page, is ok. No wireless crash!
  22. Badders44

    Badders44 LI Guru Member

    Agreed landa - works fine here also.
  23. jsmiddleton4

    jsmiddleton4 Network Guru Member

    -TM version crashes.
  24. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Crashes doesn't seem like the right word. Its as if the programming to check the noise floor is missing the code to fully re-enable the wireless radio.

    We're talking straight Tomato too. Not Victek's mods right?
  25. kallsop

    kallsop LI Guru Member

    Good results here with 1.28. About 2 days after upgrading, the router randomly rebooted once. since then it been running and running and is now at 19 days uptime.
  26. azdps

    azdps LI Guru Member

    does usb work with this firmware?
  27. fun.k

    fun.k Addicted to LI Member

    Can't provide any technical evidence but i'd swear that the whole UI responsiveness feels much faster without any other changes on the rest of my infrastructure.

    Thanks to everyone involved, Tomato is one of the few and far between pieces of tech, that make life easier :)
  28. surfsup

    surfsup Networkin' Nut Member

    Just upgraded from Thibor (2006 version) to Tomato 1.28 - had a time with my passwords after cleaning out nvram but all is well now. I assume all is good (for now)?!
  29. eegorr

    eegorr Network Guru Member

    Hah! I thought I was the last one running Thibor firmware, but I switched to Tomato a year ago (or more). Glad I did, too!

    DD-WRT is another good choice, but I find Tomato to be easier to use and has all of the features I need. Unfortunately, I just swapped out one of my WRT54GSv4 routers for a WR54GS2v1 - Tomato will not run on it, do I am running a micro build of dd-wrt.
  30. encore2097

    encore2097 Network Guru Member

    Just wanted to say thanks Jon!

    Haven't posted lately because I've been busy and haven't needed to.

    Running Tomato 1.28 on a WRT54G V2.0, running flawlessly. (With VoIP and heavy P2P)
    Current Uptime: 112 days, 15:13:48
  31. tdfranke

    tdfranke Networkin' Nut Member

    Vpn?? - 1.28

    Does anyone know if version 1.28 includes OpenVPN?
  32. rhester72

    rhester72 Network Guru Member

  33. Gewehr98

    Gewehr98 LI Guru Member

    Downloading v1.28, but a quick question if I may...

    Does the random reboot problem as found in v1.27 appear to go away with v1.28?
  34. Talon88

    Talon88 LI Guru Member


    I dont have reboot problem since v1.28 was load.
    Even BT.


  35. clweb

    clweb Network Guru Member

    I have no problems with 1.27. The uptime is 375 days now.
  36. dishjuarez

    dishjuarez LI Guru Member

    I have a wrt54g V4 and I am interested to install openvpn tomatousb but do not identify the correct file for my router, can you helpme?
  37. naptime

    naptime LI Guru Member

    Anecdotal and all that, but I ran v1.25 for over a year and no random reboots, and just upgraded to v1.28 two weeks ago and had my first RR three days later, but no more since.
  38. kiskakas

    kiskakas Network Guru Member

    dear Folks!

    how can i check the lan port's speed and duplex ? i've a media player connected to my wrt, but it seem, the connection is half duplex or maybe 10mbit, not 100.

    i cannot find any command at busybox. :I
  39. rhester72

    rhester72 Network Guru Member

    robocfg show

  40. kiskakas

    kiskakas Network Guru Member

    there isn't any command in 1.28 tomato

    robocfg show
  41. rhester72

    rhester72 Network Guru Member

    You're right - it's a part of TomatoUSB. There is no robocfg equivalent in 1.28. Sorry!

  42. Vertigo

    Vertigo Networkin' Nut Member

    Well I've just started using Tomato on a WRT54GL v1.1 with the 1.28 firmware and have already just had what seems like a random reboot about 6 minutes ago :(
  43. kiskakas

    kiskakas Network Guru Member

    thanks, i will try tomatousb soon :)
  44. Toastman

    Toastman Super Moderator Staff Member Member

  45. Vertigo

    Vertigo Networkin' Nut Member


    Thanks for the reply. I'm not using the ND version I don't think - the main download page seemed to suggest this was for routers other than my 54GL so I downloaded the standard one.

    Are you saying that I should install the ND version on my WRT54GL v1.1? Willing to give it a go - will this be ok on my model of router?
  46. rhester72

    rhester72 Network Guru Member

    Yes and yes!

  47. Vertigo

    Vertigo Networkin' Nut Member

    Ok thanks. Put the ND firmware on it last night and so far it's been running without reboots but then there's not much activity overnight nor any wireless clients connected so I'll keep an eye on it today and see how it goes.
  48. Gewehr98

    Gewehr98 LI Guru Member

    Regarding the ND version of 1.27 and 1.28...

    I "fixed" my random reboot problem with my WRT54G-TM by turning off the BlackBerry phone's WiFi connection to the router. However, at some time in the future I'd like to restore that connection to augment the poor AT&T signal in my residence.

    Am I correct in understanding I can install the ND version of Tomato in my WRT54G-TM just as easily as upgrading standard Tomato from 1.27 to 1.28?

    Also, I see cautions about doing a complete NVRAM refresh after switching over. Does that mean I'll have to manually enter all my QOS and Vonage port forwarding settings again after the upgrade? :confused:
  49. rhester72

    rhester72 Network Guru Member

    Yes, it's a straight upgrade, and no, you shouldn't need to clear NVRAM just to move to ND.

  50. fairuza

    fairuza LI Guru Member

    is there anyway you can let people edit the names in QOS->Basic Settings->Outbound/Inbound Limits?

    i want it back to generic names like "level 1" not the forced naming of specific things like it is now.

    i also seem to remember that 1.28 limits how many ports you can add to QOS->Classification->Outbound Direction now? why?

    these changes are really messing up how i do things. it was so much better before.
  51. naptime

    naptime LI Guru Member

    I've had two random reboots with 1.28 on my WRT54GL today, and some dropped connections with a new iPod Touch 4G the last couple of weeks, and I understand the ND version should help fix this? I downloaded the files, but I see a "tomato-ND.trx" file in the package which the FAQ says is for Buffalo routers. Is this the file to flash the router with?

    I know Vertigo asked much the same questions, but I don't want to brick this thing. Thanks.
  52. adlerfra

    adlerfra LI Guru Member

    I flashed my WRT54GL V1.1 with v1.28.8754 ND Std from Look for it under Kernel 2.4 (stable), NoUSB std. This has eliminated the dropped connections for me. Also with this version, the wireless noise floor is lowest/signal quality higher than with other tomato versions/mods. As always YMMV.
  53. naptime

    naptime LI Guru Member

    Thanks adlerfa, I'll probably give it a try. But again, I'm getting a .trx file and I'm used to .bin for all my other tomato upgrades. Is the .trx file the right binary?
  54. adlerfra

    adlerfra LI Guru Member

    Tomato will upgrade directly from a .TRX binary.
  55. fin1211

    fin1211 Networkin' Nut Member

    hey everyone. im new here. just got a linksys e2000, and was planning to use my wrt54g2 v1 as a wireless bridge in order to get internet to my xbox 360. can someone lead me how to do this? thanks!
  56. Yochanan

    Yochanan Guest

    Why would you bridge any router? You obviously have a modem from your ISP to connect to the internet. Bridge that if you wish and use a router from there. You don't need two routers for what you're talking about. Tomato supports the WRT54G series, but not anything near as new as your e2000.
  57. vick04

    vick04 Network Guru Member

    Im running Toastman's mod with git from 2/22 and i cant seem to get the ipv6 tunnel stable. With everything configured the tunnel will only become active if i ping the router ipv6 address (2001:470:1f07:a1a::1) from the machine i want to use ipv6 on. If i stop pinging that address the tunnel drops 5-10mins after. It comes back instantly the minute i start pinging 2001:470:1f07:a1a::1 (router address). The router time is accurate and is set to sync every hour. Im running tunnel broker.

    Anyone know how to fix this?
  58. Toastman

    Toastman Super Moderator Staff Member Member

    Yochanan, Tomato variants support the E2000,E3000, and many new models of router, as you can see by reading the posts above. Where have you been for the last few years?
  59. dmb41crash

    dmb41crash Networkin' Nut Member

    Actually, he is technically correct, especially considering this thread is titled "Official Tomato v1.28 Released". The official release does NOT natively support the E series due to the 32k vs 60k CFE issue. Most of us take TB's mod for granted as the holy grail of Tomato, which it may well be now that development of the official branch is so stagnant and TB's mod is way ahead of it. However, in the grand scheme of things it's still a mod of the official product.
  60. Derekwit

    Derekwit Networkin' Nut Member

    I just uploaded tomato 1.28 to my Linksys E3000. I am trying to block to a particular ip address in my office. This what I did. Logged in to control panel clicked on access restriction. Clicked on add. Gave it a name. Clicked the applies to drop down box and selected by ip address. Unchecked the block all internet access. Typed facebook down in the window below. Saved.... Not blocking access. What did I do wrong?
  61. Hogwild

    Hogwild LI Guru Member

    Could be wrong, as I'm new here, but I think this is more of a general help question so may
    not belong in this thread.

    Works for me on Tomato stock 1.28. Did you try specifying, for example, "$"
    in the http request window instead of what you've already got?


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice