One inaccessible website

Discussion in 'Tomato Firmware' started by Danielink, Jan 27, 2008.

  1. Danielink

    Danielink LI Guru Member

    I have a Linksys WRT54GL running Tomato (just flashed from 1.07 to 1.14 today). Have had no issues with Tomato as far as accessing websites, except for one, which my wife frequently visits. The problem didn't start until some time after I started using Tomato, so I really don't think the problem is with the firmware. However, we called our ISP Tech Support, who recommended that we try to access the website directly thru our modem, bypassing the router. I was able to do that successfully, leading us to believe that it must be a setting in the router. (BTW, I ran tracert, and it always seems to time out at the 18th hop.)

    My question is this: I have looked in the router's setting, but am not sure if there is some way to configure the settings in Tomato to allow this webpage to open. Again, I'm a little puzzled because my wife was able to access the site long after I switched to Tomato. Any suggestions? :eyebrow:
  2. ifican

    ifican Network Guru Member

    These types of issues are always fun, i would not worry so much about the trace route not going through as perhaps the devices the trace is traversing do not responds to the request. It could be dns on the isp side, it could be that the site has changed the way it responds to access, changing ports or doing something different on its side that is giving your router grief. Lets start with the site you are trying to go to, we can have a look at that then we can proceed from there.
  3. Danielink

    Danielink LI Guru Member

    Hi, ifican ...

    The IP of the website we cannot access is The URL is (I know, it sounds a little racy, but it's actually just a paint shop where she paints avatars for people to use in their chat rooms!)
  4. LLigetfa

    LLigetfa LI Guru Member

    Check your MTU size.
  5. Danielink

    Danielink LI Guru Member

    Mtu = 1500.
  6. Danielink

    Danielink LI Guru Member

    Changed MTU to 1468 ... no help.
  7. LLigetfa

    LLigetfa LI Guru Member

    Is this PPPoE over DSL? Did you change MTU on the router, on the client, or both?
  8. Danielink

    Danielink LI Guru Member

    No, this is thru a cable modem.
  9. ifican

    ifican Network Guru Member

    Ok back to trace route, the site is accessible via traceroute so you to should beable to get to it. Appears that the front end of the site uses alot of active x, so check browser setting and check your tomato config because i think there is a checkbox to not allow active x. As an fyi, IE didnt like the site to much, it came up, but slowly and complained about alot of the sites settings, opera and firefox didnt care to much about it. Go down that road and let up know if your still having issues.
  10. Danielink

    Danielink LI Guru Member

    Well, I tried accessing the website using Firefox, both from my Win XP Pro and a Linux (Ubuntu) PC ... still couldn't get to the website. I'll check my Tomato setup for the ActiveX setting you suggested. Still hard to understand why it would quit working now when it has worked fine, and I haven't made any changes in Tomato. :confused:
  11. LLigetfa

    LLigetfa LI Guru Member

    Try downgrading to 1.13 and also try a 30 second hard reset to defaults.
  12. Danielink

    Danielink LI Guru Member

    Have not tried reflashing to 1.13 ... the webpage quit working while I was still on 1.09. I did power off the router and modem, and reset them. Tried the webpage again, both in IE 7 and Firefox. Still no success. Any further suggestions?
  13. ifican

    ifican Network Guru Member

    Yeah that is a good one, if you really want to figure it out and stop just guessing, load wireshark (free packet sniffer) on your xp machine and run it while you try accessing the website, that way you will know exactly what is going on and how to go about fixing it. Some versions of linux and unix have a snoop function that will do the same thing. The setting will probably be under security>firewall>filter active x. I guess if you dont want to do the packet sniffer you can try resetting to defaults and giving it a go and potentially reloading, maybe something got gummed up. It this sort of reason i prefer a firewall that i can monitor realtime to tell me whats going on, tomato would be good for that if you could load a packetsniffer into it and run it from the command line.
  14. LLigetfa

    LLigetfa LI Guru Member

    Sorry, I missed that detail. You wouldn't happen to be running through OpenDNS by chance on the router?
  15. Danielink

    Danielink LI Guru Member

    Still can't pull up that one website

    Not running thru OpenDNS. I can d/l and run Wireshark. May also try flashing the router to something different, e.g., DD-WRT (which I was running before hearing about Tomato) or even going back to the latest Linksys firmware (unless that could create more problems of its own). If anyone can think of other possible causes/solutions, please let me know. Meantime, I'll keep you posted.
  16. Danielink

    Danielink LI Guru Member

    Do you think the issue has to do with Tomato, even though the problem started while I was still running 1.09? Any input about reflashing using different firmware (DD-WRT, or even the new Tomato 1.15)?
  17. DeCex

    DeCex LI Guru Member

    Is this DNS lookup issue? Can you try adding like a alternate DNS server to your PC config. Try add to your PC DNS config.

    (* Dns resolved to , a Swedish university NS)
  18. Danielink

    Danielink LI Guru Member

    I could try adding another DNS Server setting. Is there something in the original settings that might have gotten corrupted?
  19. DeCex

    DeCex LI Guru Member

    I ment was, try manually set your PC to use internal IP settings, bypassing the router DHCP service, set your PC to use;


    I am guessing that the router itself is getting DNS server from your ISP provider, but you set your PC to use another. I hope your understand what i mean.
  20. Danielink

    Danielink LI Guru Member

    Thanks, DeCex. I do understand what you are recommending. I can try this when I get home. Just curious, whose IP is :confused:
  21. Danielink

    Danielink LI Guru Member

    DeCex, I tried adding a static IP, subnet, & GW, and added the other DNS server setting you suggested. Still can't access the elusive website. :frown:
  22. Danielink

    Danielink LI Guru Member

    After flashing my router to Tomato 1.15, and still having no success getting to my wife's paint shop website, I decided (just for the heck of it) to flash it back to the latest Linksys firmware. Did that, set it up, but still no help. I did take ifican's advice and d/l Wireshark. Thru that, I was able to isolate the port that is supposed to open for access to the website (2382), but now I'm not sure where to go from here.
  23. feld

    feld Network Guru Member

    you should never have to open a port to visit a website. the router's firewall will allow all established,related traffic through. If you request to the outside world first, they can come back in and talk to you through the router.

    what website is this anyway? post your wireshark packet dump.
  24. bhlonewolf

    bhlonewolf LI Guru Member

    Is it possible they are blocking the IP for some reason? If you plug in your computer directly, and it works, you may be getting a different IP address from the cable co, right? Try MAC cloning that MAC address on the router so it grabs the same IP address, then try. Kind of a long shot I guess.
  25. ifican

    ifican Network Guru Member

    Though this is the case most of the time it is not always the case with all applications. However as long as the sight is not trying to do anything strange it should work as stated. And from my end it all looks ok, seems to be something on his router or network.
  26. Danielink

    Danielink LI Guru Member

    Just to recap: we contacted our ISP to report the problem, and the tech had me bypass the router to see if the webpage (, a paintshop, would come up if we connected directly to the cable modem ... it did. I have tried flashing the router (went from Tomato 1.09 to 1.14 to 1.15, and finally back to the latest Linksys firmware - the webpage failed to load on all of these). This really seems like an odd situation, so I appreciate all of your recommendations. If you can think of any other things to try let me know; I will keep you posted.
  27. DeCex

    DeCex LI Guru Member

  28. Danielink

    Danielink LI Guru Member

    Yes, held the reset button (recessed, on back of router) for 30 seconds. I may not have powered off the cable modem before doing that, however. Resetting it this way should take the router back to its defaults, so since I flashed it to the latest Linksys firmware, that's what I should expect to see, but with all default values, right? I may have to try the reset again, but remember to power down the modem first.
  29. Danielink

    Danielink LI Guru Member

    I re-flashed the router back to Tomato 1.15, and tried all of the suggestions given in this thread. Still cannot open Since this is the only website I'm aware of that we cannot access, I'm still inclined to think we are being blocked (even though my wife contacted someone on their end, who said that wasn't the case). As I said in one of my earlier posts, I ran tracert, and it went thru about 17 hops before hitting a brick wall.
  30. azeari

    azeari LI Guru Member

    tried using a cgi-proxy to access it? google for some of them. it should load the page if you're being blocked
  31. Danielink

    Danielink LI Guru Member

    Thanks, azeari, I'll give that a try. The website is a paintroom where my wife paints chatroom avatars. Like I said, this is the only page where we've had this problem, and it doesn't matter whether I'm running Tomato (1.09, 1.13, 1.15) or Linksys firmware, or whether trying to access it thru IE 6, 7, or Firefox. :rolleyes:
  32. Danielink

    Danielink LI Guru Member

    I was able to find a list of cgi-proxy sites; tried one that did let us get to the paintroom website. Now we need to figure out a way to icorporate it from within the chatroom so that my wife can have access to the avatars she paints while communicating with others.
  33. wol2

    wol2 Guest

    Hello, i`ve got similar problem, but with more pages. I`ve tried to clear alle the settings by resset button and resseting nvram but it didn`t help. For example yesterday webpages were working fine for exemple . Today I couldn`t enter it. This problem is strictly linked to DNS because when I get dns via dhcp on tomato. Pages Don`t work. But when I`ve eneterd DNS into XP tcp/ip setting there are no problems and everything works just fine.

    There is tomato 1.15 in wrt54GL. Got any solutions for this?
  34. Danielink

    Danielink LI Guru Member

    I've had a lot of suggestions, and so has my wife (from her chat buddies), none of which have actually fixed the problem (although we do really appreciate the suggestions). Probably the best workaround has been azeari's recommendation to try getting to the website thru a cgi-proxy site ... that actually worked, but still didn't allow my wife to access the page thru the chatroom where she normally does.
  35. Dudeman456

    Dudeman456 LI Guru Member


    Could you try something for me? Assuming you are using Tomato V1.15, put the computer you are on in the DMZ. Could you also tell me the IP of your DNS? Thanks
  36. Danielink

    Danielink LI Guru Member

    Hi, Dudeman ...

    I did try DMZ, and it didn't make any difference. My DNS IP is just
  37. Dudeman456

    Dudeman456 LI Guru Member

    What is the router's DNS address?

  38. Danielink

    Danielink LI Guru Member

    Are you talking about something other than the default DNS of
  39. bengarland

    bengarland LI Guru Member

    I'm having the same problem here...

    Just wanted to say that I'm having the exact same problem.

    Here's my setup:

    Router - Linksys WRT54g v3
    Tomato - v 1.17
    Service - Time Warner Cable

    Cannot load:

    Does not work with TWC DNS nor OpenDNS. Also does not matter if I use the original Linksys firmware or Tomato.

    Loads fine if I plug my Mac directly into the cable modem.

    Can't figure out what is going on, and why this single website won't load through the router.

    Seems to be the same issue as the original poster, although I can load his website just fine. Can anyone load



    EDIT: Ok, so I installed a cgi proxy on my remote server. The site loads. However, one part of the site I am trying to use is a mapping application (similar to google maps). It apparently uses a lot of javascript or something that doesn't work through the proxy (at least not the cgi proxy that I'm using).

    Here is a direct link to the map page:

    EDIT: Updated link -- Parcel Maps of Franklin County

    Also, I tried the MTU settings suggested in this thread on Metafilter, changing the MTU on the router (through Tomato) and on my Mac using the command line. Still didn't work.

    Any suggestions?
  40. bengarland

    bengarland LI Guru Member

    Well, I fixed it.

    By buying a D-Link router.

    No joke. I'm calling Linksys tomorrow with a WTF?
  41. rben789

    rben789 Guest

    Cannot Connect to a Website through Router

    I have a Linksys WRT54G router and am having the same problem. Can access all internet sites through direct modem connection but when I hookup to wireless router, I cannot access a website.

    Have tried all the suggestions to no avail.

    Is there a fix or should I buy a new router.


  42. Toastman

    Toastman Super Moderator Staff Member Member

    Don't give up - for every problem there is a reason. Just noticed this thread is very old... probably sorted long ago. Tomato is now into v2.3 !
  43. renno

    renno Guest

    There seem to be a fair few occurences of this around. I'm experiencing exactly the same (although currrently with Tomato v1.23)

    I can't believe that such a seemingly simple problem has flummoxed the world. If it's not a Tomato problem (the OP flashed back to Linksys firmware), what else can it be?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice