"only b"-mode works, "only g"-mode or &q

Discussion in 'HyperWRT Firmware' started by muenstereifel, Nov 6, 2004.

  1. muenstereifel

    muenstereifel Network Guru Member

    hello over there,

    i've got really into trouble with my wrt54GS, running Firmware Version: v3.17.4 - HyperWRT 2.0b1.
    my notebook (a fujitsu-siemens, centrino-technologie) is not able to connect to the router in g-standard (wrt: only g-mode or mixed-mode). running the wrt in "only b-mode" it is no problem for me to connect to the router and the signal is very good.
    has anyone an idea what the problem could be? :cry:

    i'm really in despair. :cry:

    sorry for my bad english . . . if you don't understand what i mean, ask me. ;)
  2. Toxic

    Toxic Administrator Staff Member

    can you see a signal when the wrt54Gs is in G mode?

    try using netstumbler on the laptop and see the signal strength.

    or try making the power gain higher.
  3. Esquire

    Esquire Mesquire Staff Member Member

    Which Fujitsu notebook model? Is the Intel wireless adapter your notebook is using a B-only or B/G adapter?
  4. muenstereifel

    muenstereifel Network Guru Member

    hi guys,

    yes there is a signal. windows shows a signal-strenght of 4 of 5 bars. that signal should be strong enough i think. :roll:
    it's an amilo m 1420. and the notebook is using a B/G adapter. it's the modell Intel(R) PRO/Wireless 2200 BG Network Connection. that's what ne device-manager says . . . i hope this helps you. :oops:

    EDIT: here is the result of my networkstumbler-scan:

    encryption is shown as WEP but in the router interface it's WPA PSK. Intel Proset is also configured to use WPA PSK.
    i hope this information helps you to support me. :)
  5. Esquire

    Esquire Mesquire Staff Member Member

    If I remember correctly, Intel's 2200BG wireless adapter is a "G" adapter so your notebook should be able to connect to a "G" network.

    Network Stumbler reports every encrypted network as WEP regardless so I don't think there is anything wrong there.

    Which firmware were you using before you switched to HyperWRT? And did the G-only mode work then?
  6. Toxic

    Toxic Administrator Staff Member

    try channels 1, 6 or 11 as the initial channels first. of all.
  7. muenstereifel

    muenstereifel Network Guru Member

    i was using the original linksys firmware before i installed the Hyperwrt.
    the confusing thing for me is that for a day (or two days) and Firmware Version: v3.17.4 - HyperWRT 2.0b1 g-mode worked perfectly. :evil: i don't know what's wrong . . .
    using the original linksys firmware the g-mode didn't work eighter.

    i actually tried all channels but i will try theese three channels again.

    thanks for your support! :wink:
  8. Esquire

    Esquire Mesquire Staff Member Member

    Sorry. I re-read your posts and one thing wasn't very clear. Is your notebook able to detect the router but simply cannot connect? Or it can detect and connect but fails to obtain a network IP?

    Have you also tried connecting without any wireless encryption (as a test)? Is SpeedBooster disabled?

    Did you do a hard reset?

    You will need to start over and reconfigure your router. This time leave the router in Mixed Mode or G-only.
  9. muenstereifel

    muenstereifel Network Guru Member

    i'm back. ;)

    few minutes ago i have done a "hard reset". problem's not gone and still exists. :roll:
    the w-lan-connection is detected by the notebook but when i click "connect" (in intel proset-utility) the connection isn't established. :evil: the dialogue pops up every, i wouls say, 30 seconds. i click "connect" and nothing happens again. :cry:
    the router runs in "mixed mode" and channel 6 at the moment. any wireless encryption is also disabled.

    how do i disable SpeedBooster? :oops:

    yeah, i think that's the point. that's the way i would describe my problem. 8O

    EDIT: by the way the screenshot above was made on (is that grammatically correct?) the notebook.

    after a while my notebook got the connection to the wrt. but the connection takes about 10 minutes and more. using "b-mode" the notebook gets the connection immediatly. :?

    2nd update:

    suddenly my network runs in perfect harmony. :lol: i don't really know what i've done wrong.
    is there eventually a "law" which says that these and those characters are forbidden to use as SSID or passphrase? :roll: maybe that was the major problem. i don't know. my SSID at the moment is the "original" namely linksys.

    btw: Esquire, is it possible that you are from Hongkong? :rolleyes:

    i want to say thank you all for all your previous support!

    THANK YOU :)
  10. Esquire

    Esquire Mesquire Staff Member Member

    I'm glad it came through for you.

    Your previous SSID W-LAN should work in term of the characters being used. Many vendors don't recommend using anything other than English characters and numbers for SSIDs, but I've tried all kinds of symbols as well as spaces on my network without any problem :wink:

    Now that you mentioned it, I noticed something else from one of your replies as well. This is just a guess, but maybe your SSID "W-LAN" being too similar to your neighbour's WLAN was causing the problem.
  11. muenstereifel

    muenstereifel Network Guru Member

    ok, thanks. :)

    maybe . . . i don't know. :roll:

    is it normal that a connection takes up to ten minutes until it's established? 8O . . . and now the next problem appeared. :cry: every now and then my connection breaks. last time it broke after about 1 1/2 hours. is that problem well-known? :oops:

    thanks for reply. 8)
  12. Esquire

    Esquire Mesquire Staff Member Member

    No. It is not normal. Windows XP should connect to the network while it finishes booting - ideally, you should be able to go online right after booting is complete. Do you have a firewall running on your notebook? If so, what is it? Try disabling it.

    Do you have access to another wireless computer so you can test the wireless connection to the router and see if it experiences the same issues? Is the router still under warranty in case it proves to be faulty?

    PS. Wireless network can break due to radio interference as well as other issues. My network breaks when my 2.4GHz phone base scans for the handsets, but connection is re-established, usually immediately. Does yours re-establish itself?
  13. muenstereifel

    muenstereifel Network Guru Member

    no firewall's running on any pc on the network. the firewall of winXP SP2 is disabled.

    no, the notebook is my only w-lan device. yes, the router is still under warranty. i bought it in september.

    no, the connection isn't re-established . . .

    it's really confusing. :?
  14. Esquire

    Esquire Mesquire Staff Member Member

    Sorry. Sounds to me like you have done everything possible to fix the problem. IMHO, the only thing left to do is to identify whether it is the router or your wireless adapter on the notebook is at fault, so if you know someone with another wireless notebook, may be you can ask him/her to come and try out your connection for you, and if the same thing happens it's almost definitely the router is at fault.
  15. muenstereifel

    muenstereifel Network Guru Member

    i solved the problem and my w-lan runs like, i don't know what! 8)
    the latest release of the intel-proset was the solution to the problem.
    i don't know the changes to the prior versions but it works very well yet.

    maybe this solution helps other centrino and linksys user.

    thanks for your great support! :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice