optware install help

Discussion in 'Tomato Firmware' started by ak907, Jul 31, 2014.

  1. ak907

    ak907 Connected Client Member

    Hello I formatted My 8gb USB flash drive with Gparted and it seems mounted up OK in tomato.

    Partition 'swap' swap (512.00 MB) is not active
    Partition 'optware' ext2 (503.95 MB / 500.83 MB free) is mounted on /opt
    Partition 'data' ext2 (6,323.13 MB / 6,309.00 MB free) is mounted on /tmp/mnt/data

    when I SSH in to my R7000 I run command

    wget http://tomatousb.org/local--files/tut:optware-installation/optware-install.sh -O - | tr -d '\r' > /tmp/optware-install.sh
    chmod +x /tmp/optware-install.sh
    sh /tmp/optware-install.sh

    but I end up with error in screenshot. Any advice?

    Attached Files:

  2. koitsu

    koitsu Network Guru Member

    I have some guesses but none are conclusive. I'd need to actually have access to the system to really figure it out.

    Can you format the /opt filesystem (don't just delete all the files -- optware often installs hidden files (ones that start with dot), it's just easier to format the filesystem -- you don't need to re-partition the drive for this, just format /opt) and instead use Entware, which is updated and maintained regularly? If so, I'd also suggest renaming the label 'entware' not 'optware'.

    Entware also has official support channels / a ticketing system, so if you use that and it works for you, but you encounter issues, please file tickets there. (This forum isn't for Entware support, but some of the Entware folks do hang out here and are very helpful :) )
    ryzhov_al likes this.
  3. ak907

    ak907 Connected Client Member

    I got same error trying to install entware. After extensive searching I was able to install optware finally. Method was to SSH to router and type:


    this might be specific to ARM platform, idk... but it worked =)
  4. koitsu

    koitsu Network Guru Member

    Wait, what? No. First thing: you didn't disclose what firmware (give the filename, nothing else!) you're using. Shibby I believe has Optware support "natively implemented", which may mean the Optware installation script comes with the firmware. But other firmwares do not have this. EDIT: Sorry, it looks like you did state what router you were using -- a Netgear R7000 which is ARM-based. My fault for overlooking that single line.

    If you are using an ARM-based router with TomatoUSB, and you went to install Optware via the old TomatoUSB instructions, then that is DEFINITELY going to fail -- because that installation script only works with classic MIPSEL architectures, which is exactly the "gut feeling" I had earlier (re: "I have some guesses...").

    TL;DR -- mipsel binaries will not function correctly on ARM, nor vice-versa. The result will be seriously hardcore breakage like what you've witnessed.
    Last edited: Jul 31, 2014
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice