Path too deep error: problems copying files over network

Discussion in 'Networking Issues' started by sae724d, Mar 21, 2006.

  1. sae724d

    sae724d Guest

    I have a problem saving files over a wireless 802.11g connection from a laptop **to** a WRT54GS router that is then connected via 2 hubs to a NSLU2. I am running XP on all machines.

    The full config is Dell Inspiron (WLAN) -> Linksys WRT54GS -> Netgear EN104 10Base-T (LAN) -> Netgear EN108 10Base-T (LAN) -> Linksys NSLU2.

    I get the infamous 'Cannot copy xxx: path is too deep' error (which is NOT really due to the path being too deep).

    I **can** copy from other machines on the wired part of the network to the slug, and I can also copy **from** the slug to the laptop. I can also copy from the laptop to another machine directly connected to the WRT54GS. All machines can ping each other and are on the same workgroup/domain and all can see the internet fine. Removing the XP firewall on the laptop has no benefit.

    Note the LAN uses 10Base-T & I have forced any ethernet cards on the wired machines to work at 10Mbps half duplex (since full duplex caused problems). The WRT54GS and the NSLU2 are both supposed to autonegotiate. I can't set their speed manually. Any help very gratefully received.
  2. andrewop

    andrewop Network Newbie Member

    long path tool can be used to solve this problem

  3. Patrick8

    Patrick8 Network Newbie Member


    I suggest to try "Long Path Tool" program .

    before I have problem cannot copy file because file path too deep. and after I found long
    path tool and now my problem solved :)


  4. paulina

    paulina New Member Member

    Why don't you try Long Path Tool?
  5. gregory2015

    gregory2015 New Member Member

    Have you tried software called Long Path Tool, it is absolute solution for such kind of errors.
  6. Markos illona

    Markos illona New Member Member

    i prefer to use software ( Long Path Tool )
  7. Hogwild

    Hogwild LI Guru Member

    I beg to differ. I think it IS a path length issue.

    Old thread, but I will just add this for other things you can try:

    Shorten the paths by either shortening the names of some of the folders/directories in which the files
    need to reside; or

    Copy/Move the files to a folder whose path is closer to the root folder on the destination drives or:

    Shorten the filenames.

    I had this problem a while back, and had to use all three shortcuts to fix the problem long-term.
    Even if you use Long Path Tool, if your paths are too long, you may simply have more problems in
    the future. Too complicated to explain, but take my word for it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice