PC's can't see each other

Discussion in 'Networking Issues' started by Thom_D, Oct 15, 2004.

  1. Thom_D

    Thom_D Network Guru Member

    I hope this hasn't been covered too many times before, but I could find a topic that seemed to match.

    I have a desktop PC running Win 2K Pro SP 4 and a laptop running Win XP SP2. I recently got a Linksys WRT54GS and set it up just fine. The desktop is attached by CAT5 to the router and the laptop has a WPC54GS wireless card.

    I can get on the internet using both machines but I can't get local file sharing going because I can't see one machine from the other.

    I set up a group and pointed both PC's to it, I set the folders and printer to be shared according to the documentation I have been able to find on the topic. (I am a total noobie at networking but I have all the network protocols installed that I think I need, netbui, TCP/IP, File and Printer sharing for MS Networks and client for MS Networks.

    When I first set up the newtork it worked fine, but I don't know where to start trouble shooting to get the file and printer sharing working again. That is the main reason I got the router in the first place.

    I have tried it with the firewalls turned on and off (Hardware and Zone Alarm) and still can't find one PC from the other.

    Is there a decent tutorial in laymans terms somewhere on setting up a mixed windows OS network that I can start with, or has anyone had a simiarl problem and found an answer.

    Thanks for any and all help on this.

  2. Toxic

    Toxic Administrator Staff Member

    do they have the same workgroup name?
  3. komUnec8

    komUnec8 Network Guru Member

    Have you got Netbios over TCP/IP enabled under WINS?
  4. ImprezaDude

    ImprezaDude Network Guru Member

    Hve u disabled the firewall in XP? (Network Interface, advanced settings under TCP/IP) XP2 enables it by default.

  5. Thom_D

    Thom_D Network Guru Member

    Yes to both

    I installed NetBios and have had the Win XP firewall shut off since I updated to SP2.
  6. Sandman333

    Sandman333 Network Guru Member

    can the machines ping each other?


    Type "ping" and then the IP address of the opposite machine (no " marks). To ping indefinitely, add a space and then /t after the IP address. Does it time out, or can you get a successful ping both ways?
  7. Esquire

    Esquire Mesquire Staff Member Member

    You have TCP/IP and NetBEUI installed?

    I presume you have left them as is after you have installed them. Try not to bind 2 protocols to the same service.

    To unbind either protocol:

    - Control Panel > Network Connections
    - (from the toolbar) Advanced > Advanced Settings
    - Untick NetBEUI Protocol under File and Printer Sharing for Microsoft Networks
    - Reboot your computer

    If this works, you may remove NetBEUI as this is now superfluous. If this doesn't work, try reversing the above and repeat on TCP/IP instead.

    Good luck.
  8. chet

    chet Network Guru Member

    I suspect that the responses you have received so far are on the right track.

    The configuration of multiple protocols means that SMB (Micrsoft file and print sharing) could potentially be bound to different protocol stacks. I can see a certain logic to binding SMB to NetBeui (it won't pass through your IP router), but it makes troubleshooting without a protocol analyzer tricky. Remove all the protocols except for TCP/IP, make sure that Microsoft File and Print Sharing is enabled on both systems, and try again.

    If as was mentioned earlier, if these systems can ping each other, they should be able to share file and print services
  9. Thom_D

    Thom_D Network Guru Member

    I removed the extra protocols

    I deleted and reinstalled just the basics, TCP/IP, MS Client, MS File and Printer Sharing. I can ping both PC's both ways but I still cant see the computers in net. neighborhood to open the folders attach to printer, etc. I keep getting the message "Network Path Cannot Be Found".

    I am only running the Linksys Firewall, and have tried without it as well and have had no luck. I have shut down Norton Internet Security, Norton AntiVirus and everything else I can think of that might be blocking the network path from being recognized. I even managed to hose up my internet connection in general and had to spend 90 minutes with the tech reps from my ISP and clear out a number of lines in my Registry File to get it back.

    I thought that File sharing was supposed to be the easy part of setting up a network. Sheesh!!! All of your suggestions are very helpful keep them coming so we can get my pc's talking and I can stop looking like an idiot in front of my wife.

  10. Esquire

    Esquire Mesquire Staff Member Member

    Unfortunately, like many technological devices, when it works it's easy, but when it doesn't, it drives one to near insanity :lol:

    Binding File and Printer Sharing to NetBEUI usually works for me only as a last resort, especially when just having TCP/IP doesn't work between different operating systems.

    This may be a long shot, but have you tried disabling QoS Packet Scheduler?
  11. Thom_D

    Thom_D Network Guru Member

    Yes I have disabled Packet Sharing

    I only have MS Client, MS File and Printer Sharing and TCP/IP runing on both machines.
  12. GodKomplex

    GodKomplex Network Guru Member

    do you have the accounts associated with the login on each machine? in other words.. Desktop account --> Account login on Laptop, Laptop Account --> Account login on Desktop

    Have you tried unchecking NetBeui? like previously stated, this protocol will NOT go thru a router. uncheck NetBeui and just use TCP/IP. If you can ping the other machine, you should be able to map via the TCP/IP address assigned to the alternate machine.

    hope this helps..

  13. Esquire

    Esquire Mesquire Staff Member Member

    Just like to point out that NetBEUI will work through the router - my home LAN is binded to this instead of TCP/IP. This protocol isn't a necessity - TCP/IP with NetBIOS enabled works just fine at work.
  14. Thom_D

    Thom_D Network Guru Member

  15. 4Access

    4Access Network Guru Member

    Re: I removed the extra protocols

    I was going to ask which firmware you are using since Sveasoft's Satori 4.0 will cause the problems you describe...

    But then I noticed that comment. Since you say you've tried without the router the Loopback option doesn't sound like the problem. Regardless, if you're still monitoring this thread it might be helpful to know which firmware you are using as well how you connected the PC's without the router. (Another Hub/Switch, Cross-over cable...?)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice