Peculiar TCP Problem with Wireless Access thru WRT54G

Discussion in 'Networking Issues' started by dgtloutlaw, Jan 4, 2006.

  1. dgtloutlaw

    dgtloutlaw Guest

    I have a Linksys WRT54G 1.1 running Version 4.20.7 version of the firmware.

    I am running Mixed Mode WEP with a manually entered WEP Key and MAC address filtering. At one point I had the SSID broadcast disabled...although I have enabled it now in order to better troubleshoot this issue.

    I have three wireless clients... a DLink DSM-320 Home Media Server, a Dell Latitude Laptop with Orinoco Wireless 802.11B Card and a Dell Inspiron with an integrated Intel Pro/Wireless 2915ABG Network Card.

    This setup worked for the longest time...until recently. The Dell Laptop with integrated ABG wireless card no longer gets beyond the access point. It sees the AP...Associates with it. I can release and renew my IP address just fine. I can even ping my DNS Server (External)... I can connect to the AP Web Client thru this wireless connection as well. I seem to be able to ping all external web address by IP only (so I am not resolving DNS)...However, I cannot connect to a web address thru IP which leads me to believe that for some reason the Access Point is not passing my TCP packets.

    I thought for some reason my Wireless NIC was not working properly...but after a quick trip to Panera Bread and connecting to their wireless network (which worked brilliantly)... I'm not certain what the problem is.

    My other laptop works brilliantly (the one with the Orinoco Gold Card)... I swapped the card into the laptop with the integrated controller and that connection worked perfectly too.

    I took the AP out of mixed mode and put it in B Only...still No joy. I've reloaded WEP and removed and re-added the MAC addresses into the MAC filtering table.

    I've also rebooted the access point more than my share of times. I am at my wits end with this. Does anyone have an idea...this used to work.

  2. DBruceM2

    DBruceM2 Network Guru Member

    You've tried most everything I would've up to this point. The fact that it works on another network indicates that it's not an issue w/ the PC or NIC. Obviously, the router doesn't like that NIC anymore for some reason.
    I'm not entirely familiar w/ your firmware, but I'll take a few stabs at things to try.
    First possibly try putting this laptop in the DMZ.
    If that doesn't work, the other thing to check is to make sure there's nothing weird going on w/ the MAC filtering on the wireless. Possibly turn the MAC filter off or remove and re-enter the MAC for that laptop.
    You might even take a look for Access Restrictions for that IP address. Other than that, I don't have any other bright ideas.
    Hope that helps.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice