Ping O.K. but Can't Flash Firmware / Bricked?

Discussion in 'Cisco/Linksys Wireless Routers' started by jfhi, Feb 19, 2007.

  1. jfhi

    jfhi LI Guru Member

    Hi, I got a wrt54g v.3 and I hope it's not bricked! I got Blinking Power and DMZ lights and no WLAN Light.

    I've been following several tutorials, one here on this forum

    Well, I can't access router settings via browser, my v3 wrt has a different IP than the original so I try the routers Actual IP in browser address bar and still no go.

    I can however ping the router successfully with the routers actual IP. So I figure I can Flash Original WRT54G v.3 firmware using tftp utility and no luck.

    I have tried every method trick hitting reset holding reset unplugging holding reset 5,10, 30 sec before and after power trying to flash fw and no luck.

    Tried setting LAN to 10mbs instead of 100mbs and still no luck.

    So i try to use Command prompt to flash after a successful ping and still no go Says "System path cannot be reached"

    So I try to flash with continuous ping running and still nothing!

    I thought about the LAST RESORT ground to chip method but I thought that was for the routers that could not Ping Successfully, Right? :confused:

    I figure this router is recoverable because communication is established through ping method but I can't Flash FirmWare on this thing to save my life.

    Using WinXP Pro, V.3 WRT54G, Linksys TFTP Utility to try and flash, Stock WRT54G FW from Linksys website.

    Any Comment Suggestions or Feedback Greatly Appreciated!

    Regards jfhi
  2. GeeTek

    GeeTek Guest

    Try using a network switch or hub between the computer and router to keep the computer's NIC alive. A lot of computers do not "wake up" quickly enough when the LAN is first connected. Also, hit the "upgrade" button on the TFTP utility just BEFORE you connect power to the router. Set the retry count in the utility to 25 or 30. Be sure to use the WRT's actual IP in the utility, not the linksys default IP.
  3. jfhi

    jfhi LI Guru Member

    I tried with the utility set to 10 tries (w/Router Actual IP) and when I start utility Before power on It takes computer till 7th or 8th try brefore computer establishes link to router and the last 2 or 3 tries the utility update still failed.

    I will try switch or hub and set utility to 25 or 30 attempts and hopefully that will do it!

    Thanks GeeTek

    Regards jfhi
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice