Please help with SSH question..

Discussion in 'DD-WRT Firmware' started by sufrano63, Oct 19, 2005.

  1. sufrano63

    sufrano63 Network Guru Member

    I used SSH to connect to my home wireless router, so I can bypass the office firewall to surf the Internet without restriction. Anyway, I mistyped a URL and it comes up with my router admin page? When I do an nslookup on the URL it comes back with IP address? Can someone tell me what's going on? Should I be concern?

    hardware: wrt54gv3 with DD-WRT v23 firmware.

    Any response is greatly appreciated.

  2. skipparoo

    skipparoo Network Guru Member

    How are you using your internet connection at home from work? Are you connecting to a PC through Remote Desktop or VNC, or are you using your router as a proxy and setting up a tunnel so all internet requests from work are forwarded through it? Perhaps you could post your configuration, the SSH client you're using, maybe the URL you're trying... I'm not sure why you'd be taken to the admin page of your router by mistyping a URL, that sure is strange, but post some more info detailing your configuration so we can get an idea of what's goiong on here.

  3. sufrano63

    sufrano63 Network Guru Member

    I'm using my router as a proxy and setting up a tunnel so all internet requests from work are forwarded through it.

    I'm using Bitvise Tunnelier ssh client

    I mistyped the URL and my router admin page comes up. Did an nslookup it show as being

    I think I'm safe. I found out that any 127.x.x.x address belong to localhost. Tried tracert and it comes back as being a localhost
  4. skipparoo

    skipparoo Network Guru Member

    Hey thanks for the bitvise link, I did not know about this SSH server and client, looks really good though. I'm going to play with WinSSHD and Tunnelier all weekend :)

    I'm still not sure why you'd be redirected to your router admin page after having mistyped a URL. It is true that any 127.x.x.x IP address falls under the localhost/looopback range. It could be that you're doing dynamic port forwarding and that has something to do with it but I still don't get it.

    Quick question for you. Are you able to launch a terminal window from Tunnelier after having connected to your WRT? When I try this my connection drops and syslog reports this message on my WRT: dropbear[5054]: exit after auth (root): bad buf_getbyte

    I AM using DD-WRT v22 which contains version 0.44test4 of dropbear, so that may be the problem. I tried vt100, bvterm and xterm, none worked. xterm works from PuTTY, so I'm guessing there's an incompatibility between at least this older version of dropbear and Tunnelier.

  5. sufrano63

    sufrano63 Network Guru Member

    You don't need to use WinSSHD if you use dd-wrt FW, just enable the sshd...... :thumbup:

    I have everything I need from my flash drive....take it everywhere I go with internet connection and instant tunnel to my home wireless and firefox auto launch from the flash drive too.... :cheering:

    I'm able to launch terminal window, sftp and remote desktop from tunnelier after a successful connection. I find it better than putty due to the fact I just click on "login" and whamo. Also profile is save on Tunnelier instead of registry

    - login using pub/priv key
    - use sftp, terminal and remote desktop
    - auto launch firefox (you have to configure)
    - securely browse the internet

    :thumbup: :thumbup:

    Try unchecking the twofish256-cbc or both twofish128-cbc in the SSH encryption and see if that work. Let me know.
  6. skipparoo

    skipparoo Network Guru Member

    Hmm okay, so xterm works for you... I'll have to try Tunnelier on one of my test units with v23 to see if the newest version of dropbear helps. Otherwise I have everything working, using either PuTTY or SSH2. I am currently using the dropbear sshd server on my WRT but I'd like to try WinSSHD on one of my PCs just to see what it's like. Bitvise seems like they've produced a pretty solid product from what I've read.

    Thanks for your all your input.

  7. sufrano63

    sufrano63 Network Guru Member

    try unchecking both twofish-cd encryption in Tunnelier and connect to see if your able to use xterm
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice