Port forwarding issues with WRT54GX and WRT55AG

Discussion in 'Cisco/Linksys Wireless Routers' started by ljacob66, Feb 10, 2005.

  1. ljacob66

    ljacob66 Guest

    Just had a really strange and difficult to pinpoint problem with a handful of Linksys routers.

    I was replacing a WRT54G which either failed, or I managed to break during the flashing process. The existing configuration was set up to forward ports 21-25, 80 and 10000 to a system on our local network handling some linux services, and we are configured with a static IP address with a domain name mapped to it. All in all, its what I would consider to be very straightforward, and things have worked solidly for several years.

    Now, I picked up a WRT54GX and installed/configured it identically. Everything seemed to be working, as our email traffic continued to map through to our linux system, and then I suddenly realized that from INSIDE our network, I was unable to communicate with our devices by going out through our router and then back in.

    IE. telnet/ftp/web services, etc all were blocked by our router - as if the ports weren't being forwarded. But, from OUTSIDE, everything appeared to be fine - the ports WERE being forwarded. I spent a good deal of time on the phone with linksys about this -- they said the router must be defective.

    So, I got another one, and also picked up a WRT55AG, just in case. Same issue with BOTH of them.

    I diddled with every security setting I could fine. Swapped DSL modems, too. And verified that our other IP address (we have a different server on a switch that shares our DSL service) handled all services fine. We tried swapping IP addresses, and eliminated every single piece of equipment on our network to replicate the problem.

    And then, last night, I bought yet another router -- a WRT54GS (just the updated version of what we initially attempted to replace, anyway) -- and lo and behold, everything worked, as normal.

    So, the only conclusion I've been able to draw, is that there is a firmware issue going on, because I find it very hard to beleive that this is an actual hardware issue, and after spending about 5 hours, diddling with router settings, going to factory default and just mapping the ports, etc I would be really surprised if this is a "user error".

    I'm posting this with the hope that someone can point me in the right direction as ultimately, we would like to be using the SRX or the AG router; of course with the less expensive WRT54GS working fine right now, I have not too much to complain about, other than the 45 minute linksys phone call and four trips to Best Buy, and still not a clue as to why things just won't work as they normally should...

    Any thoughts are appreciated!

  2. Domp

    Domp Network Guru Member

    Not quite the same but similar

    My problem with a new WRT54GX: I have a Linksys printserver hooked up directly to the router as (the router is I was able to get to the printserver just after resetting it but would loose connection after printing a page or getting to the config pages from a browser.
    However, this problem only happens when using a laptop connecting to the WRT54GX wirelessly. My other computer connected to the router through a cat5 wire is always able to get to the printserver.
    After fiddling with settings for days, I finally discoverd that turning off the CTS protection mode would make everything work. It was ON by default.

    This makes little sense but it seems to work.

    Not quite sure it's related to your problem but it sounded somewhat similar.
  3. BrooklynWalker

    BrooklynWalker Network Guru Member

    WRT54GX Port Forwarding Issue, Too

    I've noticed the same thing on a new WRT54GX. Have you also noticed that the DNS server address delivered to the router's DHCP clients is the router's IP address itself? I wonder if that's related. How about the fact that there's no WINS address option for DHCP clients?
  4. kenshell

    kenshell Network Guru Member

    I'm also having problems with port forwarding with a WRT54GX.
    I set up my ftp box the same way as used with my befsr41, wrt54GS.
    I can not connect to it.
  5. bthompso

    bthompso Guest

    Port Forwarding Issue on WRT54GS v2.0

    That's funny because I'm having the same issue with port forwarding! I had it configured and working with a WRT54G but when I replaced it with a WRT54GS v2.0 and configured it the same, it doesn't work!

    I've about given up. Internal to my network I can see my web server but I cannot access anything from outside my network. The ports are not forwarding correctly.

    Has anyone tried to fix it with 3rd party firmwares?

  6. kenshell

    kenshell Network Guru Member

    There is a firmware on the linksys page that fixed my problem.
    all is well :)


  7. KZXten

    KZXten Guest

    FYI, I have the WRT55AG and it has a NAT problem with might be what's bugging the GX version. I've spent alot of time trying to use port forwarding wiht no luck to find it was a NAT prob. I spent countless hours on the phone with the tech support and they sent a replacement which exhibited the same problems. After prodding the level 2 tech supp he pretty much said that they know there is a problem and then pushed me up to the level 3 tech in CA. I talked to the level 3 today and am now waiting for a call from RMA in an attempt to get a replacement. I was going to go for the GX but after purusing this forum for a bit I'm going to opt for the 54GS.

    After some research I found that the 55AG has been known to have NAT problems. Of course the other 'problem' that bugs me is the DHCP address lease time, 24 hrs? For me it's not enough.
  8. prankstr

    prankstr Network Guru Member

    Well folks after 4 hours of messing around with port-forwarding this WRT55AG is going back to CompUSA. Its quite obvious it doesn't work correctly - my old BEFW11S4 works great, but unfortunately the same cannot be said for this router.

    I did the Linksys Live Assistance online chat thing to see if there was a newer firmware version (mine is running v1.10). The "technical support" guy said that because I have multiple computers behind my firewall that I should be using port-triggering instead of port-forwarding - what a load of horseshit - all I want to do is simply port-forward 80 to my server running Apache webserver.

    Between this and the defective Dell 2005FPW 20.5" flatscreen I bought last week i'm ready to gouge my eyes out - do all customer service calls go straight to India these days?

    I guess I will not be buying anymore hardware from Linksys again - its a shame cause I really liked there stuff.
  9. prankstr

    prankstr Network Guru Member

    Well I didn't think I'd post again, but Linksys sent me the chat transcript of their "Online Assistance" - my advice is that you do your homework before buying one of these WRT55AG routers - if you don't need to do port-forwarding then its a good enough router

    Anyway enjoy:

    Chat Transcript 04/20/2005 03:59 PM
    Hi, my name is Blasgil T(18928). How may I help you?
    Jeff: I just purchased a WRT54AG and the port forwarding isn't working at all
    Jeff: everything else works great on it though
    Blasgil T(18928): have try doing a dmz?
    Jeff: yes, but that option will not work for me as i have multiple computers on my network
    Jeff: basically i run an apache server on one of my computers and i need to forward port 80 through
    Blasgil T(18928): Port forwarding will not work as well form multiple pc's you need to use port triggering insted
    Jeff: well basically when i port forward, anytime i try to connect on port 80 using external ip address it resolves back to which is the address for the router configuration server
    Jeff: for example, my external ip is - if i try to connect to that ip address it should port forward through to, instead it forwards me to
    Jeff: so should i get rid of my port forawrding entries and setup port-triggering?
    Blasgil T(18928): I think so Jeff
    Jeff: i used this router to replace a Linksys BEFW11S4 - the port-forwarding works fine on that router
    Blasgil T(18928): Have you already tried doing a firmware update?

    That last line must've been added after the fact to make him look good (BTW my firmware version was 1.10 - which is the newest version).
  10. unclej

    unclej LI Guru Member

    Remote administration

    I found i had the same problem with a WCG200. It would route any external traffic back to the modem. I found that disabling remote adminstration of the modem allowed the port forwarding rules to work correctly. So for now I have this disabled since i wanted port forwarding for port 80 to work correctly, and it wouldn't if remote administration was enabled.
  11. ecotrojan

    ecotrojan Network Guru Member


    In a nutshell you cant, Linksys released the WRT55AG with firmware that does not work.

    I bought a WRT55AG to replace my WRT54GS. I needed the wireless 'A' for streaming live tv from my MCE to my XBOX360 extender.

    Unfortunately, I also have 3 I.P. cams on my network that needed to be open so my family around the world can see my kids. I tried for ages and had 4 live chats with Linksys to no avail. The only way for me still to have the I.P.Cams working and the MCE / XBOX360 extender working was to connect the WRT55AG to the WRT54GS. A basic work around provided by Linksys. To be honest, the last two things I have bought from Linksys have both had faulty firmware, there R&D / testing department need a rocket up the ass.

  12. ofblong

    ofblong LI Guru Member

    Has anyone made a firmware that works with the wrt55ag? Meaning 3rd party apps. I am nervous to try one that says for the 54 as I dont want to borque up my router and have no way to connect to the internet since I exclusivly use wireless for my main computers and wired for when I have an issue I need to check on (that and the wired one is also a linux box).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice