port forwarding. Tomato v1.27WRT54GL

Discussion in 'Tomato Firmware' started by reon2, Dec 14, 2009.

  1. reon2

    reon2 Addicted to LI Member

    So I followed the instructions on their web page, which is to go to port forward and fill in the info, but it still doesn't work. It used to work fine on the original firmware but I need the QOS stuff to manage bandwidth on my network. Tomato v 1.27. Router: WRT54GL. disabled UPnP as well.
    here's some maybe relevant info:

    MAC Address: 00:11:EE:AA:67:56
    Connection Type: DHCP
    IP Address	:
    Subnet Mask:
    MTU: 1500
    Router MAC Address: 00:11:EE:AA:67:56
    Router IP Address:
    Subnet Mask:
    DHCP: - 
    Type: DHCP
    MTU: default (1500)
    Router IP:
    Static DNS:
    DHCP Server: check 
    here's the forwarding entry for utorrent on my PC:
    enabled: On
    protocol: Both
    Ext Ports: 1609
    Int Address: 
    any help is appreciated.
  2. mstombs

    mstombs Network Guru Member


    That's a local IP address, not a real external Internet one. Your 'modem' must also be a router and will also need portforwarding.
  3. reon2

    reon2 Addicted to LI Member

    checked the modem, it doesn't have any "forward" options. maybe I need to setup something on the modem, bridge perhaps? It's a motorola 2210 and I went into it but found no port forward stuff. Though after looking at it it seems I should be running in PPPOE, but I'm not so sure. Is there a guide on setting up bridge between this modem and tomato? the modem came with nothing as it replaced an older broken modem (repair guy just pulled it out and hooked it up).

    -uploaded some pics, maybe they will help, the below settings work for internet, but port forwarding doesn't.





  4. karogyoker

    karogyoker Addicted to LI Member

    check the ppp is on router option and set the user/password fields in tomato, then you can dhcp and portforward from tomato,
  5. reon2

    reon2 Addicted to LI Member

    tried your suggestion, everything seems to work in the router and modem, all the signs say "GO", but no internet. some pics of tomato below.


  6. mstombs

    mstombs Network Guru Member

    DNS server is still pointing the old modem/router config, have you ticked "Use Received DNS With Static DNS" in advanced dhcp/dns setup?
  7. ipse

    ipse LI Guru Member

    Looks like the router is set up properly (apart from the DNS bo-bo)...check the PPPoE screen on the modem, you have an option "PPPoE from router" - I take this will make the modem to work in bridge mode.
  8. reon2

    reon2 Addicted to LI Member

    the modem is set to PPPoE from router (not at the moment tho as I need to revert the settings to get on the internet to post). I can't seem to find the "Use Received DNS With Static DNS". This is what appears on that page. I assume I would have to disable the currently checked one as well?

    Okay, I got it to work. I disabled "Use internal DNS" and enabled "Use received DNS with user-entered DNS". Then I changed my routers IP to so that put my machine on Internet works fine and port forwarding finally works! Thanks for all the help guys!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice