Port forwarding Warcraft III - WRT54GL

Discussion in 'Tomato Firmware' started by eveningninja, Sep 18, 2008.

  1. eveningninja

    eveningninja Addicted to LI Member

    Back when I used the old standard Linksys router firmware, my port forwarding worked fine. But now that my brother is running Tomato on this computer, I tried port forwarding to host custom games in Warcraft III today and I failed. No one could join my game, despite me setting up what I thought to be the correct settings. Anyway, here's a screenshot of my port forwarding page:



    ---Oh, and I called my brother about it and he said that it was weird that my IP address within the LAN was he said that it shouldn't be that and that normally it would be 100, or 101, or 102, or 103, etc. He noted that I may have the wrong number or something, but I checked both the Device List on the Tomato page and my wireless card settings, and it says it was

    And yes I checked the WC3 game settings and its port is set to 6112

    Anyway, any help would be appreciated. :what:
  2. bigclaw

    bigclaw Network Guru Member

    A cursory search on the Internet yields the following recommendations for Warcraft III port forwarding:

    * Allow port 6112 TCP out
    * Allow port 6112 TCP in
    * Allow port 6113-6119 TCP out and in

    Are you sure the last one wasn't needed prior to Tomato?
  3. eveningninja

    eveningninja Addicted to LI Member

    I actually saw that too when I first began searching google and to be honest I'm not really sure what that means. How do you specify "out" and "in" ?

    I just know that I only had to set up one port and it worked. :confused:
  4. i1135t

    i1135t Network Guru Member

    As far as my understanding of how firewalls work, you only need to open the port to allow connections coming in, NOT out. If no ports are defined, Sratful Packet Inspection (SPI) Firewalls will only accept connections that were initiated internally. So in your case, you will probably need to open TCP ports 6112-6119 to so that uninitiated connections from the outside can access your computer without being dropped by the firewall.
  5. bogderpirat

    bogderpirat Network Guru Member

    first off: 6112 alone is enough for hosting games. warcraft 3 and its expansion tft do not use any other inbound ports that you would need to forward.

    - are you certain that the ip in the form is actually the one you're hosting from?
    - are you certain that there is no personal firewall (i.e. the windows one) running?
    - are you hosting games solely by creating custom games via warcraft iii, or are you utilizing a latency reducing tool, like dota client or pickup.listchecker? in that case, you'll have to forward UDP traffic as well.
  6. eveningninja

    eveningninja Addicted to LI Member

    -I'm pretty sure it is the correct IP Address, but one thing: on my wireless settings, it was telling me before that my IP was indeed the .116, but now it is telling me that my MAC Address is something that is not one of the three addresses on my Tomato DeviceList. What does that mean?

    -My firewall asked me about Warcraft III and I told it to 'unblock' so I don't think that should be a problem.

    -I'm running WC3Banlist, an application run separately from the game which is used to do things like check the latency of players who enter my game.

    Here's what I mean about the MAC Address:


    And I don't see one that matches here on the Device List:


  7. bogderpirat

    bogderpirat Network Guru Member

    interesting. wc3banlist doesn't affect the ports, so that is ruled out.

    as a test, please disable the firewall and attempt to host a game. firewalls are annoying with stuff like that.

    what does WIN+R->cmd->ipconfig /all say about your wireless MAC ("hardware address" or something like that)?
  8. bigclaw

    bigclaw Network Guru Member

    Are you sure it's not the MAC address of the wireless router? All other settings are about the current network, so it may well be displaying your router's MAC address too.
  9. eveningninja

    eveningninja Addicted to LI Member

    Damn. Well I turned off the firewall and still no success. I'm out of ideas =(

    And yeah I have no idea about what a MAC Address even means, so you're probably right bigclaw. I was just hoping to find a problem XD
  10. Mastec

    Mastec Network Guru Member

    Are you sure you're connected wirelessly to your brothers Tomato router and not a neighbors router? That would explain the mixed up MAC address.
  11. eveningninja

    eveningninja Addicted to LI Member

    Yeah I'm positive that I'm connected wirelessly to my brothers linksys.
  12. bogderpirat

    bogderpirat Network Guru Member

    looks like the router's mac is shown there, as the OUI is registered by linksys: http://standards.ieee.org/cgi-bin/ouisearch?00-21-29

    do you have any other application to test port forwarding with? like a p2p app? that might rule out the firewall as a delinquent.
  13. spliff

    spliff LI Guru Member

    You need UDP as well, change it to TCP/UDP
  14. eveningninja

    eveningninja Addicted to LI Member

    bogderpirat - I'm not really sure how to test port forwarding. I'm really quite ignorant when it comes to computer tech stuff =/

    spliff - I originally had tried "Both" but it makes no difference =/
  15. bogderpirat

    bogderpirat Network Guru Member

    wc3 does NOT use the udp protocol for multiplayer games on battle.net. unless they're hosted as a LAN-game.

    ninja: get hfs. it's a lightweight http fileserver that will require no installation, just a simple starting of the application. then go to your tomato webinterface and forward port 80 (or whatever hfs is using by default) to your computer. afterwards, direct your browser to http://<your.internet.ip>/ (get it from http://whatismyip.com/). if it displays an empty directory listing, port forwarding in general works and the firewall should not be in the way of things, if it says something like "connection refused", i would assume that your firewall is ****ing things up.

    as a test, you could also try deleting the rule that was created for warcraft iii in your firewall settings and re-create it, and be sure that it allows for inbound traffic on TCP-port 6112 to be received.

    i guess it's obvious what i'm aiming at; this shouldn't be a tomato issue, but rather something else.
  16. way2quik

    way2quik Addicted to LI Member

    I wish I could help you but I have no problem hosting a game in WC3 with port 6113.
    Perhaps try changing the port setting in Options under WC3 to 6113 and allow that port to be forwarded in the Port Forward > Basic in Tomato.
  17. eveningninja

    eveningninja Addicted to LI Member

    I see. Well, I didn't download hfs because I'm not sure that it could help me at this point. As a test I already enabled DMZ to my IP Address and also disabled my Firewall completely. And yet I still fail at hosting WC3 games. So if it's not a port issue and not a firewall issue, what else can I do?

  18. eveningninja

    eveningninja Addicted to LI Member

  19. kripz

    kripz LI Guru Member

  20. rkloost

    rkloost Addicted to LI Member

    Assigned a static ip-address to the system running warcraft III?
  21. eveningninja

    eveningninja Addicted to LI Member

    Well, I got this:
    Checking port 6112 on [my ip address]

    Error! Port 6112 does not appear to be open.

    So what does this mean? I don't see what I've done wrong. The port should be open :frown:

    Yep, my system has a static ip.

    --Any ideas? I want so badly to host games.
  22. GhaladReam

    GhaladReam Network Guru Member

    Just to test, try putting the PC you're hosting from on a DMZ. While this isn't a safe or permanent solution, as it opens every single port on that PC to the outside world. If it still doesn't work after doing this, the router may be defective. If it does work, just make sure you doisable DMZ when you're done playing, as it's not safe to have it enabled 24/7 unless you have a software firewall on that PC.
  23. eveningninja

    eveningninja Addicted to LI Member

    I did try that actually, and it still did not work. :frown:
  24. spliff

    spliff LI Guru Member

    Did you disable windows firewall or any other firewall apps on your PC?
  25. eveningninja

    eveningninja Addicted to LI Member

    Yes, I did. Nothing is working. Why is this happening?
  26. Clovenhoof

    Clovenhoof Addicted to LI Member

    Did you try this while Warcraft3 ran and a LAN game was created, waiting for other players to connect?

    By the way, some antivirus-programs also can block ports, you should try to disable that also, just for testing.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice