Port Forwarding

Discussion in 'Tomato Firmware' started by Webb1, Jan 27, 2013.

  1. Webb1

    Webb1 Serious Server Member


    I'm new.

    I have Shibby's 102-BT-VPN running nicely, but I can't get it to port forward my Synology NAS. It's set up with a static ip in the router and initially I just need one port forwarding so I can access the management UI outside the LAN. I've tried the UPnP route, but that doesn't work.

    I've tried manually configuring by adding the port, protocol, ip etc ... but this doesn't work either.

    Can anybody help please?

  2. rs232

    rs232 Network Guru Member

    Supposed you have added the default gateway (e.g. NAS can ping google.com) manual port worwarding is all you need.

    P.S. make sure the enabled flag is set when defining the port worwarding rule

    P.P.S. UPnP will not help you in this case.
  3. gfunkdave

    gfunkdave LI Guru Member

    Synology uses port 5000 for the web administration interface. Ensure that you are forwarding LAN port 5000 to the NAS in your forwarding rule.
  4. Webb1

    Webb1 Serious Server Member

    Thanks all. Everything above is done. I still can't get it to work - canyouseeme.org can't see Port 5000 (or Port 80).

    Synology set up seems fine - network is all green - internal/external gateway address fine, DDNS status normal. It should work, but doesn't.

    Any more suggestions appreciated!

  5. koitsu

    koitsu Network Guru Member

    Can you provide some screen shots of the following things:
    • Basic -> Network
    • Port Forwarding -> Basic
    Please do not hide or obfuscate any of the info shown. Also, if you have any VPN or alternate network bits set up (vlanning, two networks, etc. -- since you do mention you're using a VPN build) please disclose that setup as well.

    Unless your ISP is doing inbound filtering, I can assure you 100% the port forwarding code and underlying bits work just fine on TomatoUSB (doesn't matter what build). In every case I've seen here on the forum its been the result of someone over-complexifying their setup, an ISP doing filtering, or an ISP doing NAT.
  6. vlads

    vlads Networkin' Nut Member

    Check the NAS firewall under Control Panel - Firewall.

    Under Allow/Deny for the LAN port you either need to create an All/All/All/Allow rule or click Allow access under If no rules are matched.
  7. Webb1

    Webb1 Serious Server Member


    Thanks for your help everyone. I've managed to make some progress. Vlads, I've double-checked your suggestion on the NAS and it's correct. Koitsu- there's no alternate network bits set up as yet, this is the first real tinkering I've done. Screengrab attached of what I think should work, but doesn't.


    However, I've just discovered that when I enter the following (Port 80 also forwarded) - it does work. But is it correct that I have Port 80 forwarded here? Shouldn't it work just with 5000 open? What are the implications? Is something missing? Should Port 80 be open, or routed somewhere else?

  8. koitsu

    koitsu Network Guru Member

    Your images are broken. Please fix.
  9. eahm

    eahm LI Guru Member

    Who are you talking to? Shibby?

    Webb1, please test RAF and Toastman and let us know.
  10. koitsu

    koitsu Network Guru Member

    Webb1. Attached is a screenshot of what his post looks like.

    Attached Files:

  11. eahm

    eahm LI Guru Member

    Ohhh "these" images, I was thinking firmware images !
  12. Webb1

    Webb1 Serious Server Member

    I can't get the images to work!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice