Port Ranges won't Forward!? Help me please.

Discussion in 'HyperWRT Firmware' started by meemo, Mar 7, 2005.

  1. meemo

    meemo Network Guru Member

    Hey Guys..
    i got another problem here, after installing the newest HyperWRT 2.1b1 Firmware on my WRT54G(v2) and doing the hard reset... and reconfiguring all the settings the way i need them to be.

    Even though i type in the Port Range that is to be forwarded (Ports: 6880 - 8010) and direct it to my ip ( and make the "Tick" and the save the settings; my programs tell me that Port 8000 is not open and i get a NAT Problem under "Azureus" a P2P Prog using BitTorrent.

    Now, i dont know what else i could try to open these Ports up, cuz in addition to that i already made my ip ( the DMZ... which obviously doesnt work either.

    My last check was the one where i disabled the SPI Firewall and all filters completely... didnt help anything though.

    For all you helpers out there ;) , i am not running any software firewall at all.

    PLEASE HELP ME IF YOU CAN, cause i just dont what to do anymore.

    Thanks for reading and thanks in advance for helping my out of my misery here..

  2. sillygoose

    sillygoose Network Guru Member

    Did this work for you with a previous firmware and the only change to your configuration was the firmware upgrade?
  3. meemo

    meemo Network Guru Member

    well, before i did work! (using the original linksys firmware (v2...), but going back to it is not really an option, because with the previous firmware i had constant problems eg. disconnects, VERY slow speeds and i had to reboot the WRT54G quite a lot.

    i think what the problem there was, the low number of max connections and not having the option of increasing the max connections (which i did with the current firmware over telnet (to 4092 (works perfectly considering speeds))

    so i really hope that i can somehow solve this problem without going back to another firmware...

    apart from the firmware i didnt change the settings... (of course i did do the hard reset but i manually put the settings back to the way they were before!)
  4. sillygoose

    sillygoose Network Guru Member

    well one thing you could check is to see if the router's iptables match what you configured in the web interface. by the way are any of the ports in the range you forwarded working? you can check the iptables by telneting to the router and running "iptables -L -v" and "iptables -t nat -L -v"
  5. meemo

    meemo Network Guru Member

    thanks for all your help, it is much appreciated, but i just fixed the problem myself...

    Thing was: I accidently changed the "Frameburst" Option to "ENABLE" now, that its set to "DISABLED" it all works fine again.

    What does that Frameburst thing actually do?
  6. angeline

    angeline Guest

    I am also experiencing a similar problem with my router blocking connections at port 6881. Bittorrent keeps saying " Port 6881 is blacklisted, use another port (0.00012 seconds)"

    I've also set the port ranges to be forwarded etc directed to my ip, all of which were previously mentioned by meemo. I even checked the frameburst and that is set to disabled. (Although I guess it wouldn't be too relevant since I'm working on a D-link Hub rather than a wireles access point)

    As for the ports working in the ranges I forwarded, I'm not exactly sure if they are... that might be my problem. I don't exactly know where to open up ports in the linksys interface. I tried to do it in the access restrictions but that didn't work, and I suspect that wasn't how to open up a port.

    I've tried making my IP the DMZ as well but that doesn't work either. The only thing in the suggestions I haven't tried is the iP tables because even after much research I still can't figure out what telneting to the router means. But I'm sure my IP has access to the net at least.

    I'm using a WRT54G Firmware Version: v2.02.7

    I would appreciate any help I can get since I've been trying to make bittorrent work on this system for ages and I've only managed to make bT work when there are no routers involved.

    Thank you.
  7. sillygoose

    sillygoose Network Guru Member

    i don't think that error is caused by a problem with your router. i think you need to change the bittorrent settings so it uses different ports.
  8. meemo

    meemo Network Guru Member

    hey there,
    your BT problem is fixable in a second!
    and dont worry, it s pretty easy.

    First go to your routers interface and go to the "Applications & Gaming" section (this is where you forward ip ranges!) now type something (BT for example) in the "application" field type "6880" as start and "8010" as end. "Protocol" you can leave set to "Both".
    Now the IMPORTANT bit: you of course have to have a static ip (i suppose you do have that (NOT DHCP)); type in your ip address (mine for example is and then tick the "enable" box.

    thats it! save and close window.

    now go to your BT Client, i suppose you are using "Azureus", click on the "Tools" tab and select "Configuration" now you should see something like "Incoming TCP-Port" (in category "server") change that (usually 4 digit number) to "8000" and save.

    now it should all work.

    if you need help setting anything else up... feel free to PM me or write in this topic.

    hope i could help you,

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice