Port redirection problem

Discussion in 'Tomato Firmware' started by GhaladReam, Oct 2, 2007.

  1. GhaladReam

    GhaladReam Network Guru Member

    I recently upgraded my Tomato 1.07 WRT54GS v2.0 to 1.09. I have been having a strange problem with one of my port redirects that was not present in 1.07.

    I run an FTP server on a non-standard port, so that it doesn't get hammered. I have it set so that Tomato forwards this non-standard port to internal port 21. Up until now this hasn't been a problem. If I reboot the router it works again, but only for about an hour, then stops working. Any idea what could be causing this?
  2. GhaladReam

    GhaladReam Network Guru Member

    I cleared NVRAM and re-entered all my settings and I think that's remedied the problem.. I'll post on this thread if the problem comes up again. It's been running for several hours now.
  3. GhaladReam

    GhaladReam Network Guru Member

    Ok, so it's NOT fixed. It started happening again. Anyone have any ideas? It was working perfectly for almost a full day but when I got home from work and tried to use my FTP it wouldn't connect again. I know it's not my FTP server because I can connect to it perfectly internally.
  4. roadkill

    roadkill Super Moderator Staff Member Member

    I think you should try doing the iptables rule manually with accept instead of forward
  5. GhaladReam

    GhaladReam Network Guru Member

    How would I go about doing that?

    Also, I wonder why it does this in 1.09 but it never did in 1.07? (yes, I did try clearing NVRAM)
  6. der_Kief

    der_Kief Super Moderator Staff Member Member

    Maybe because of updated iptables 1.3.8 !

  7. GhaladReam

    GhaladReam Network Guru Member

    That's certainly possible, can anyone else confirm this problem? I'm still having it in Tomato 1.10.
  8. u3gyxap

    u3gyxap Network Guru Member

    As far I understand, there has been some changes in the Port Forwarding. Just go to to Port Forwarding --> Basic/DMZ/Triggered/uPNP, and click Save.
  9. GhaladReam

    GhaladReam Network Guru Member

    As I said, I cleared NVRAM and re-keyed all my settings, so alas, this unfortunately isn't the problem...
  10. GhaladReam

    GhaladReam Network Guru Member

    Seems to happen very randomly. Tomato was up for about 1 day and it was still working... I checked it just now and it's down again. *sigh* Any other suggestions? I don't really want to downgrade to 1.07, prior to the iptables 1.3.8 being added, which I think is the culprit.
  11. pharma

    pharma Network Guru Member

    Since this really seems to be an isolated issue, the only suggestion I can make is to shut everything down (modem, router, computer, etc...) and then restart everything up. I realize you cleared Nvram, but there was another thread here not to long ago where the individual resolved a Port Forwarding issue by using the above advice.

    Good luck ! :)
  12. GhaladReam

    GhaladReam Network Guru Member

    I tried that, again there is still a problem... I unplugged the power bar (not just switched it off) which has everything connected to it, and waited about 10 minutes before plugging back in. This isn't so much of a port FORWARDING issue as it is a port REDIRECTION issue... All my regular port forwards work flawlessly,they always have. It's when the int port is different than the ext port that this happens. It doesn't happen right away either, it takes a day or two for it to stop working, requiring me to reboot the router to start working again... Almost as if something is triggering the malfunction. What could possibly be triggering this that didn't exist in Tomato 1.07? My network configuration hasn't changed at all since this started happening.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice