Possible to debrick WRT54G V4?

Discussion in 'Cisco/Linksys Wireless Routers' started by goodluck, Jul 20, 2006.

  1. goodluck

    goodluck Guest

    My new WRT54G is bricked. Power lED is blinking and no web access. I have walked through the revival guide and tried them except JTAG. I grounded pin 16 and antenna and I can ping

    But whenever I do tftp, it says "unable to get responses from the server"

    I did "arp -d" and it says static in "arp -a".

    What esle can I do now? Desperately need help!
  2. MG_Strolch

    MG_Strolch LI Guru Member

    Hi, I have the same problem with my WRT54gs v4 after download "dd-wrt Firmware v23 SP1 wrt54gsv4" without resetting the nvram settings.

    I have boot_wait switched on, I also have a seriell console on it. The router worked with openwrt last 1/2 Jahr. What to do?

    Ping to the router ( but the other side from the router to the pc did not work, I always get no response...

    I walk through many avayable docs, but nothing works, also I can not clear the nvram from the console per Hyperterminal via "mtd erase nvram" and "nvram commit" . But I get an connection via serial console...

    The Boot-Messages mean:

    CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
    Build Date: Thu Sep 22 15:03:49 CST 2005 (root@localhost.localdomain)
    Copyright (C) 2000,2001,2002,2003 Broadcom Corporation.

    Initializing Arena
    Initializing Devices.

    No DPN
    et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    CPU type 0x29008: 200MHz
    Tota memory: 16384 KBytes

    Total memory used by CFE: 0x80300000 - 0x803A3620 (669216)
    Initialized Data: 0x80339530 - 0x8033BC40 (10000)
    BSS Area: 0x8033BC40 - 0x8033D620 (6624)
    Local Heap: 0x8033D620 - 0x803A1620 (409600)
    Stack Area: 0x803A1620 - 0x803A3620 (8192)
    Text (code) segment: 0x80300000 - 0x80339530 (234800)
    Boot area (physical): 0x003A4000 - 0x003E4000
    Relocation Factor: I:00000000 - D:00000000

    Boot version: v3.6
    The boot is CFE

    mac_init(): Find mac [00:14:BF:A5:90:3F] in location 1

    eou_key_init(): Find key pair in location 0
    The eou device id is same
    The eou public key is same
    The eou private key is same
    Device eth0: hwaddr 00-14-BF-A5-90-3F, ipaddr, mask
    gateway not set, nameserver not set
    Reading :: Failed.: Timeout occured
    Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
    Loading: .. 3732 bytes read
    Entry at 0x80001000
    Closing network.
    Starting program at 0x80001000
    CPU revision is: 00029008

    Linux version 2.4.33-pre2 (root@linux) (gcc version 4.1.0) #775 Tue May 16 20:13:17 CEST 2006

    Setting the PFC value as 0x15

    Determined physical RAM map:

    memory: 01000000 @ 00000000 (usable)

    On node 0 totalpages: 4096

    zone(0): 4096 pages.

    zone(1): 0 pages.

    zone(2): 0 pages.

    Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200

    CPU: BCM5352 rev 0 at 200 MHz

    Using 100.000 MHz high precision timer.

    Calibrating delay loop... 199.47 BogoMIPS

    Page-cache hash table entries: 4096 (order: 2, 16384 bytes)

    Checking for 'wait' instruction... unavailable.

    POSIX conformance testing by UNIFIX

    PCI: no core

    PCI: Fixing up bus 0

    Initializing RT netlink socket

    Starting kswapd

    pty: 256 Unix98 ptys configured

    Using word write method

    mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only

    ip_conntrack version 2.1 (512 buckets, 4096 max) - 336 bytes per conntrack

    ip_tables: (C) 2000-2002 Netfilter core team

    ipt_random match loaded

    netfilter PSD loaded - (c) astaro AG

    ipt_IPV4OPTSSTRIP loaded

    arp_tables: (C) 2002 David S. Miller

    ip_conntrack_rtsp v0.01 loading

    ip_nat_rtsp v0.01 loading

    VFS: Mounted root (squashfs filesystem) readonly.

    boardflags are 0x02758
    Using /lib/modules/2.4.33-pre2/switch-core.o
    Using /lib/modules/2.4.33-pre2/switch-robo.o
    Using /lib/modules/2.4.33-pre2/diag.o
    Using /lib/modules/2.4.33-pre2/wl.o
    eth1: Broadcom BCM4320 802.11 Wireless Controller

    mkdir: Cannot create directory `/var/log': File exists
    nvram_commit(): start
    nvram_commit(): end
    br0: No such device
    br0: No such device
    eth1: Argument list too long
    eth2: No such device
    eth3: No such device
    opening /tmp/udhcpd.leases
    SIOCGIFFLAGS: No such device
    SIOCGIFFLAGS: No such device
    SIOCGIFFLAGS: No such device
    SIOCGIFFLAGS: No such device
    Using /lib/modules/2.4.33-pre2/ip_conntrack_proto_gre.o
    Using /lib/modules/2.4.33-pre2/ip_nat_proto_gre.o
    Using /lib/modules/2.4.33-pre2/ip_conntrack_pptp.o
    Using /lib/modules/2.4.33-pre2/ip_nat_pptp.o
    Using /lib/modules/2.4.33-pre2/ip_conntrack_proto_gre.o
    Using /lib/modules/2.4.33-pre2/ip_nat_proto_gre.o
    Using /lib/modules/2.4.33-pre2/ip_conntrack_pptp.o
    Using /lib/modules/2.4.33-pre2/ip_nat_pptp.o
    vlan1: Setting MAC address to 00 14 bf a5 90 40.

    udhcpc (v0.9.9-pre) started
    Jan 1 00:00:12 udhcpc[173]: udhcpc (v0.9.9-pre) started

    Sending discover...
    Jan 1 00:00:12 udhcpc[173]: Sending discover...

    sh: /tmp/.rc_startup: not found
    : /etc/init.d/rcS: 4: /etc/init.d/S*: not found
    nvram_commit(): start
    umount: /tmp/smbshare: No such file or directory
    nvram was changed, needs commit, waiting 10 sec.
    nvram_commit(): end
    /etc/config/pptpd_client.startup: 14: /tmp/pptpd_client/vpn: not found
    Sending discover...
    Jan 1 00:00:19 udhcpc[173]: Sending discover...

    Sending discover...
    Jan 1 00:00:26 udhcpc[173]: Sending discover...

    nvram_commit(): start
    nvram_commit(): end

    Any Ideas? Thank a lot in advance
  3. MG_Strolch

    MG_Strolch LI Guru Member

    after several tryouts to erase nvram via console and resetting by button on backside I can't connect. But...

    I use WinXP and some LAN-Tools for Firewalling and VPN. So I can ping from pc to router, but backwards, no change. The tftp-upload get always an timout. So I restartet the Computer, disallow all Networktools stating and e voila, i can connect to the router without any problems, webinterface etc.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice