PPoA on WRT54GS?

Discussion in 'Cisco/Linksys Wireless Routers' started by SteveD1, Sep 4, 2005.

  1. SteveD1

    SteveD1 Network Guru Member

    Does anyone know if it is possible using a nw version of firmware or some particular configuration to connect using PPoA? The configuration possibiliies in the router only seem to have PPoE.
  2. DocLarge

    DocLarge Super Moderator Staff Member Member

    You're going to need to get an ADSL ethernet router in order to use the WRT54GS (which is an ethernet router).

    Look at the "x-modem ce" from http://www.adslnation.com; also Dlink has a couple that might still be in production:

    - DSL-300G
    - DSL-300T

    Broadband buyer is also a good place to find these if they're in stock.

  3. SteveD1

    SteveD1 Network Guru Member

    Thanks for the response. You probably meant to say that I need to get a DSL ethernet modem to connect to the DSL line to use the WRT54GS router. I already have that and of course I would not be able to connect otherwise.

    My DSL provider uses the PPoA protocol and I initially was able to connect using a Dlink 300G+ - limking that to the DSL connection and then connecting through using the WRT54GS Router but configured as PPoE since the WRT54GS does not support PPoA!

    It all worked until I tried to upgrade the modem with a Linksys ADSL2MUE modem. Now it does not link through - either with the Linksys modem or with my original DLink modem.

    I know the modem is connecting to the Internet through the DSL cause it all works if I have a computer directly connected to the ethernet cable from the modem.

    And I have a good connection between the WRT54GS Router and the the wifi equipped computers.

    The modem and the router just don't seem to talk to each other - and I suspect (rightly or wrongly) it may be connected to the router not supporting the PPoA protocol.

    Any suggestions or ideas? Any one else have any thoughts?
  4. DocLarge

    DocLarge Super Moderator Staff Member Member

    Oooops, my bad :) Thought you were posting from another machine, hence the your original question.

    I had an ADSL2MUE I gave away because of the problem you're having. What you probably didn't find out until the last minute (like I did) is that the ADSL2MUE is the "lowest" modem/router combination that Linksys sells and is "not" the pure modem it's advertised as being. Think of it as the WAG54G's little brother (still has some growing to do). It has no firewall and no port forwarding capabilities. If you wanted to use it in your existing configuration "as it is," you'd need to use your WRT as an access point. However, there is the commando approach...

    My man, you are "sooo" in luck. I just met a guy who showed me this workaround using the ADSL2MUE the other day and he uses it in a production environment. It's highly irregular but it might work for you also.

    Set your ADSL2ME for "bridged mode;" this, as you know forwards all PPPoA communications to the device behind it. Next, run some straightthru CAT 5 from one of the modem's LAN port to the WAN port of your WRT54GS. Then, set your WRT54GS to PPPoE. Now, use your PPPoA credentials (username/password/modem settings) on the WRT54GS and this "should" get everything going.

    Again, this is "so not proper" meaning no guarantees, but it worked for him. Give it a shot.

  5. SteveD1

    SteveD1 Network Guru Member

    Thanks Doc for the prompt and hopeful response. I am out the door in a moment for a two day trip but I will try your suggested course of action as soon as I get back - and it sounds as if it should work. Thanks again. - Steve
  6. SteveD1

    SteveD1 Network Guru Member

    Thanks Doc so much. That "fix" did it and I am a happy camper again with my 8MB speed Wireless Lan up and thriving again. Thanks again!
  7. beagleboy

    beagleboy Network Guru Member

    I also have a D-link and had this problem, I set the "faux modem" (it is actually a router and that is why it has problems) to half-bridge and this passes control over to the router and everything works beautiful.

  8. derchris

    derchris Network Guru Member


    I'm going to buy the ADSL2MUE, and I also have PPPoA.
    If I set the modem to bridge, and use my ISP Login on the WRT,
    then everything like Port Forwarding is handled by the WRT.
    Does this work for every PPPoA Internet Connection ?
  9. derchris

    derchris Network Guru Member

    Ok, got it working, :cheering:
    but you have to select LLC for Multiplexing,
    at least for me
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice