PPPoE disconnect issues. Roaring penguin?

Discussion in 'Cisco/Linksys Wireless Routers' started by jccollet, Jul 9, 2004.

  1. jccollet

    jccollet Guest


    I keep having these disconnect issues with my WRT54G. It happens after a while (several hours usually), but when it happens it can take many many attempts before it can reconnect. I would regularly get the "Can not get a IP address from PPPoE server" error message. A complete reset (long power down) would usually fix this.I have tried a few different firmwares both from Linksys (up to 2.02.7) & sveasoft (including the latest Satori 4.0) but to no avail.
    I suspect a memory leak, or something similar, in the PPPoE code, but it's hard to tell. I thought the latest firmware from sveasoft (Satori 4.0) was supposed to include the "roaring penguin" implementation of PPPoE, but it's not mentioned in the release notes.
    Would anybody know about that kind of issues? Or have any suggestions (I have tried 1000s of things)?

    Thanks in advance,
  2. kennz

    kennz Network Guru Member

    check with your isp what is their pppoe implementation . Possible problem that the router is dialing up to fast when the router is idle. it could also be an inplementation on the isp side. regarding roaring pengiun no idea with that matter.
  3. gongo

    gongo Network Guru Member


    I have similar problems with my WRT54G 3.1 with 4.00.7 firmware. If you find a solution, let me know.
  4. snowgoose

    snowgoose Network Guru Member

    Sudden PPPOE disconnections

    I have similar problems with my WRT54G 2.2 with 4.00.7 firmware.
    It disconnects even when simply browsing (no P2P or any other high throughput client).
    Its seems like this problem is related to the 4.00.7 firmware, cause its happened since I have upgraded to it...
  5. gongo

    gongo Network Guru Member


    I've had nothing but problems with this device. Its going back...things should work straight out of the box, and not have these problems.
  6. snowgoose

    snowgoose Network Guru Member

    Random PPPoE disconnects

    I found out that my ISP requires that the login will be using PPPoA and not PPPoE. I used the WRT54G PPPoE to connect to the ISP but this connection was dropped after a few minutes. Fortunately my ADSL modem has the capability of PPPoE, so I am using it in order to create the WAN (internet) connection and the WRT54G is using static IP in the subnet of the ADSL modem.

    That solved my problem, hope it will help others with this problem.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice