PPPoE Problem with RV042?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by leebob, May 16, 2007.

  1. leebob

    leebob LI Guru Member

    I have an interesting problem that is apparently well documented, but with no resolution... I have 2 clients whom I installed the RV042 for with firmware on the Linksys production site. Both clients use a local carrier's ADSL connection (BellSouth, now ATT). Both are experiencing strange website anomalies like timeouts, certain functions that do not work, failed uploads, webmail logins not working, etc. It does not affect ALL sites, only some. After pulling my hair out, I searched the web and found the below write-up. Albeit old, it describes the exact same problem to a T with the PPPoE client in the WRT54G router. I am wondering if anyone out there has seen this issue and can confirm the problem/or suggest things to remedy it? MTU has 0 effect. Plugging directly into the DSL modem works great, DMZ does NOT work, Firewall Off does not work. Replacing the router with a ProSafe Netgear works like a champ. I am partial to the Linksys for features, etc. but if I cannot get past this, I don't have many options in this price range...

    Here is the link with the same description:

  2. aviegas

    aviegas Network Guru Member

    I know you have ruled out MTU, but it smells like it. So, just for the sake of it, what MTU settings have you tried? Have you tried going down from 1500 in -4 decrements (1496, 1492, 1488,...) and see what happens?

    Also, you have one WAN on ATT DSL. What about the other WAN port? What's the dual-wan mode setting (smart link or load balance)?
    If you have just one WAN, try changing the dual-wan mode.
  3. leebob

    leebob LI Guru Member

    I'm going to ping -l once again to be sure I have the right MTU setting, but last try was 1492. What is puzzling is that the Netgear works out of the box with an MTU of 1500(default). There looks like something in the code causing the problem. I have it in Smartlink Mode. The second WAN port is disabled. I did not try switching them. Will let you know shortly... Thanks for the post.
  4. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    What modem are you using? Are you use it's not already doing the PPPoE for you? All my clients that have DSL at their location..I always always always change the "modem" that they are given..into pure bridged mode, so it's really only being just a plain modem. Many ISPs are shipping devices which are combo modem/routers...(brouters)...they do the PPPoE, NAT, etc. Most can be reconfigured to pure bridged mode so you can use your own router.
  5. leebob

    leebob LI Guru Member

    brand new netopia dsl modem. no dhcp, configured for bridged mode. router has to be configured for pppoe to obtain ip and authenticate to network.
  6. aviegas

    aviegas Network Guru Member

    I'm puzzled that the Netgear can work with 1500 bytes MTU. Usually there is a packet size degradation with PPoE (normally 4 bytes, down to 1496).

    Have you checked the dual WAN mode?
  7. leebob

    leebob LI Guru Member

    So far MTU of 1472 seems to be working, I'l know more on Monday when the office gets back in... What is odd with this is A) I did not set an MTU on the NEtgear and it defaults to 1500 with no issues. B) The MTU fragments at 1474, but not at 1472, but if you add the 28 bytes back from ICMP and overhead, you get 1500... In any event, if this works, I'll take it. Thanks for the advice to look there Aviegas... I'll report back more soon.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice