PPTP -> PPPoA Relay Problems

Discussion in 'Tomato Firmware' started by KevindB, Mar 7, 2008.

  1. KevindB

    KevindB LI Guru Member


    This is a long story so bear with me. I've been running Tomato on a WRT54Gv3.1 for a little while now, longer than I thought (since v1.07) and have been extremely happy with it (understatement) This is where it goes wrong: In order to save a bit of cash I 'upgraded' my account with Tiscali to include 8MB ADSL and 'free phone calls'. Little did I know, but at the very least this involves Local Loop unbundling.....which happened on Monday 3rd March.

    Since then, my internet connection plays dead every 45 minutes. Config is WRT54Gv3.1 ( local, WAN) -> PPTP -> (WAN Speedtouch 510v4. This configuration with various WRT54G clients (Linksys, DD-WRT, Tomato) has been working fine. The speedtouch modem is configured with a reverse IP route from 10.0.0.X to 192.168.1.X so that I can use the modem's management interface from the LAN side. The PPTP connection within Tomato is configured to connect on demand with an idle drop of 1440 minutes. I've tried changing this to keepalive at 30second intervals with no change in outcome.

    Symptoms of the 'playing deadness' are no pings to internet addresses, but pings to modem WAN address okay. Checking the modem interface shows the PPTP->PPPoA relay service up & running & in 'connected' state. ATM modem loopbacks are okay and all the modem status info says the ADSL line itself is running & stable.

    I've tried connecting the modem directly to a WinXP PC and using the Microsoft VPN client to establish a PPTP -> PPPoA relay connection via the modem. This works correctly but ALSO suffers from the 45 minute 'drop off'. No errors, no logs, just stops working.

    Dropping the PPTP connection & re-establishing brings everything up fine, but obviously with a different WAN side IP address.

    In desperation (and boy was I desperate) I bought a Belkin N1 ADSL modem router at considerable expense but much reduced functionality. This establishes and maintains the internet connection (using built-in ADSL modem & PPPoA) without problem. There is a small clue in it's logs as to what might be going on.... every 45 minutes there is an entry "ATM1 get IP:" - it's like a DHCP address renewal.

    Being so unimpressed by the Belkin's ability to do simple things like act as a DNS server for additional LAN addresses (it doesn't even serve addresses it's handed out via DHCP!) I was keen to get the WRT54G up and running. I've failed but have turned up something odd:

    1) Tomato 1.13 & 1.17 - fail
    2) HyperWRT Tofu - fail
    3) DD-WRT v23 & 24 - fail

    4) Linksys 4.20.8 - WORKS - worked solid overnight. Only sad bit is that functionality is not that much better than the belkin.

    It looks and smells like a DHCP renewal issue on the WAN side IP address but without a LAN sniffer I'm a bit helpless. I wish also there were some log entries to go on, I've bumped up the logging level on Tomato but still no clues. I'd love to debug this some more but I've hit my limits. Anyone help?

    Kind regards,

  2. bigclaw

    bigclaw Network Guru Member

    Hope you resolve the issue eventually. In the meantime, you can connect your WRT54G to the Belkin router and let the latter just be the Internet connection. All your client PCs can still connect to the WRT54G, which retains all custom functionality.
  3. KevindB

    KevindB LI Guru Member

    Indeed. As a workaround I've turned off the WRT54 WAN interface, set the Belkin to and put that on the LAN subnet, then changed the WRT54's default router to So I have DNS/DHCP/Wireless handled by the WRT, with the belkin acting as default router out to the internet via PPPoA ADSL. Convoluted but it avoids double NAT problems.
  4. bigclaw

    bigclaw Network Guru Member

    If you can return the Belkin N1 ADSL modem router and pick up another WRT54G (I would buy a GL just to be flexible), you can save your "considerable expense" by letting the new WRT54G run the Linksys firmware and the old one handle everything else.

    Also, you can try talking to the Tomato author, and he may be interested in "fixing" the problem the proper way (maybe as simple as a quick diff between his code base and the Linksys code base.) I assume his code is based on the Linksys one anyway...
  5. TerminatorHTK

    TerminatorHTK LI Guru Member

  6. KevindB

    KevindB LI Guru Member

    There is no error message, that's the frustrating thing...it's an ill-educated guess based on seeing a repeating entry (every 45minutes) in the Belkin's log.

    I've tried the 'reduce packet size' option, no dice. I've been through so many different versions of firmware trying to find a working version that has suitable features it's a wonder I haven't bricked the router :)
  7. KevindB

    KevindB LI Guru Member

    The 'difference in code base' was why I thought if I went back far enough/try enough versions I'd find one that hadn't lost the Linksys 4.20.8 PPTP WAN behaviour, sadly no such luck. The one consolation is that official firmware DOES work okay, so it must be possible to fix. Any ideas how I contact Jonathan?

    Thanks to everyone responding so far to this little mystery!
  8. LLigetfa

    LLigetfa LI Guru Member

  9. KevindB

    KevindB LI Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice