PPTP to PPPoA Relay

Discussion in 'Cisco/Linksys Wireless Routers' started by humsafar, Apr 1, 2005.

  1. humsafar

    humsafar Network Guru Member


    I have a Speed Touch Home Alcatel modem that has been firmware moded to be a Spped Touch Pro. I used to have this setup with a PPTP relay. Connected to this was the RED interface of my IPCoP box. I set the IPCoP box's wan (RED Intergace connected directly to Speed Touch) an IP in the same subnet as the Speed Touch say the speedtouch was Using the PPTP dialup on the IPcop i setup my username and password in chap mode with and set the server as, so it would try to make a connection to PPTP to the sppedtouch and it would relay to my ISP, essentaly this creates a PPPoA connection. The benifit of this is that you MTU is 1500 and need not change from default on any PC. The connection is also more stable than on PPPoE. Also Instead of the IPCop box i can use any windows XP pc with IP set to and create a VPN PPTP connection to with my isp credentials and get a PPPoA connection.

    Ok my problem now is that with the WRT54G i have been unable to do this.
    To achive this i would need to be able to set the WAN IP and have the PPTP client on the router make a connection to However this does not seem to be possible. Can anyone suggest me a way to do this. I am currently using Satori firmware on ver 2 router. Thinking of switching to DD-WRT because the developer is more accesable and due to other issues i have posted in my "Satori to DD-WRT" post.

    Thanks in advance..
  2. humsafar

    humsafar Network Guru Member

    <<Bump to top>>

    Can anyone help me with this?

    1. I need basically a way to set the WAN IP to
    2. Run a PPTP client on the WRT54G to VPN to (my modem) which will relay connection to the ISP. The login information is as supplied by ISP the modem relays this on, pptp client needs to support CHAP.

    I have tried to use PPTP mode in the router and set the IP to, however there is nowhere i can place my modem's ip as the box to connect to. I tried making it the gateway but still no luck. Can anyone help??

  3. humsafar

    humsafar Network Guru Member

    Ok fixed it myself..
    Upgraded to HyperWRT 2.21b and the PPTP works. It looks like it is broken under Satori.

    My modem is set to act as a relay for PPTP, this essentially gives me a PPPoA link. I set the WRT54G with PPTP IP set the gateway as and it works now. It did not under Satori..

    One thing though with IPCoP my MTU would remain as 1500 with HyperWrt i seem to get 1460 as the MTU this is Auto set as otherwise pptp does not work. 1500 means i dont have to lower MTU on the other devices on the network. Does anyone know why this is ocuring. Or is this normal.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice