Print Server Fails to connect to PC with static address

Discussion in 'Other Linksys Equipment' started by TundraDome, Oct 25, 2004.

  1. TundraDome

    TundraDome Network Guru Member

    Hi. I request your help with this issue:

    I have a Linksys wireless router (BEFW11S4.V2 ) and wireless print server (WPS54GU2) and ADSL internet service. I have two laptops (home and work) that both connect wireless via 802.11b cards to the router. The wireless print server has a USB hard wire connection to my laser printer (HP LaserJet 3330 Series). I installed the wireless print driver only on the home computer - only the home laptop can print wirelessly.

    In the past, I had all addresses assigned by the router through DCHP; and everything worked flawlessly. Then I got creative: Decided I wanted to maybe run a "mini server" from my laptop and, more importantly, be able to connect to my laptop via Remote Desktop Connection.

    I created a static address for my home laptop and port forwarded the appropriate ports to enable the the web server and RDP connections from remote computers, through my gateway, routed to my home laptop. The good news is that I can, now, establish a Remote Desktop Connection and access my home computer from the office. The webserver works as well (I chose a dynamic Domain Naming Service that provides me a virtual "static" IP address (I have a dynamic IP address) to the internet - works great.

    The Issue
    The home laptop can no longer wirelessly print. I get a "print server failed to connect" message. I figured my new static IP address somehow conflicts with the IP address of the wireless print server. So, I reset the printserver (defaulted everything back to factory settings), and re-configured the print server. When I run the Print Server Utility to set up a printer port, I receive the following message:

    Device not found. Please check:
    1. Connections (power cord, ethernet cable, printer cable)
    2. The Print Server and your PC are the same LAN segment and have compatible IP address.

    After ensuring "1." was not the issue, I focused on "2." I don't pretend to understand what "2" is telling me, but I tried the following: I configured my print server to obtain an IP address using DCHP - ran Print Server Utility - same error message as above. Then I tried assigning different static IP addresses to the print server, ran Print Server Utility - same error message as above.

    Current IP Adresses
    Linksys Router IP address =
    Static IP Address assigned to laptop =
    Starting Address for DCHP IP address assignments =

    I tired print server static IP addresses of 192.168.1.X (X=151, 159, 170)
    The DCHP approach assigns the printer server an IP address of Nothing seems to work - I get the error message indicated above.

    Thanks for your help.

    -- TundraDome
  2. SimonMackay

    SimonMackay Network Guru Member

    The first thing I would do is to ping the wireless print server from the home laptop. This can prove whether the server really exists on the network. You could also type "arp -a" in order to see whether the print server is still part of the network. If these TCP/IP tests determine that the print server exists on the network, you would have to restart the print server driver software so that it works properly on a higher level.

    With regards,

    Simon Mackay
  3. TundraDome

    TundraDome Network Guru Member

    Thanks for the advice . . . I did the arp -a command, and this was the response:

    Interface: --- 0x3 [static IP address of laptop]
    Internet Address [/] Physcial Address [/] [MAC address of Router (i.e. 00-06- . . . .)] [/] [MAC address of wireless print server (i.e. 00-0c- . . .)]

    [data in brackets are my comments]

    It appears that my print server is on the LAN network. How do I restart the print server driver software so that it works properly on a higher level? Thanks for hour help.

    P.S. I also pinged (print server address) and the ping "timed out."

    -- TundraDome
  4. SimonMackay

    SimonMackay Network Guru Member


    You may need to uninstall and reinstall the driver because there doesn't seem to be any "restart" option available to it. OTOH, try to reconfigure it.

    It also may be worth seeing whether you can gain access to the print server's Web interface to determine whether that aspect will work.

    With regards,

    Simon Mackay
  5. TundraDome

    TundraDome Network Guru Member

    I will try reinstalling the driver tonight . . . .

    -- TundraDome
  6. TundraDome

    TundraDome Network Guru Member

    O.K. . . . we achieved *Success!* :D

    Here's how:
    1. I uninstalled the printer driver, and rebooted the laptop

    2. I reinstalled the printer driver, (I believe that was a good call Simon MacKay . . . thanks for that tip)

    3. And this is important: While the laptop can wirelessly connect to the router and configure the printer server using the Print Server Install CD, (remember the print server is connected via hard-wire to the router for the purposes of installation/configuration), this same setup will not allow one to retrieve the port information when you run the print server driver setup utility. The first time I did step 4 below, I received the error message stated above in this thread.

    Then, with nothing to lose, I connected my laptop via hard-wire ethernet to the router . . .

    4. Ran the printer server driver setup utility - and sure enough, wait . . .wait . . . wait . . . and just as I think I will get the error message, "bam," I get two ports (Port 1 - no printer, Port 2 - HP LaserJet 3330) (again, only after I hard-wire connected my laptop to the router). selected Port-2 - LaserJet 3330, and clicked "next" to complete one more step. . . exit the utility.

    5. With my laptop still ethernet hardwired to the router, and the print server also still hard-wired to the router, I open IE enter the IP address for the printer, and the web configuration utility opens. I ensured that WEP security settings for the print server matched my network, but still the WLAN LED on the print server was not lit (indicating the print server was not wirlessly connected to the network). So, I re-entered the settings using web based utility (remember, I had already entered them via the installation CD). I click "save" to re-save the same settings, and I receive the message, "Changes Successful. Your changes will be applied after you reboot the device."

    Hmm. I disconnect all hard-wire ethernet connections from the router to the Print Server and from the router to the Laptop. To "reboot the device," I disconnect the DC power cord from the back of the print server . . . wait a few seconds, Plug back in . . . wait ten seconds, Still no WLAN Light. Perhaps a few seconds is not enough for a hard reboot. Then, I unplug the Print Server Power Adapter, wait about 20 seconds, and then plug the adapter back into the surger protector. After a few seconds, presto, the WLAN LED on the print server is lit, and we're in business. :wink:

    -- TundraDome
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice