Printserver won't take static IP address

Discussion in 'Networking Issues' started by serpico, Mar 17, 2006.

  1. serpico

    serpico Network Guru Member

    1. wireless router: Linksys WRT54G v.4, Firmware Version: v4.20.6 (2005-05-26)
    2. wireless printserver: D-Link DP-G321, Firmware Version: 2.00 (2005-06-27)

    Intranet settings:
    1. default gateway (router address):; subnet mask:
    2. DHCP server enabled, IP address range: -
    3. The printserver firmware allows me to assign the printserver static IP address (static IP addressing is needed to make printing easy). This used to work fine - and the router would show that the print server (identifiable by name and MAC ID) was indeed assigned the requested IP address, even though the requested IP address was within the range used by the DHCP server. The 3 other devices on the network are all automatically assigned IP addresses.

    Now however, the printserver is no longer being assigned the requested IP address. I.e., the manual assignment setting is requesting, but the router shows that the printserver has been assigned This also happens if the requested IP address is outside the DHCP address range - i.e., the static IP requested is 1.110, the printserver gets assigned an address inside the DHCP range, e.g., 1.3.

    In fact, if I type in the URL, the printserver home page appears. Since the printserver thinks it has been manually assigned 1.20, but in fact has been assigned 1.3, it no longer allows me to print.

    I have tried changing the manually assigned IP address to no avail. For example, if I change the manually assigned IP address to 1.3 and reset the printserver, it now thinks it has been assigned 1.3, but the router shows that the printserver has been assigned 1.5 (my computer was sitting at 1.4, so presumably that's why it jumped over 1.4). If I then change the manually assigned address to 1.5, the actual address assigned by the router becomes 1.6.

    Why is the Linksys router not assigning the static IP address requested by the printserver? Any thoughts or suggestions?

    I emailed Linksys about this 2 days ago, but no response as of yet.
  2. bluebox

    bluebox Network Guru Member

    Understanding why this statement is wrong may help you. If you set a device to have a static IP address, your DHCP server plays no roll whatsoever in allowing/knowing/assigning/etc the IP address of your staticly configured device. When you set a device statically it is set for that IP address regardless of other devices on the network, including the DHCP server.

    So, knowing that, I believe that the "blame" likes squarely on the printserver. Either the manufacturer has a setitting in there that allows DHCP to override static settings, or the thing is broken. My money is on the first one because it's a hell of a longshot that when a network devivce breaks, it's gonna break in this sort of way.

    Now I know your next question is "why did it work before then?" And I think this would be the second thing that would commonly send someone down the wrong troubleshooting path. In fact I wouldn't let it working before figure into your troubleshooting at all. Misconfigured network devices can frequently appear to work properly one day, and crap out the next with no obviously apparent changes in configuration.

    I'd start looking into the documentation for the printserver to find out if there is a setting that allows dynamic (aka DHCP) to override static settings. That's where my money is.

    PS - You should set it outside the dynamic range of your DHCP server. This almost never actually matters these days, but it does allow the potential that something else could be assigned the same IP address.
  3. serpico

    serpico Network Guru Member

    I agree with your assessment. I am able to assign a static IP address to my pc with no problems.

    Yes, the printserver is set to a static IP address outside the DHCP server's range of addresses. But it continues to get a dynamically assigned address within the DHCP server's range.

    No, there is no setting that is designed to override dynamic addressing. In fact, there is a radio box where one chooses either manual (plus fields to specify IP address, subnet mask and gateway) or auto addressing.

    Still no email response from D-Link.
  4. serpico

    serpico Network Guru Member

    Mark, you were exactly on point. The factory default UPnP setting is Enabled. I switched to Disabled, rebooted the printserver, and presto, it gets a static IP address. Why this is, I have no clue - but that's because I have no idea what UPnP is supposed to do. This is especially strange because I never changed this setting from the factory default when I first got the device, but it worked fine for a while. Per your point, I'm not going to waste time pondering this particular issue.

    Of course, D-Link's manual (the full pdf manual, not just the "quick start" guide) never mentions this setting, not even under the section that tells users to manually assign an IP address to the printserver.

    And 72 hours later, still no response from D-Link. Good device, but terrible documentation and customer support.

    Thanks to Mark, and if there's any way to give you rep points, let me know - you deserve it.
  5. bluebox

    bluebox Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice